Jump to content

Silent .NET Maker (latest update: 20080603)


Recommended Posts

Hi TC,

Just downloaded the program and followed the instructions. Worked great! When added to HFSLIP build everything ran fine and installed (used option 13). Got one error message in the XP Pro SP2 event log though:


.NET Runtime Optimization Service (clr_optimization_v2.0.50727_32) - Service reached limit of transient errors. Will shut down. Last error returned from Service Manager: 0x800736b1

Normally there is a long list of optimization events. The service seems to be running fine and flags no errors. Has anyone run into this before? Is there a way to verify everything is OK. Thanks!

Link to comment
Share on other sites

Hello. Because the problem is brought up for a moment when I am using SNM this

time, it reports.

It seems not to be likely to be able to complete operation correctly by combining applied hotfix. KB928366 and KB927495 cannot be applied at the same time in my hand. Even if the file name is changed, the order of the operating system's retrieving the file is changed, and which hotfix is applied previously, it seems not to be able to evade. Is there a combination of such hotfix ..the other..?The appearing dialog is the following. 「It is information 9005.

Hotfix KB927495 need not be installed. Hotfix KB928366 including the up-to-date file has already been installed. 」

Link to comment
Share on other sites


KB928365 replaces the other .NET 2.0 updates. I checked the binaries inside. I'll update the instructions in the main post.


I have never experienced that error message (even with other programs) and haven't got a clue what it means.

Do you also get it when installing DNF30.exe by hand after Windows setup has completed?


To be honest, those Event Log errors have always appeared for me when installing .NET 2.0 at T-13 -- even using others' silent .NET installers.

Link to comment
Share on other sites

The problem was this...


Have no idea where I got this file! Anyway, executing this file on its own causes the error.

Edited by zedox
Link to comment
Share on other sites

I guess I should update the info in the main thread. DNF30.exe force-installs this program (the original in .NET 3.0 or the updated version) from a batch file, which probably explains why you don't get that error message when you install .NET 3.0 normally.

Link to comment
Share on other sites

  • 2 weeks later...

hi there,

eheh again me :D

anyway i use to install the net frameworks only because i need to use the visual studio...

now visual studio 2008 pro as been released and it needs the net framework 3.5 beta 2....

i tryed to use the microsoft net 3.5 downloader because i couldn t find the net framework 3.5 beta 2 as a full installer....

now i used this with win xp without the net frameworks installed (eheh i use your 3 frameworks :whistle: ) for to see wich frameworks are really needed for it. now after the download i find only the net framework 2.0 (23 mb) , dotnetfx30 (29.3 mb) and the dotnetfx35 (6.4 mb) with the lang pack (44 kb)... O.o, now their size are really strange while your:

net framework 2.0 is about 39.8 mb

net framework 3.0 is about 25.9 mb

now your script also include the hotfix and langpack, but it seems their are also included in this download (maybe yout script include also the installer for x64, in this download there are only installer for x86).

Then in this download there is not the framework 1.1 (and now i m thinking that it is useless)

But the real problem is, after installing the net 1.1 - 2.0 and the 3.0 of your script i finally run the net framework 3.5 just downloaded and an it says that it is needed the net framework 3.0 sp1 O_O (i didnt find it on the web)

Now can you explain what the hell it s happening? O.o

Anyway this post must be sticked because is really usefull, and i hope that you will contuinue you wonderfull work including the net framework 3.5 in your script :thumbup

Thanks so much for this and for your great answer about the directx :thumbup

p.s: here there are the images with the contents of the download:

General Folder

dotnetfx 2.0

dotnetfx 3.0

dotnetfx 3.5

Edited by darafat
Link to comment
Share on other sites

Tomcat76, I understand that the 7zS.sfx file has been compressed using UPX. I have tried to change icons of the resulting .NET installers to use the same icon as "ndpsetup" (.ico file attached) using reshack and it fails. I believe it is failing due to the fact that your 7zS.sfx file has been compressed. I have tested reshacking the 7zS.sfx file that comes with 7z and it works fine with your .NET installers - its just not compressed.

I read the 7z help file that indicates that UPX can compress 7zS.sfx files, so I tinkered with UPX - way cool! Executing UPX --help in a command window reveals all its secrets. bottomline is that you drop an sfx file into the same folder as UPX and from a command window you execute UPX --best --ultra-brute file.sfx and voila, it compresses all the pieces it can and leaves you with a compressed version of the same file written over the existing one.

so I took the standard 7zS.sfx file that comes with 7z, res-hacked it to use the icon file (attached), compressed it with UPX and used this instead - works perfectly (so I attached this too!). then out of curiosity, I compressed the standard 7zS.sfx file as it stood and it compressed to something slightly smaller that what you have currently packaged up (so I attached this too!). finally, I took the enhanced sfx files from http://unattended.solta.ru/unattended.en.htm, res-hacked the uncompressed 7zS only file and compressed it as well (also attached).

So, in the end, thank you for putting together these .NET installers (I haven't tried .NET 3.0 but i'll get to it). In return, I have attached some more colorful SFX files and the .NET icon file for anyone to use.


Edited by bigfatroundguy
Link to comment
Share on other sites


installing the visual studio 2008 i saw more fromeworks... lol

It will be a great thing to make unattended this stuff:

.NET Framework 1.1 (already included in your script)

.NET Framework 2.0 (already included in your script)

.NET Framework 3.0 (already included in your script)

Adding this stuff:

.NET Framework 3.0 Service Pack 1

.NET Framework 3.5

.NET Compact Framework 2.0

.NET Compact Framework 3.5

Eheh, i m asking too much :whistle:

If it is not enought for you, you can make this stuff for x86 and x64 (priority at the x86 lol)

p.s: it was only an idea, not a request. just because i think that the net frameworks are basically for developers :)

Link to comment
Share on other sites

HI :)

How can i do if DNF3.0 gets Installed after the first login.

I have put in nLite under Unattended->RunOnce:


But it gets not Installed after the first login. :(

Edited by Outbreaker
Link to comment
Share on other sites

I've used Silent .NET Maker to pack Microsoft .NET Framework 1.1, 2.0 and 3.0 to use with HFSLIP 1.6.2. I placed all three files (DNF11.exe, DNF20.exe and DNF30.exe) in my HFSVCPACK folder. The installation of Microsoft Windows XP Professional with Service Pack 2 goes fine until the T-13 mark. Microsoft .NET Framework 1.1 is installing fine, followed by 2.0, however once installing Microsoft .NET Framework 3.0 it returns an error code:

Windows Communication Foundation -- Error 1304.Error writing to file: Microsoft.Transactions.Bridge.dll. Verify that you have access to that directory.

There is already a topic regarding this error message, but it concerns the above error code when you install Microsoft .NET Framework 3.0 via RunOnceEx.

What can I do to solve this problem and have it properly install at the T-13 mark as both Microsoft .NET Framework 1.1 and 2.0 do?

Link to comment
Share on other sites

Doing it differently now. I've used Silent .NET Maker to pack Microsoft .NET Framework 1.1 and 3.0 into only one file. I will use HFSLIP later on today to cook up a new image after which I will test it. Crossing my fingers... ;)

Link to comment
Share on other sites

  • 2 weeks later...

I bump this topic because after several days of researching and tests I've figured out that repair ability for .NET 2.0 is not working well in your .NET Maker ONLY if you slipstream the KB928365 patch, and I think it's virtually impossible to workaround this in any way.

Do the test yourself:

Try to delete the following file:

%WinDir%\Microsoft.NET\Framework\v2.0.50727\AppLaunch.exe . This file is marked with the following version string:


Now, go to Control Panel > Add or Remove Programs and click the "Modify/Repair" button for the "Microsoft .NET 2.0 Framework" entry. The setup program appears. Select the "Repair" option and click Next. Repair process will take place. When repairing is complete, go to the previous directory:

%WinDir%\Microsoft.NET\Framework\v2.0.50727\ , and show the properties for file AppLaunch.exe. You will see that the string version is the following:


That is, the original version shipped with .NET Framework 2.0 (not the patched one included in KB928365). The repair process restores the original version of .NET Framework files, not the patched version (with KB928365 applied).

The reason is simple: The hack you said me modifying the PackageCode value in the Registry is necessary in order to Setup can work with the original database of .NET Framework 2, since performing and administrative install of the product modifies the PackageCode in the administrative image. Due to this, Setup always use the original database to repair missing or damaged files.

Now, I see why RyanVM removes the repair ability (source cache feature) of .NET Framework 2, not only for freeing space.

I hope this post will be useful for you.


Edited by ponghy
Link to comment
Share on other sites

AgiHammerklau: I have SFC enabled, but this is not meant for .NET Framework 2. The repair process restores the original files of .NET 2 with or without SFC enabled. And this works in that way because the database contained in the CSetupMM subdirectory (the source cache feature) is the original database of .NET 2.0, not the patched one by KB928365. Setup extracts files from this MSI (database) file when repairing.

Currently I'm working on modifying the PackageCode of the product stored on the Registry to match with the stored in the patched version of the MSI file. If both Package Codes don't match, a severe error will occur when uninstalling or repairing.

Edited by ponghy
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...