Jump to content

Universal Extractor


nitro322
 Share

Recommended Posts

Great utility :) But I tried to install it on another XP Pro SP2 system and though it seemed to install okay, it seems to have uninstalled itself and I ended up with the "HKEY_CLASSES_ROOT\jarfile\shell\uniextract" error (as mentioned here) on subsequent reinstallations.

Sorry, but I never did find an answer to this. Is this occurring with the 1.6 beta as well?

Link to comment
Share on other sites


The following file is a Microsoft CAB archive, but is being treated as an InstallShield archive by Universal Extractor 1.5.

http://download.microsoft.com/download/b/c...f31/w95gray.exe

Also, whenever the /x switch is used on a file (Microsoft Hotfix), is there any way the description can be changed from a cab archive to a hotfix?

the_guy

Link to comment
Share on other sites

can the new version incorporate support for updating innounp? this way we can only replace innounp.exe when a new version comes out.

As BigRandalo suggested, this can be done easily yourself. Just download the new innounp and overwrite the older innounp.exe in the UniExtract bin\ directory. I don't plan on adding any automatic support for this, as new versions may behave differently and as a result break UniExtract if it's not properly tested.

Hi nitro322 :hello:

New version of innounp (0.20) works well with new version of inno setup but in uniextract no, it uses cmdtotal and files are bad.

cause:

peid internal scan not recognize new version of inno setup (show Borland Delphi 2.0 overlay)

My solution:

1) I add external signature to peid and modify this line $scantypes = _ArrayCreate('deep','hard','ext') to $scantypes = _ArrayCreate('ext', 'deep','hard')

2) modify this line case stringinstr($filetype, "Inno Setup Installer", 0) to case stringinstr($filetype, "Inno Setup", 0)

3) modify this line if (stringinstr(filereadline($debugfile, 1), "Version detected:", 0) _ to if (stringinstr(filereadline($debugfile, 1), " Version detected:", 0) _

All now works. :thumbup

Old bug: if folder already exist uniextract shows error but it extracts anyway. :rolleyes:

Link to comment
Share on other sites

The following file is a Microsoft CAB archive, but is being treated as an InstallShield archive by Universal Extractor 1.5.

Thanks, will check it out.

Also, whenever the /x switch is used on a file (Microsoft Hotfix), is there any way the description can be changed from a cab archive to a hotfix?

Shouldn't be too hard. Will look into it.

New version of innounp (0.20) works well with new version of inno setup but in uniextract no, it uses cmdtotal and files are bad.

cause: peid internal scan not recognize new version of inno setup (show Borland Delphi 2.0 overlay)

My solution:

Cool, thanks for the detailed report. I'll definitely check it out.

Link to comment
Share on other sites

I have one problem with inno setup and i was wondering how to fix it.

I have tried to extract Rocket Dock v.1.3.5, and it comes up with this error:

Signature detected: Inno Setup Setup Data (5.1.13)
This is not directly supported, but i'll try to unpack it as version 5110
; Version detected: 5113
Critical error: The setup files are corrupted. Please obtain a new copy of the program.
Unpacking failed. This version is not supported.

I updated to the latest version off of the sourceforge site, 1.9. it still does not work.

thanks.

The Program is the best i have ever used for extracting, by the way.

Link to comment
Share on other sites

I have one problem with inno setup and i was wondering how to fix it.

I have tried to extract Rocket Dock v.1.3.5, and it comes up with this error:

Signature detected: Inno Setup Setup Data (5.1.13)
This is not directly supported, but i'll try to unpack it as version 5110
; Version detected: 5113
Critical error: The setup files are corrupted. Please obtain a new copy of the program.
Unpacking failed. This version is not supported.

I updated to the latest version off of the sourceforge site, 1.9. it still does not work.

thanks.

The Program is the best i have ever used for extracting, by the way.

Try this version h**p://innounp.sourceforge.net/test020.rar :thumbup work

Link to comment
Share on other sites

Nitro, I'm gonna cross-post here-- serves to bump up this thread as well...

Context menu entries for Universal Extractor have disappeared(for .zip, .msi & .exe), on Vista Home Premium Sp1(btw no such issues on Win XP SP3). I've tried reinstalling, w/ all possible context entries enabled and .zip associated w/ it, of course-- to no avail. Send To shortcut remains in place.

Of note-- may help you-- re related programs:

Those with issues--

PeaZip: identical situation-- all entries disappeared as well + all Send To entries still in place.

ZipInstaller: context entry ONLY appears after archive is opened & listed in Explorer 'Folder' Pane-- ALTHOUGH ONLY if right-clicked from that side, NOT if right-clicked in File pane.

ExtractNow context entries have disappeared for .exe files, but for .zip have NOT disappeared.

7Zip main context 'name' entry is still there, BUT its command submenu NEVER LOADS.

Other related programs "with no such issues(each/all the very latest release, even if beta/rc/etc.)": #7Z, AlZip, IzArc, GSplit.

BTW

A. Universal Extractor, even before reinstall, was the last program of its kind installed.

B. SP1 for Vista was only installed 2 days ago.

C. Universal Extractor was upgraded to present Beta 1.6, w/ no issues, from the day it was released to the public.

Dollars to Doughnuts this is a Vista change issue--

1. NO such issues on WinXP SP3, &

2. Going by MS deadline to programmers to comply with all Vista OS changes: something along the lines that 'initially' older programs could still run normally w/ some older behaviors allowed & expected folder locations still in place... until xx date.

One other possibility:

some critical windows services "may need to be set to Automatic" for Universal Extractor to function properly??? i constantly weed out unnecessary ones-- although rarely Disable, usually set to Manual.

For instance: i had slsvc & SLUINotify set to Manual(after subsequent restart one Started, the other did not-- btw one depends on the other: cannot be started / stopped if the other one is stopped / started)... and lost Control Panel functionality... they both MUST be set to Auto.

And... i DON"T have MS Update set to auto.

Again, fantastic work on your part... thank you.

Edited by horsecharles
Link to comment
Share on other sites

a few updates are released:

7-Zip 4.56 beta - http://downloads.sourceforge.net/sevenzip/7z456.exe

ARJ32 3.14a - http://mysite.verizon.net/vze3nqpn/files/arj32v314a.exe

StuffIt Expander 12.0.0.3 - http://www.stuffit.com/downloads/std-downloadv.html

maybe there are other updates too but i dont find the most files :( maybe you can make a refresh build for us?

Link to comment
Share on other sites

Hi,

Can you fully automate the command line by adding the following switches?

  1. Rename extracted files automatically if file with the same name already exists. Renamed file will get the name like 'filename(N).txt', where 'filename.txt' is the original file name and 'N' is a number starting from 1 and incrementing if file exists.
  2. Set a password to decrypt files during extraction.
  3. Disable error and/or prompt messages.
  4. Recurse subfolders for archives
  5. Specify another log file name instead of the default UniExtract.txt in the switch, for example, -ilogc:\log\backup.log
  6. Specify default extraction tools to avoid user intervention (maybe put this one in the INI)

Thanks!

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...