Jump to content

WPI 4.3.5

Recommended Posts

I have a question about the Hover boxes in this version.

In the manual stands that you have to adjust some code of OnMouseOver, but you have to do this in the default themes folder wich don't excist in this version.

If i change it in the Glossy version in the wpi.htm it still showes.

How can i solve this problem?

Link to comment
Share on other sites

I also need to know how to do this in the new version. I have altered the wpi.htm in both Classic and Glossy without success.



Yes, getting rid of them would be cool, thanks. Also the tick boxes next to each title eg Internet, Utilities ect

EDIT again


Found your rar file with new main.js, great job, that sorted the tool tips, thanks

Edited by codeblue
Link to comment
Share on other sites

  • 2 weeks later...

Just upgraded to the new 4.3.5 version and would like to offer the following suggestions:

1. If you use exclusions (excl) then the multi check does not work properly. It will check all and the excl will not be selected as it should but you cannot click the multi again to uncheck everything in that category. Instead you have to use uncheck all to remove the checks. It would be ideal if when checking the multi it would check all but the excl but still show a check in the multi box and when you remove the check it removes all checks from that category.

2. I have so many entries now in my wpi that it loads very slow. It would be nice to implement a select box similar to the configs choices that would load a seperate config.js file. For instance I made a full page of regsitry changes that would be ideal for a seperate config.js file. When I wanted registry choices in wpi I could just select another config.js file and wpi would load that file. This way wpi would load quicker as it would not need to scan through one huge config.js file.


Link to comment
Share on other sites

  • 2 weeks later...


I recently updated to the latest version of WPI and I have some problems.

I attached my config.js because first of all, if I click "Select all", some entries are not checked (flash player and scite editor). They are both dependant on other entries ... I think that is the cause ...

And another problem is that the entries up from 130 are not installed ... (begining with flash ... maybe it is the cause of this, dunno). This is not totally tested right now, so I shall stick to my first problem for now.

I would really appreciate if you take a look at my config.js and tell me if I stupid and I did something totally wrong. I made my conclusion upon a Vmware install, so I'm not sure that it is not working in a real install, although I made a real install earlier (with only few of these programs) and it gave me an error (something about line 247access denied :realmad: ) and it had some strange behavior (I won't give mroe details for now, because I hope all this is because of my first problem).

BTW, this config.js was made for wpi 4.2b.


And one more thing: I noticed that if I edit my config.js like this


it is automatically converted to


But I don't want it that way, because it is really simple: %programfiles% has already a backslash :realmad:

I can make a secondary variable like %prog%="C:\Program Files", with no slash... but I was wondering just how to disable that feature of WPI (is it function WPIPath()?).


Edited by sadicq
Link to comment
Share on other sites

hmm ... but that way i get something like "C:\Program Files\\blah\program.exe".

And in most of the cases, it is ok for dos commands, but this is not happening for all of them :(.

I'll try to solve it by creating a new variable...

Link to comment
Share on other sites

I am trying to get avatars in the descriptionbox, but it dont work, i am sure i write the path correct and have used a java.gif which is make smaller to 128x128. also tryed a 32x32 azureus.jpg. both dont work? i have read your howto and there stood:

Adding Cosmetics

Add a pic and text in the description box

For the text and description just enter all of the text

you wish to be shown in the description box.

For the desired picture place the desired image into the

graphics folder at the root of WPI and simply add the file


(Like this = blah.jpg). Many pre-set image sizes for both

the height and width are pre programmed in to the

configuration section for your use. Also you can choose

where the text is to be displayed with the image i.e. To

the left, right, top or bottom.

so i have placed it in the map graphic, this also dont work? there is no word about limits or which rules i have to follow to be able to place a avatar....

Link to comment
Share on other sites

Feedback: extremly simple solution: instead of "%programfiles%\\blah" use "%programfiles%blah" in config.js.

This is quite simple, but for %cdrom% you have to use the double slashes... actually I took a look into the source of wpi and I saw a function that messes with this variables.... why do you add "\\" at the end of the %programfiles% variable? I mean anyone should use the system variables in wpi exactly like the cdrom one ... I don't see that function's role, that's all... Is it really necessary? :blink:

Link to comment
Share on other sites

Hi all i finally got around to adding wpi install to my unattened xp disk and everyhting goes fine until it starts to install the apps and then it tell me it cannot find the files or apps.

Yet after windows is finished installing i can go to my d:\ drive click on the wpi folder and click on the wpi.hta file and wpi will run and load all the apps i select just cant get it to do it while im installing windows

this is my runonce file if anyone can help me out please

cmdow @ /HID

for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\WIN51 set CDROM=%%i:

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

REG ADD %KEY%\001 /V 1 /D "%CDROM%\WPI\WPI.hta" /f


Link to comment
Share on other sites

Hi! I'm back with my feedback... did more testing and it seems that if I run WPI in debug mode and then restart my computer without deleting the entries in the registry it works fine.

If I run it in normal mode by double-clicking the wpi.cmd (no debug mode) it works fine.

BUT, if I run it from the GuiRunOnce (winnt.sif) the entries which have order numbers over 125 are not written to the registry.... WTF? is it a known bug/ am I doing it wrong?

I attached a picture of the registry (taken when WPI ran from GuiRunOnce) and my config.js (again).


EDIT: problem solved. It was caused by a cleanup scipt which was restartingmy computer and was called from wpi.cmd



Edited by sadicq
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...