Jump to content

Script error WPI.hta

Recommended Posts

:blushing: It is the first time for me to use WPI. I’m using wpi Version 3.3.5.

I saved WPI-folder just below Install-folder. Then I double crick WPI.hta to start. Suddenly, following error message was appeared.


In this picture, you can see WPI was saved on C loot, however, WPI.hta also did not work at $oem$\$1\install\WPI folder, either.

I’m Japanese so I use two byte letters OS like Chinese.

-Win XP SP2 Pro Japanese

-IE 6.029 SP2 128

Is there any person who got same problem and could solve it?

Link to comment
Share on other sites

Though I believed that above error caused due to two byte-Japanese OS. However, I found simple Chinese character in Language.js. I’m confused because Chinese also uses two-byte OS. Then, I install WPI in an old OS NT4 English version. BUT, I got same error message again!! Why!? I just extract wpi.zip and save the folder…and double click WPI.hta. I got the error message.


Is there anybody who can provide me the latest version 3.3.5 that dose not make any errors on your screen, and a previous version? I really want to check those 2 files.

Link to comment
Share on other sites


I DO NOT modified any files!!

I downloaded WPI.zip more than 10 times, but all files gave me the error message.

Because I got an error message, so I tried to Debug WPI. It was interesting. WPI was never stopping in my Debugger. Running endless…seems strange.

Link to comment
Share on other sites


No, as you said, WPi.hta does not have more than 130 lines. However, in this case, Line183 is in main.js, I think. I'm talking about 3.3.5 version.

I may not able to explain you about it in detail due to lack of my script knowledge and bad English, sorry. For instance, please modified any lines in main.js, you will see an error message like “Line 183” . You can see "#130"over information, I suppose. In addition, this kind of message does not always tell us good information. Foe example, there is something wrong code in other.js., the MS message can inform us “ there is an error Line 183”, wrong information. It is rare case but there is. It is difficult to explain….sorry. :blushing:

I still believe WPI is the nice installer and there is no error for English &European OS. :w00t:


Will you send me your WPI.zip( rar or anything) which works on your screen? And, if you have 2 different versions of WIP and if both of WPI are version 3.3.X, could you please send me both of them? :rolleyes:

I tried WPI 3.3.5 after clean install condition (OS), but it did not work.


Link to comment
Share on other sites

@ bonedaddy

Thank you for your kindness and support.

Finally, I found the key script line and solved this problem!!! :w00t:

Now my 3.3.5 works well. :D

I hope the next version will not show this kind of error message when Japanese guys install his the new WPI.

I promise you to upload a modified Lang.js which contain “Japanese” on this page. I hope this Japanese language data will be adopted in the next Lang.js version.

The problem for Japanese OS is a line in simplified Chinese in Lang.js. This is not an error for European language OS. It is cause to two byte character.

You can see the screen shot here


Many thanks :thumbup

Link to comment
Share on other sites


:D I upload my files on a website. I revised two files of WPI3.3.5. for adding Japanese language data.

I revised these files without obtaining permission from hasi001, sorry.


In my Lang.js, simple Chinese data is deleted.

In the future version, I hope that it is nice to have plural Lang.js files language by language to avoid the script error for two byte OS users.

@hasi001 :hello:

Could you please add Japanese language in the future version?

@Astalavista :P

Arigatou Astalavista. Tottemo ureshii yo (in Japanese)



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...