Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
MtK

How to cancel User Logon?

Recommended Posts

Maybe you could login the first-time pressing the cancel button - take the 1st regshot.

Second time, give a certain user's name and login - you know that after doing this it will login to that profile everytime - this time you take the 2nd shot.

Compare!

Share this post


Link to post
Share on other sites

OK I got two shots, now how do I compare them to see any differences?

Share this post


Link to post
Share on other sites

You should have saved it, and you know where it got saved (if not, then see where it saves the _NEXT_ regshot you save!).

So, just load (you get that option when you click the button, as in screenshot attached) the 1st shot, and load the 2nd, and click compare to see a text file of differences. You will know which ones are obviously unrelated to what you're trying, and which keys look like they are the correct ones.

post-8-1096236067_thumb.png

Share this post


Link to post
Share on other sites

The following is my Msbatch.inf file I use for Win98 installations, slightly edited to remove serial # and any personally identifiable information. This file was originally generated on 06/22/02

I believe the 2 sections below prevent the login prompt from occurring at first bootup, as my install boots directly to the desktop

[Network]

PrimaryLogon=Windows

[VREDIR]

ValidatedLogon=0

Here is the complete file:

; MSBATCH.INF

;

; Copyright © 1995-1998 Microsoft Corporation.

; All rights reserved.

;

[batchSetup]

Version=3.0 (32-bit)

SaveDate=06/22/02

[Version]

Signature = "$CHICAGO$"

AdvancedINF=2.5

LayoutFile=layout.inf

[setup]

Express=1

InstallDir="C:\WINDOWS"

InstallType=3

ProductKey="*****-*****-*****-*****-*****"

EBD=0

ShowEula=0

ChangeDir=0

OptionalComponents=1

Network=1

System=0

CCP=0

CleanBoot=0

Display=0

DevicePath=0

NoDirWarn=0

TimeZone="Eastern"

Uninstall=0

NoPrompt2Boot=1

[system]

Locale=L1009

SelectedKeyboard=KEYBOARD_00000409

[NameAndOrg]

Name="*****"

Org="*****"

Display=0

[Network]

ComputerName="*****"

Workgroup="*****"

Description="*****"

Display=0

PrimaryLogon=Windows

Clients=VREDIR

Protocols=NETBEUI, MSTCP

Services=VSERVER

Security=SHARE

[MSTCP]

LMHOSTS=1

LMHOSTPath="C:\WINDOWS\lmhosts"

DHCP=1

DNS=0

WINS=D

[VREDIR]

ValidatedLogon=0

[VSERVER]

LMAnnounce=0

MaintainServerList=2

[OptionalComponents]

"Accessibility Options"=0

"Accessibility Tools"=0

"Briefcase"=0

"Calculator"=1

"Desktop Wallpaper"=0

"Document Templates"=0

"Games"=1

"Imaging"=1

"Mouse Pointers"=0

"Paint"=1

"Quick View"=1

"Windows Scripting Host"=0

"WordPad"=1

"Address Book"=1

"Dial-Up ATM Support"=0

"Dial-Up Networking"=1

"Dial-Up Server"=0

"Direct Cable Connection"=0

"HyperTerminal"=0

"Microsoft Chat 2.5"=0

"NetMeeting"=0

"Phone Dialer"=0

"Virtual Private Networking"=0

"Baseball"=0

"Dangerous Creatures"=0

"Inside your Computer"=0

"Jungle"=0

"Leonardo da Vinci"=0

"More Windows"=0

"Mystery"=0

"Nature"=0

"Science"=0

"Space"=0

"Sports"=0

"The 60's USA"=0

"The Golden Era"=0

"Travel"=0

"Underwater"=0

"Windows 98"=0

"Desktop Themes Support"=0

"Internet Connection Sharing"=0

"Microsoft Wallet"=0

"Personal Web Server"=0

"Web Publishing Wizard"=0

"Web-Based Enterprise Mgmt"=0

"Microsoft Outlook Express"=0

"Baltic"=0

"Central European"=0

"Cyrillic"=0

"Greek"=0

"Turkish"=0

"Audio Compression"=1

"CD Player"=1

"Macromedia Shockwave Director"=1

"Macromedia Shockwave Flash"=1

"Multimedia Sound Schemes"=0

"Sample Sounds"=0

"Sound Recorder"=1

"Video Compression"=1

"Volume Control"=1

"America Online"=0

"AT&T WorldNet Service"=0

"CompuServe"=0

"Prodigy Internet"=0

"The Microsoft Network"=0

"Additional Screen Savers"=0

"Flying Windows"=0

"OpenGL Screen Savers"=0

"Backup"=1

"Character Map"=0

"Clipboard Viewer"=0

"Disk compression tools"=0

"Drive Converter (FAT32)"=0

"Group policies"=0

"Net Watcher"=0

"System Monitor"=0

"System Resource Meter"=0

"Web TV for Windows"=0

"WaveTop Data Broadcasting"=0

[Printers]

[installLocationsMRU]

[install]

AddReg=RunOnce.BatchDelay,Run.Installed.Components,Registry.WinUpdate

[RunOnce.BatchDelay]

HKLM,%KEY_RUNONCE%,BatchRun1,,"%25%\rundll.exe setupx.dll,InstallHinfSection Delete.Welcome 4 %10%\msbatch.inf"

HKLM,%KEY_RUNONCE%,BatchRun2,,"%25%\rundll.exe setupx.dll,InstallHinfSection Delete.Regwiz 4 %10%\msbatch.inf"

[Run.Installed.Components]

HKLM,%KEY_INSTALLEDCOMPS%\>BatchSetupx,,,">Batch 98 - General Settings"

HKLM,%KEY_INSTALLEDCOMPS%\>BatchSetupx,IsInstalled,1,01,00,00,00

HKLM,%KEY_INSTALLEDCOMPS%\>BatchSetupx,Version,,"3,0,0,0"

HKLM,%KEY_INSTALLEDCOMPS%\>BatchSetupx,StubPath,,"%25%\rundll.exe setupx.dll,InstallHinfSection Installed.Components.General 4 %10%\msbatch.inf"

HKLM,%KEY_INSTALLEDCOMPS%\BatchSetupx,,,"ICW"

HKLM,%KEY_INSTALLEDCOMPS%\BatchSetupx,IsInstalled,1,01,00,00,00

HKLM,%KEY_INSTALLEDCOMPS%\BatchSetupx,Version,,"3,0,0,0"

HKLM,%KEY_INSTALLEDCOMPS%\BatchSetupx,StubPath,,"%24%\progra~1\intern~1\connec~1\icwconn1 /restoredesktop

HKLM,%KEY_INSTALLEDCOMPS%\>BatchAdvpack,,,">Batch 98 - Advanced Settings"

HKLM,%KEY_INSTALLEDCOMPS%\>BatchAdvpack,IsInstalled,1,01,00,00,00

HKLM,%KEY_INSTALLEDCOMPS%\>BatchAdvpack,Version,,"3,0,0,0"

HKLM,%KEY_INSTALLEDCOMPS%\>BatchAdvpack,StubPath,,"%25%\rundll32.exe advpack.dll,LaunchINFSection %10%\msbatch.inf,Installed.Components.Advanced"

HKLM,%KEY_INSTALLEDCOMPS%\>Batchwu,,,">Batch 98 - Windows Update"

HKLM,%KEY_INSTALLEDCOMPS%\>Batchwu,IsInstalled,1,01,00,00,00

HKLM,%KEY_INSTALLEDCOMPS%\>Batchwu,Version,,"3,0,0,0"

HKLM,%KEY_INSTALLEDCOMPS%\>Batchwu,StubPath,,"wupdmgr.exe -shortcut"

[installed.Components.General]

AddReg=Browser.Settings, Proxy.Settings, Security.Settings, Shell.Prep

BitReg=Shell.Settings

[DelOEdesktop]

setup.ini, progman.groups,, "groupOE=..\..\desktop"

setup.ini, groupOE,, """Outlook Express""" ;deletes icon

[installed.Components.Advanced]

DelFiles=OLS.Icons, QuickLaunch.Icons

CustomDestination=Custom.Dest

RunPostSetupCommands=DirCleanup

[Custom.Dest]

49070=DesktopLDIDSection,5

49050=QuickLinksLDIDSection,5

[DesktopLDIDSection]

HKCU,"SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders",Desktop,OLSFolder,"%25%\Desktop"

[OLS.Icons]

[DirCleanup]

rundll32.exe advpack.dll,DelNodeRunDLL32 %49070%\%OnlineLong%

[Delete.Welcome]

DelReg=Registry.Welcome

[Registry.Welcome]

HKLM,Software\Microsoft\Windows\CurrentVersion\Run,Welcome,,

[Delete.Regwiz]

AddReg=Registry.Regwiz

[Registry.Regwiz]

HKLM,Software\Microsoft\Windows\CurrentVersion\Welcome\Regwiz,@,1,01,00,00,00

HKLM,Software\Microsoft\Windows\CurrentVersion,RegDone,1,01,00,00,00

[Registry.WinUpdate]

HKLM,Software\Microsoft\Windows\CurrentVersion\Policies\Explorer,NoDevMgrUpdate,0x10001,0

HKLM,Software\Microsoft\Windows\CurrentVersion\Policies\Explorer,NoWindowsUpdate,0x10001,0

[browser.Settings]

HKCU,%KEY_IEXPLORERMAIN%,"Start Page",,"http://www.google.com"

HKCU,%KEY_IEXPLORERMAIN%,"First Home Page",,"http://www.google.com"

HKCU,%KEY_IEXPLORERMAIN%,"Search Page",,"http://www.google.com"

HKLM,%KEY_IEXPLORERMAIN%,"Search Bar",,"http://www.google.com"

HKCU, "SOFTWARE\Microsoft\Internet Explorer\Help_Menu_URLs","Online_Support",,"http://support.microsoft.com/support"

[security.Settings]

HKCU,"Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1",CurrentLevel,1,00,00,01,00

HKCU,"Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3",CurrentLevel,1,00,00,01,00

HKCU,"Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\4",CurrentLevel,1,00,00,01,00

[shell.Prep]

HKCU,"Software\Microsoft\Internet Explorer\Desktop\Components\0",Flags,01,00,00,00

HKCU,"Software\Microsoft\Internet Explorer\main",Show_ChannelBand,0,"no"

[shell.Settings]

HKCU,"Software\Microsoft\Internet Explorer\Desktop\Components\0",Flags,0,20,1

HKCU,Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState,Settings,1,20,4

[QuickLinksLDIDSection]

HKCU,"SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders",AppData,QuickLaunch,"%25%\Application Data"

[QuickLaunch.Icons]

viewch~1.scf

[DestinationDirs]

QuickLaunch.Icons=49050,Micros~1\Intern~1\QuickL~1

[strings]

KEY_RUNONCE="SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce"

KEY_INSTALLEDCOMPS="SOFTWARE\Microsoft\Active Setup\Installed Components"

OnlineLong="Online Services"

KEY_IEXPLORERMAIN="Software\Microsoft\Internet Explorer\Main"

KEY_INTERNETSETTINGS="Software\Microsoft\Windows\CurrentVersion\Internet Settings"

Share this post


Link to post
Share on other sites

@MtK did you find a solution about this first log-on, because I've tried the one gived by @vic_vertebrae, but didn't work for me.

If you find a way to do this, please tell me how. Thanks in addvance.

Becko

Share this post


Link to post
Share on other sites

I sometimes had that auto login thing. Basically you just say OK with no username/password.

You can also mess around with the Networks part of the Control Panel, my memory is a bit vague on this but I recall messing with it, changing something and it stopped asking completely.

Share this post


Link to post
Share on other sites

I am having the same problem... I was already using the lines that Vic mentionned. My guess is that you need to fill the password in advance, otherwise Win98 asks for it... I know that my unattened XP CD sets the passwords and such, so eventually I will go back to it and see if can be done in Win98 too...

For the people wondering what's the big deal with that first logon... In my case, it's the difference between having all the patching/software installation done automatically after the scandisk phase or having to come back to the PC half way through to hit enter and wait another 5-10 minutes for the completion...

Share this post


Link to post
Share on other sites

I did it this way.

You need 5 things to this

- TweakUI (tweakui.cpl in \windows\system)

- Your password file (username.pwl in \windows)

- The [Password Lists] section from your system.ini

- Configured msbatch.inf

- A reg file that adds user information and an autorun service

1. First you need an installed version of Windows 9x with TweakUI. Then enter your username & password and enable the autlogin option. Make sure it works.

2. In your Windows folder should be a file called [username].pwl and in the system folder a file tweakui.cpl. Copy these 2 files to your unattended folder where your msbatch.inf file is.

3. This is part of my msbatch.inf (irrevelant lines are here omitted) with network. I don't know if the network section is necessary.

msbatch.inf

[NameAndOrg]
Name="Username"
Display=0

[Network]
ComputerName="ComputerName"
Workgroup="Workgroup"
Display=0
PrimaryLogon=Windows
Clients=VREDIR
Protocols=MSTCP
Security=SHARE
PassThroughAgent="Workgroup"

[VREDIR]
LogonDomain="Domain"
ValidatedLogon=0

[Install]
AddReg=RunOnce.BatchDelay,Run.Installed.Components,Registry.WinUpdate,RegistrySettings,OPKInstall
CopyFiles=winfile.copy, winsysfile.copy
UpdateInis=UPD.Sys.systemini

[winfile.copy]
username.pwl

[winsysfile.copy]
tweakui.cpl

[UPD.Sys.systemini]
%10%\system.ini,"Password Lists", , "Username=c:\Windows\Username.pwl"

[RunOnce.BatchDelay]
HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup,"Userdefined Batch File",,"start [Your unattended folder here]\custom.bat"

[DestinationDirs]
winfile.copy=10
winsysfile.copy=11

4. Now during the installation a file custom.bat is executed which registers a reg file called runonce.reg. This regfile adds user information and the TweakUI autorun service to the registry, so you will be automatically logged in (see below) .

You can probably also do it in the msbatch.inf, but I use custom.bat for other purposes as well.

custom.bat

c:
cd\[Your unattended folder here]
%windir%\regedit /s runonce.reg

5. Runonce adds your username & password and an autorun service to the registry. I used the my username as password, so I don't know if it will work when you specify another password.

runonce.reg

REGEDIT4

;Autologin for specified User
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon]
"AutoAdminLogon"="1"
"DefaultUserName"="Username"
"DefaultPassword"="Password"

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices]
"Tweak UI"="RUNDLL32.EXE TWEAKUI.CPL,TweakLogon"

Share this post


Link to post
Share on other sites

Thank you kukris, I used the method you described and all went well.

I checked how I was doing it in Win XP, and basically the NET command was doing the equivalent of the various TweakUI steps. There is a NET command in W98 also but it refuses to run from DOS, so I had no luck getting it to work with RunOnce...

Share this post


Link to post
Share on other sites

Hi all

I just want to point out that alot of ppl seemed to forget about what MtK was asking about.

How can I cancel User Logon, in an unattended installation?

Notice the last bit hehe He wasnt refering to after windows is installed and then, later on, you want to set it to autologon.

Good work kukris but there surely must be a simpler way ...er... right? :D

(btw havent tried it yet myself kukris hehe)

Regards,

N.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...