Jump to content

Boot PE from USB Flash Drive


Recommended Posts

Though seemingly unrelated, here is a list of USB sticks that work on Xbox, if they work there they WILL work on PC, whilst devices reported as NON WORKING on Xbox MIGHT work on PC also:

1 Devices that do work

3System USB Flash Disk USB Drive 32 MB (1998 blocks)

Aigo 128MB USB Memory Stick (7997 blocks)

Apacer 256Mb USB Key (Paradigit)

AVB 64 MB USB 1.1 Mobile Drive (4030 blocks, ID 0ea0:6803)

Belkin 32MB USB Memory Stick

Captiva USB BAR 128 MB (7989 blocks)

Commodore Floppy -on- stick 128MB (7989 blocks)



Creative Labs Nomad Muvo MP3 Player 128MB (7997 blocks)

Dolphin  PowerCAM 2.0 Megapixel Digital Camera FASTUSB-1015

Digital Research MP3 player 32MB (~5092 blocks)

Digitrex DSC-1300 camera, in Mass Storage mode (8MB)

EasyDisk 32MB (2014 Blocks)

EasyDisk 128MB (7997 Blocks)

Freecom USB Stick 32 MB (1998 blocks)

Fujitsu Siemens 64MB Menustick

Fujitsu Siemens SB-512 MemoryBird USB-2.0 (512MB, how do I get MechInstaller onto it? - sajb)

Gateway 16MB USB Flash Drive (998 blocks), Windows sees it as "USB NAND FLASH DISK",  VID:0c45 PID:1060

Gateway 32MB USB Flash Drive (1998 blocks), Windows sees it as "MFG FLASH DRIVER", Vendor=0c45 ProdID=1060

Hama 6-in-1 USB Card Reader (Model-Nr.: 46958) with Lexar Media 16MB CompactFlash (992 blocks)

HP Photosmart 315 with 8 MB SanDisk CF Card

HP Photosmart C618 Digital Camera

IBM 32 MB USB Memory Key (1998 blocks)

KBGear JamP3 Player (9998 blocks)

KingMax USB2.0 Flash Drive 512MB - KS/PD2-512M (31994 blocks)

Kingston DataTraveler  32 MB (1998 blocks) & 256 MB (15740 blocks)

Lexar JumpDrive Secure 128 MB (7869 blocks)

Lexar JumpDrive Secure 256 MB (15740 blocks)

Lexar JumpDrive Sport 64 MB

Linksys Instant USB Disk 64 MB (Model USBM64M) (3998 blocks)

Logic3 16MB USB (991 blocks)

Medion USB 128 MB (7997 blocks)

Memorex 64 MB (4030 blocks) & 128 MB

Memorex ThumbDrive 256MB (16116 blocks)

Memory in Black USB memory pens from 32 to 512 MB, both the PQI-based and Opti-based models

Micro Advantage 64MB (4008 blocks)

Minolta DiMAGE F300 with 64MB SD-Card

M-Systems DiskOnKey 8MB (486 blocks)

Nikon Coolpix (test with 1x 16 MB and 2x 128 MB CF/SD cards)

Nikon Coolpix 995 w/128MB SanDisk CompactFlash

Ocean 8 MB (490 blocks)

Olympus D-510 Zoom Digital Camera with 64 MB SmartMedia (3990 blocks)

Olympus D-550 Digital Camera with 128 MB SmartMedia (7997 blocks)

Olympus D-380 Digital Camera with 64 MB SmartMedia (MechInstaller - Open 8-32MB image and write to 64MB)

Oti 32 MB

Paradigit 128 MB USB2.0 memory stick  (aka Apacer memory stick) (7837 blocks)

PNY 64 MB (3998 blocks)

PQI "Travelling Disk" translucent USB sticks, 64 and 128MB at least

(all 0ea0:6803; some models (09a6:8001) say "damaged", though)

Prolific USB Flash Disk 256 MB (15996 blocks)

SanDisk Cruzer Mini USB Flash Drive 128MB (USB 2.0)  Works Great for mechassault install

SanDisk Cruzer Mini USB 128MB - Had to use 8MB-32MB image

Sandisk Mini Cruzer 256Mb USB 2.0 (15k+ blocks - tossed my notes on this)

Samsung 64Mb USB disk (4030 blocks)

Sony 64MB MicroVault (USB 2.0) - 3998 blocks - for MechInstaller, open 8-32MB .img, write to 64MB stick. Has security features, see JetFlash below (?)

Soyo CigarPro2 (USB 2.0, 128MB--the green plastic one) - shows up as "Prolific USB Flash Disk" on WinXP (7997 blocks)

Sweex 128 MB

Transcend JetFlash 64 MB - se below

Transcend JetFlash 128 MB - Depending on model, there are 6 JetFlash types, see link 

    http://www.transcendusa.com/Products/ModLi...eldNo=2&CatNo=4 and info in the paragraph above.

TwinMos MobileDisk III 64 MB (3998 Blocks)

Twinmos Mobile Disk USB 1.1 Pocket Pen Drive 64B (seller p/n XPD64) (Manuf p/n FMD064S) 

                                        (0ea0:6803,Manuf="USB",Prod="Solid state disk")

Typhoon USB Memory Adapter 32 MB (USB 1.1, Art. Nr. 83049, 2014 blocks, for MechInstaller, open

                                  "MechInstaller-1.0-FATX-8MB-to-32MB.img", write to 32MB stick)

Universal Smart Drive 64MB - used 8mb-32mb image

USB UltraDrive 32 MB (1998 blocks)

Zyon Systems 64MB popdrive - commonly handed out to trade show patrons:) - must be plugged in before xbox is powered on, otherwise nothing.

2 Devices that don't work


Apacer HandyDrive 64 MB (0d7d:0100, not detected)

Atech Pro-9 Card Reader with 8 CF or memory stick (not detected)

Belkin Media Reader USB2 8-in-1 (F5U248) with at least 4 different SM/CF media, from 32 to 128 MB (not detected)

Ben MP3 and Pen Drive 64MB

Casio Qv3000 Camera with with 8 meg casio CF-8x card (makes the screen flash over and over..)

Creative MuVo 128MB

Creative MuVo 64MB

Creative NOMAD MuVo NX 128meg (Xbox said "damaged" but then formatted it with 7005 blocks. but not recognised on reconnect)

Dazzle Memory Stick Reader (04e6:0314, screen flashes and "damaged" shows up when media removed from reader)

DataFab KESD-USBA Reader with Toshiba 16MB SD Memory Card (Memory screen flashes indefinitely)

Dell branded Lexar 16MB

Dell branded Lexar 64MB

DeLock UISDMC1S, 6x Card Reader with 2 slots + ExtreMEmory 256 MB CF-Card ("damaged")

DeLock UISDMC1S, 6x Card Reader with 2 slots +  Apacer 64 MB CF-Card ("damaged")

DeLock UISDMC1S, 6x Card Reader with 2 slots +  SanDisk 48 MB CF-Card ("damaged")

DeLock UISDMC1S, 6x Card Reader with 2 slots +  32 MB SmartMedia Card ("damaged")

DeLock UISDMC1S, 6x Card Reader with 2 slots +  64 MB SmartMedia Card ("damaged")

Disgo 512MB PRO USB2 (M-Systems DIS20512R) 0x08EC:0x0012, relative of DriveKey, bootable but "damaged"

Disgo 64MB (Damaged, even when low-level formatted)

DiskOnKey 16MB (says "damaged")

DiskOnKey 64MB (says "damaged")

Frontier Labs NexII with 8 meg Casio CF-8x card ("damaged")

FujiFilm FinePix 6800Z Camera (tested with 16 MB and 128 MB SmartMedia cards)

FUJIFILM 128MB USB 2.0 DRIVE (PLUG & PLAY) (says i may have a corrupt memory card)

HP Photosmart 620 with 256MB SanDisk SD memory card (camera says connected to pc, but xbox does not recognize)

HP Photosmart P-1000 with Hitachi 8MB CompactFlash Card

Hama 6-in-1 USB Card Reader (Model-Nr.: 46958) with PQI 128MB CompactFlash

Hama 6-in-1 USB Card Reader (Model-Nr.: 46958) with SanDisk 128MB SecureDigital

Hama 6-in-1 USB Card Reader (Model-Nr.: 46958) with HAMA SmartMedia 32MB

Hama 6-in-1 USB Card Reader (Model-Nr.: 46958) with Sony MSA-128A 128MB

Hama 6-in-1 USB Card Reader (Model-Nr.: 46958) with SanDisk 128MB CompactFlash (says "damaged")

Hama 6-in-1 USB Card Reader (Model-Nr.: 46958) with Canon 8MB CompactFlash (says "damaged")

Imation FlashGo! (IMN-USB-FG1) with at least 4 different SM/CF media, from 32 to 128 MB ("damaged")

Iomega PocketZIP 40 USB (says "damaged")

Iomega ZIP 250 USB (says "damaged" on all media)

Jump Shot 8MB (says "damaged")

KingMax usb 64 (says "damaged")

Kodak EasyShare CX6230 Camera -- neither internal memory nor 256 MB Sandisk SD card -- no apparent recognition by XBOX

Lexar JumpDrive 64MB USB memory stick

Lexar JumpDrive 128MB

Lexar JumpDrive Trio with 128mb Secure Digital card (says "damaged")

LG Flatron USB Drive 64 MB from haansecure (Korea) (says "damaged")

Memorex USB -> CF Card Reader, causes the memory page in the Dash to flicker repeatedly, tried with multiple CF (32, 64, 128)

Mercury Cyberpix - all models (says "damaged")

NAPA P22 WMA mp3 player

No-name (Lexar Chipset + Samsung Memory) 128 Meg USB 2.0 (not detected)

Nikon Coolpix 775 (with 8Mb Nikon card or 32MB Sandisk card) -- no apparent recognition by XBOX

Nikon Coolpix 5400 w/32mb sd card.  (shows moving rectangle on camera display and never connects)

Olympus USB SmartMedia Reader-Writer with at least one card of unknown size

Packard Bell AudioKey 32MB

PNY Attache 64MB (says "damaged")

PQI "Travelling Disk" translucent USB sticks, 64 MB (some work, some (09a6:8001) say "damaged")

QDI U2Disk 64MB

SanDisk Cruzer with SD 256MB card.

SanDisk ImageMate combination CompactFlash/SmartMedia to USB adapter

Softick Card Export II (SD drive emulation for the Palm OS - Uses USB mass storage driver) (Xbox breifly recognizes the card 1 time out of 10 - will format in FatX, but will not read savegames - Screen flashes)

Sony Cyber-shot DSC-P31 with Memory Stick (054c:0010, Camera recognizes USB connection but XBox screen flashes)

Sony Cyber-shot DSC-P32 with Memory Stick

Sony Cyber-shot DSC-p71 (makes the screen flash over and over..)

Sony DCR TRV18E Digital Camcorder with Memory Stick

Sony DCR TRV-25 Digital Camcorder with Memo

Sony Micro Vault 256 MB USB 2.0

Topcom Pocket Memory II 256 MB

Transcend JetFlash 2A 128MB (TS128MJF2A, 0c76:0005, see link above) just makes the memory screen flash forever.


Link to comment
Share on other sites

Ive been trying diffrent methods for getting this to work on my visiontek 1 gig flash drive and I can get dos to boot but not for the life of me will winpe boot, sometimes it hangs, sometimes it gets like cant boot errors. Its very strange im still messing with it. :hello:

Link to comment
Share on other sites

Well I got it working on my main system here, I havent had the time to try it on other systems yet. I used the simplest method and it actualley worked so suprised. I had been trying alot of diffrent methods and none of them where working except the simpliest hah. So I used the HP tool to format the drive just regular NOT with DOS files. Copied over the windows PE files before an ISO build. and put the ntdetect.exe in the root renamed the setupldr.bin to ntldr and put it in the root also and deleted the other files except the winbom.ini and it boots like a charm. This perticuler bios supports boot from USB HDD, USB Floppy, USB CDROM and USB something else. So it has the compatability, im gonna go ahead and try it on a few of my other systems and let you all know how I fare. But to say the least im pretty stoked.

BTW. I have a VisionTek 1 GB USB 2.0 Flash Drive. Just to let the people that are trying to do this but have not succeeded yet, it is a pretty slow solution even at USB 2.0. It will take a bit to boot but once its up it runs pretty nice. It does have a bit of a lag but its not that bad. Also I was reading for the really hard up folks with no bios support for USB I was reading you could use a floppy disc or even a cdrom really thats bootable to load just the usb drivers and then continue to boot from the USB , but I havent tested that method as it has not applied to my situation yet.

Link to comment
Share on other sites

I didnt realize the HP tool supports NTFS, thats cool I just used the default option of FAT, and I did not include the DOS. If you have used the HP tool there is an option for including the DOS files from a external DIR, I DID NOT INCLUDE DOS. Also I just did a regular format I didnt tick Quick format, but it was just as fast as a quick format. Hope that helps

Link to comment
Share on other sites

Found this:

(If the USB key don't boot)

You can try the other USB Boot Options (Floppy, CD-ROM, Harddisk), if still nothing happens you might have to enable USB Keyboard Support in your BIOS (needed on some motherboards with AMI BIOS and a Via chipset, including Epia-m and Shuttle mv42n).

On some broken boards (like my Epia-M...) you need to plug the memory stick in without any power (remove your power plug), otherwise the BIOS might not recognize the memory stick.

Found here:


It might resolve some of the problems discussed here.


Link to comment
Share on other sites

When you use the HP tool - don't use a MSDOS 6.22 bootdisk for your base - try using this and see if this helps:

Super MS-DOS 7.10 Boot Disk (Build: 2004.2.14) Updated!

Note: The above Super MS-DOS 7.10 Boot Disk is a customized DOS boot disk that has many more features than standard DOS boot disks. Therefore, it also supports NTFS/USB drives, mouse, and many more.


Please advise if it is any better..


Link to comment
Share on other sites

Has anyone had selective luck with this working? I have a Lexar Jumpdrive 256MB, and the install went slicker than you know what. Just copied everything over, renamed some files, and I'm off to the races...as long as I boot an IBM using the key.

My workplace has a lot of Dell and a lot of IBM laptops and desktops, depending on who is cheaper during each purchasing cycle, and the Dells don't seem to want to boot from my key. I've tried the GX270, GX280, D400, and D600, and each time, I get a stop code of 0x0000007b. To me, this means the right drivers for the HDD contollers aren't installed, but everything works smoothly if I boot the exact same WinPE installation from a CD-ROM.

Has anyone else seen this, or anyone else had success with Dell machines?

Link to comment
Share on other sites

You can save yourself a lot of time, effort, irritation, etc by:

a. waiting for the Server sp1 release of WinPE which includes support for booting from UFD (aka Disk On Key) and tools to make it work

b. Getting a beta build of the Server tools, the latest version of which should include the support.

Using the beta tools I have been able to boot my Dell GX270+ systems from UFD.

Note that the MS solution and the HP solution are completely different, polar opposites. The HP solution boots the key out of INT13 -- the MS solution will boot the key in XINT13.

Both will suffer from the same issue -- if the system doesn't support boot from USB natively you won't get far.

Link to comment
Share on other sites

Saw that this thread was still open, so thought I would comment in and tell you my success. The PE source I used is the WinPE 2004 (Microsoft OEM issue which is based on WinXP SP2), which has WMI support and parts of the windows firewall built in.

1. Use the HP DriveKey util and format the usb key as FAT16 (no system files)

2. create a folder on the key called "minint" and copy the contents of i386 from your WinPE source into it.

3. in the WinPE source folder i386, copy "setupldr.bin" to the root of your usb key, rename this file to "ntldr" (no extension)

4. copy from the WinPE source folder i386 the file "ntdetect.com" to the root of your usb key.

Make sure your bios supports booting from usb. Some computer's bios, especially dell or IBM, you have to plug the usb key in PRIOR to booting. Go to the bios, select the boot order, click on hard drives, and expand the folder. Under there you'll see both your hard drive, and the USB key. Make sure you give priority to the USB key over the hard drive. Save settings and reboot.

This should allow you to boot up in WinPE nicely. You can also add shells like XPE or pull's BartPE's menu thingy and load all the tools from there.

Just an FYI - not a good idea to use this method to flash the bios of your computer. Use a DOS based key to do that.

Link to comment
Share on other sites

Note that by using Int13 as the HP utility does, it will limit the systems which that key can boot on to systems which have a BIOS that interprets the USB Flash Drive geometry exactly the same. Meaning a UFD prepared on one HP system will most likely not work on a Dell, Sony, etc. Even if (as RiBond pointed out) the BIOS implements support for booting them).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...