Jump to content

98SE install prep for Dell Latitude D830


beansmuggler
 Share

Recommended Posts

I'm not sure whether it was relocating, trying (and failing) to reinstall, or anything else, but it looks like I'm connected after I moved to a free ethernet connector in another room of the house. I'm guessing I'll need Mozilla or another browser to access MSFN, but it's working!

The shutdown problem still seems to persist if I turn it on with the ethernet plugged in.

 

EDIT: Got RetroZilla working properly, so I have access now! Still having the shutdown issue though.

Edited by beansmuggler
Link to comment
Share on other sites


:thumbup

About the shutdown issue, try:

1) Reinstalling video drivers (if already installed).

2) Is there different behavior with/without ACPI (see pages 8-10 of the D600-thread).

Question: is Reboot  to MS-DOS okay?

Link to comment
Share on other sites

While running through the built-in 98SE troubleshooter, I've noticed that it also reboots fine if I was in safe mode, though I guess that's expected since the ethernet seems to cause the problem. I also found an rloew patch for the A: drive issue, so now all my drives are showing as 32-bit (I have the CD disabled for now)!

Using the AUMHA site linked on MDGx, I was eventually able to get around the problem by unchecking "Use IRQ Steering" in the Properties for PCI Bus, then switching hardware enumeration to "Use BIOS". As a safety measure, I still installed "Microsoft Windows 98 SE Shutdown Supplement" anyways, and returned the PCI Bus settings to normal ("Use Hardware" and "Use IRQ Steering"). Looks like Ethernet is entirely completed!

Moving on to WiFi, I'm going to guess that the Intel Wireless WiFi Link 4965AGN (name given by SIV) is too new for 98SE to handle. So far I've tried the driver provided in Dell's R142718.EXE, but 98 won't recognize it. The one hosted on CNET (which I usually never frequent, but recently heard a success story from) is the same one as Dell's, so no luck there either.

Link to comment
Share on other sites

As expected, 98 won't cooperate with the WiFi drivers available for this device, and I can accept that. I moved on to the USB and ran the Maximus Decim nusb33e update, which seems to work less effectively than I remember last time. I was able to fix the issue by disabling USB Emulation in BIOS (it was re-enabled for convenience in Safe Mode), but I figured I'd keep all the stuff I wrote about it here just in case someone ever needed their issue remedied:
 

Quote

 

After rebooting the second time, it wouldn't detect when I plugged a USB in after bootup (this was in the side port with USB emulation on). I restarted with the USB plugged in and it recognized/installed the drivers, albeit very slowly. I opened My Computer to access the files and it took a long time to load. Once it did, I was presented with two versions of my USB drive: Drive D, which looked normal, and Drive E, which was exactly the same as Drive D but had a document icon as the thumbnail instead of the storage device thumbnail.

When I right-click the taskbar icon to eject hardware, I get a choice between ejecting "USB Disk" (with a CD drive icon) and "Lexar USB Flash Drive E:" (with a hard drive icon). In My Computer, it looks like these are both the same thing according to the device hierarchy: "Standard PCI to USB Enhanced Host Controller > USB 2.0 Root Hub > USB Mass Storage Device > USB Disk (storage controller icon) > Lexar USB Flash Drive (hard disk icon)". If I choose to eject "Lexar USB Flash Drive E:", it also removes "USB Disk" and the E: version of my USB is removed, but the D: version is still there. Unplugging the USB drive at that point does not make the drive go away. Disabling USB emulation solved the problem.

 

At this point, unless I ever want to give the CD issue a shot again (or if anyone else does), I'll move onto the sound drivers, which should be under the proper thread (which I may need to read in full since my installation doesn't seem to be working). Once everything is done, I plan to edit the first post to have a proper installation guide and maybe even a small batch file to help make installation a tad quicker. Thanks to everyone for your help!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...