Jump to content

Windows installer service could not be accessed


Recommended Posts

I have Win 7x64 bit operating system (does it say the motherboard and the CPU are also x64, or they could be x64 and still work?)
I try to insytall Autocad, error, so i try to install Microsoft Visual C++ 2008 Redistributable Package
In both cases it writes  Windows installer service could not be accessed.
I ebabled most of the processes, and still: Windows installer service could not be accessed

Link to comment
Share on other sites

Follow the first two methods detailed here (method 1 and method 2) BUT try first #2 and only if the service does not start manually or you have the "could not be accessed" error, try method #1, followed by #2 again to make sure the service is running :



Link to comment
Share on other sites

I made, mistakingly, method 1 first, no god, then #2 & #1, no good.

It says the keys & values contained in... couldn't be accesed, though the file has been added to the registry

Link to comment
Share on other sites

Maybe then the issue revolves around permissions and/or your login credentials?

Those keys in the Registry should normally be accessible as Administrator.

Or maybe you have some policies applied preventing it? :dubbio:

You can still try running the Regedit as "Trusted Installer" and import the .reg but it should not be needed.








Link to comment
Share on other sites

I updated Win7. used Simplix UpdatePack. downloaded also un update from Microsoft. now 9 updates repeatedly won't install, but they are security and office updates.

Used the 2 programs listed above: PowerRun and AdvancedRun, although i don't know which user to choose in the last one. i applied 2 options, but no good.

The process seems to work since it's written in the process manager, but the programs i want to install, for example Acad 14, Office 2003 &, as a test, Microsoft Visual C++ 2008 Redistributable Package, all write the same error message.

I remind you that i made the Regedit fixes suggested first. before tweaking with AdvancedRun i Regedit.exe didn't have UAC Virtualisation, i don't know if it's connected.

After playing with AdvancedRun-now it's written nothing under UAC Virtualisation for Regedit.exe, in Task manager.

Link to comment
Share on other sites

There is some language misunderstanding.

No idea what you mean by UAC Virtualisation. :unsure:

The process manager has nothing to do with this, you mean the service manager?

The service is either running or is it not.


To check that the Windows Installer Service is running, follow these steps:

Click Start, type services.msc in the Search box, and then click Services under the Programs heading.

In the Services (Local) list, right-click Windows Installer, and then click Properties.

In the Startup type drop-down list, check that the value is set to Manual.

The Windows Installer Service is running if the Service status: entryis set to Running.

You can use (easier) the little Nirsoft tool Serviwin:

to check the installer service status.

Then open regedit, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msiserver and export it to a .reg file.

The result should be the same as the .reg file posted on the given MS KB, if not, attach the .reg file you exported to your next post.

Next step, try the troubleshooter here:


Link to comment
Share on other sites

I made everything i could, the installer is on Automatic and running after restart (although it stops), i try to install something, even the microsoft Win 7 updates it doesn't want.

I tried while it was running, as written in the Services. no use

I also tried to install something as an administrator-no use

Maybe it's permissions?

Link to comment
Share on other sites

@Karol I'm going out on a limb but the difficulty you are experiencing might be down to not having SHA256 patches installed to your Windows 7. Read through these two threads (you'll have to read through them in their entirety to get a proper handle on what they are about) and see if the information in them is relevant to your problem.



At one point in time I had issues with not being able to install some software to Win7 (just as you are) but installing the SHA2 patches cured the issue. That said, I wasn't getting the same error messages you are getting, but reading your posts here I end up thinking that maybe the problems are related to these SHA2 issues and associated changes Microsoft introduced to software installing (third-party software and Microsoft Updates) because of them.

Edited by Radish
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...