Jump to content

[WIP] Windows Vista Extended Kernel


win32
 Share

Recommended Posts

 image.thumb.png.b40fffc7034f20cbb982fd77d71a23e1.png

Microsoft Edge finally works, all you have to do is set global OS spoofing to NT 6.1 build 7601.

 

Update: Logging in to sync is not working, because it requires IE 11 (it's curious that modern Chromium-based browser requires old IE to get some components work).

Edited by Ark_mage2180
  • Like 2
Link to comment
Share on other sites


I noticed that several applications tried to call the unavailable function CreateRemoteThreadEx, often through the VC++ runtime, and crash, if they were spoofed to NT 6.1. As these applications may require a spoof to NT 6.1 to bypass version checks in the future, I am adding that function.

  • Like 2
Link to comment
Share on other sites

16 hours ago, Ark_mage2180 said:

 image.thumb.png.b40fffc7034f20cbb982fd77d71a23e1.png

Microsoft Edge finally works, all you have to do is set global OS spoofing to NT 6.1 build 7601.

 

Update: Logging in to sync is not working, because it requires IE 11 (it's curious that modern Chromium-based browser requires old IE to get some components work).

I'm not a big fan of global Os spoofing, I prefer that all apps would know that I'm using Windows Vista and spoof individual apps. I just use global spoofing when I install something that require it. Regarding Edge, it at least work without spoofing.

  • Like 1
Link to comment
Share on other sites

Did Python 3.10 with the modified api-ms-win-core-path-l1-1-0 and ExKernel work properly in Vista? I'm having issues with a Python program compiled with Python 3.10 (PGAdmin for PostgreSQL Web Admin tool), and don't know if it's cause Python isn't working properly or the program directly gives a compilation error due to some error of the program itself.

Link to comment
Share on other sites

We will soon be able to use OBS 28.0 beta 2 as well as PCSX2 x64 (wxWidgets version for now - Qt version has complicated Windows 10 1803 functions):
unknown.png

The small DirectX extensions seem to be working. I want to take them further and go in the direction of newer graphics drivers, Vulkan and ultimately DX12 (it will come in some way - either with Vulkan using vkd3d or D3D12on7 with 2018/19 GPU drivers; and a tiny possibility of using WDDM 2.0 drivers, but that could be quite complicated)

  • Like 2
  • Upvote 2
Link to comment
Share on other sites

56 minutes ago, mina7601 said:

still not work even with OS version spoofing...

It only works with the portable "Zip" version of the latest Audacity versions... but I want the installer instead of portable version...

Edited by Brickedandroid
Link to comment
Share on other sites

6 hours ago, Brickedandroid said:

still not work even with OS version spoofing...

It only works with the portable "Zip" version of the latest Audacity versions... but I want the installer instead of portable version...

Yeah, the post I linked isn't a solution, but rather an explanation of why the installer version doesn't work.

Link to comment
Share on other sites

29 minutes ago, mina7601 said:

Yeah, the post I linked isn't a solution, but rather an explanation of why the installer version doesn't work.

It just doesn't run at all, with error sound, but no error/crash message and then the Audacity installer process disappears immediately from Task Manager

Link to comment
Share on other sites

2 minutes ago, Brickedandroid said:

@win32 Is there still support for build 6002?

No.

As for the Audacity installer, there are some missing functions. But it is 32 bit, and adding functions (presumably user32 ones) will cause substantial breakage at this time.

Link to comment
Share on other sites

2 minutes ago, win32 said:

No.

As for the Audacity installer, there are some missing functions. But it is 32 bit, and adding functions (presumably user32 ones) will cause substantial breakage at this time.

No, now the 64-bit version is available since version 3.x.x

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...