Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
spaztron64

(SOLVED!) Problems installing Windows 2000 SP4 on a Thinkpad T420

Recommended Posts

EDIT: @blackwingcat's modded 2018 acpi.sys fixes everything (http://blog.livedoor.jp/blackwingcat/archives/1974336.html).

Man, where do I even begin?


The setup complains how the BIOS is not ACPI compliant. Skipping this is only possible by using the "Standard PC" HAL...which is obviously not good for a multicore laptop.
Switching to ACPI Multiprocessor HAL post-install leads to 0x7b "INACCESSIBLE BOOT DEVICE", and switching to MPS Multiprocessor leads to c000021a "The Session Manager Initialization system process terminated unexpectedly with a status of 0xc000026c".

The EHCI controller drivers refuse to work, likely because of the Standard PC HAL.

Hjalp mig.

Edited by spaztron64
SOLVED!

Share this post


Link to post
Share on other sites

I have a report from a user on an X230T, who stated that the regular ACPI HAL worked somehow. If that doesn't work, you can install BWC's Extended Core v16a which has updated HALs and try changing them then.

The EHCI driver issue should not be related to HALs (since they do apparently work with the MPS HAL), though here are the instructions to get them working:

 

Share this post


Link to post
Share on other sites

Unfortunately, even after updating to Extended Core, switching to ACPI Multiprocessor PC results in INACCESSIBLE_BOOT_DEVICE.
I have also just read this topic (https://www.experts-exchange.com/questions/20820090/inaccessible-boot-device-after-Multiprocessor-Upgrade.html) that says that switching from non-ACPI to ACPI is very problematic.

EDIT: Switching to MPS Multiprocessor after installing ExCore v16a results in a hang at Mup.sys

Edited by spaztron64
Update on the situation

Share this post


Link to post
Share on other sites

Can someone upload this acpi.cab patch here or somewhere else, i can not download from blackwingcat server (server error forbidden)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...