Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


schreiberstein

Windows 98 on Intel Z390 platform

Recommended Posts

Hello there!

 

My machine:

GIGABYTE Z390 Designare motherboard

Intel Core i9 9900K

32 GB Dual Channel DDR4 memory kit

EVGA nVidia GeForce 780 GTX (3 GB of VRAM)

1 TB SSD attached via internal Intel SATA AHCI controller

--> CSM Mode enabled

--> 4 External PCI slots via Exsys EX-1010 extension box

-----> Currently Creative Audigy 2 ZS installed

 

Currently, MS-DOS 7.1 standalone (from Windows 98 SE) works, but I needed to replace himem.sys with himemx.exe from FreeDOS, otherwise EMM386.EXE would not work properly and booting would take a long time. (Something like Machine type unknown occurred when running regular himem.sys)

I am trying to get Windows 98 SE working on this machine, but I am hitting a major roadblock.

I was able to complete the first stage of installation (before the first reboot) by doing the following:

- Creating a new FAT32 partition using the aforementioned MS-DOS install (format /Q /S /V:WIN98 D:)

- Adding himemx.exe into a new CONFIG.SYS file

- Adding EMM386.EXE into a new CONFIG.SYS file

- Starting setup from disk via setup.exe /is /pi (NO ACPI)

 

After the first reboot, I was told that there is not enough memory to initialize the system.

I worked around that by installing the RLOEW memory patch onto the system. (I bought it a couple months before he deceased.)

I also tried adding the MaxPhysPages parameter to SYSTEM.INI, restricting maximum memory to 512 MB via burnmem.sys, and some other workarounds.

Before that, I also checked that HIMEMX is actually being loaded. I deleted himem.sys from the Windows directory just to be sure.

The AHCI patcher from RLOEW did not seem to make any difference on my system. Perhaps the legacy mode is not supported anymore.

 

However, no matter what I do, with both Windows ME and Windows 98 SE I get the following black screen message:

While initializing device VCACHE:

Windows protection error. You need to restart your computer.

 

Windows 3.11 also freezes when starting via win.exe. Not even the splashscreen is displayed.

 

Do you have any idea how I could fix this and get Windows 98 to boot? Or how to troubleshoot this problem further?

This is so strange. Usually, Windows 98 "just works" on any x86 compatible machine, from my experience.

I guess a lot of things have changed since Skylake and Z170...

 

I would be happy if anyone on here could give me an advise on this.

Thanks a lot.

 

Cheers,

schreiberstein

(PS: It's my first post on this forum, but I have been lurking on here for years and appreciate this place a lot!)

Share this post


Link to post
Share on other sites

> EVGA nVidia GeForce 780 GTX (3 GB of VRAM)
3 GB of VRAM worries me, even with rloew's ram patch. Try also his nVidea patch or use an old video card until W98 is installed.

How are the keyboard and mouse connected? The USB3.1 might be a problem if basic USB1 drivers don't work with it.

Share this post


Link to post
Share on other sites

Hello!

Thanks for your reply!

I will try his nvidia patch, though I do not intend to use this modern video card as the primary video device for Windows 98.

My goal is to get it working and then swap in compatible PCI extension cards to make it usable.

I have a working PS/2 keyboard and mouse attached. It works flawlessly.

On a bare x86 Windows XP install, I get about 904 MB of RAM. (I guess onboard devices such as the Intel HD Graphics and my main GPU reserve the rest of 3.25 GB)

I just wonder how all of this is related to VCACHE. I was unable to find any similar crashes online that were not due to faulty drivers on an already installed system.

 

Cheers,

schreiberstein

Share this post


Link to post
Share on other sites

IMO, you've mixed too many parts together for starters. :angel

If you're using rloew's RAM patch you should not need HIMEMX, and unless you have some specific reason for using it, you most definitely don't need EMM386. Nor do you need to limit MaxPhysPage... (what is burnmem.sys? :blink:) When using PATCHMEM, you can forget about all of the "tweaks and workarounds" used by those without it.

re: Slow Boot due to unrecognized Machine Type... I've seen this problem once on an AMD machine. Newer systems don't handle Gate A20 in a 9x-friendly way. Setting /MACHINE:1 on HIMEM.SYS in CONFIG.SYS may solve the issue.

I've not used rloew's AHCI driver yet, so I can't address that part specifically... If you have the option on that board to use Native SATA mode (may be labeled as "IDE") then it should work with his SATA patch, but I doubt that option is still present. Maybe someone who has used the AHCI driver can comment on this.

Newer motherboard manufacturers no longer care about optimizing their BIOS code for x86 operating systems. They assume everyone will be using x64, so they don't bother to optimize the MMIO RAM allocation to make the most memory available to x86. I had an X99 system where only 1873MB of RAM was available to a 32-bit system when 4GB was installed; this later increased to 2910MB after a BIOS update but I never could manage to get their tech support to understand the problem. A good BIOS modder might be able to help with this, but they're hard to find in my experience. Newer video cards usually use a "memory banking" method to avoid tying up all of the 32-bit RAM.. since your 780GTX is XP compatible it should do this, but who knows what the onboard Intel HD Graphics will do.

I've had 9x up and running on my X79 and X99 systems. I have an X299 system that has yet to see any experimentation with any OS... I detest onboard graphics to begin with, and the fact they're no longer supporting XP rules chipsets using them out completely. The "X" series boards and processors may cost more, but it at least rules out one set of legacy compatibility problems.

Share this post


Link to post
Share on other sites

On my ASRock H110M-DVS R3.0 motherboard, I need HIMEMX.EXE even when using rloew's RAM Patch, or else 98SE is stuck on the boot screen. It's probably what LoneCrusader is talking about the /MACHINE:1 switch, never tried that myself as I have always used HIMEMX.EXE, will try that when I get a chance.

Why do you need EMM386.EXE? I do not need it to install 98SE on my H110 motherboard, try without it.

Try using the integrated GPU rather than the GTX 780.

Try installing 98SE without the PCI slot box thingy connected.

You do not need AHCI driver to get 98SE to boot on new AHCI only motherboards. After the system is installed, you will simply have legacy 16-bit Disk Access that is noted in the Performance tab in System properties. ESDI_506.PDR is not used at all.
After you have 98SE booted, then you can install the AHCI driver (by selecting one of the PCI Card devices in Device Manager) and enjoy the full 32-bit Disk Access.

And finally, try obtaining a PCI-E 98SE compatible GPU, those include the GeForce 6/7 series, and ATI Radeon X300/X550/X700/X800/X850 series.

You can also try removing some RAM sticks if possible.


 

 

 

 

Edited by MrMateczko

Share this post


Link to post
Share on other sites

Hm...

I tested with a GeForce 7500 again, onboard graphics completely disabled. Windows For Workgroups 3.11 also hangs with blinking cursor.

Windows 98 SE still hangs with the same VCACHE initialization error.

I am looking for my VIA PCI IDE controller to check if it has to do with the AHCI controller.

Standalone MS DOS 7.1 runs very well with HIMEMX, also more advanced applications. File access on the ACHI disk works flawlessly in DOS extenders as well.

But I am quite lost. I will try to do a fresh install of 98 SE and add /MACHINE:1 to config.sys, but I think there is something else blocking it.

Is there some kind of debugger I could attach / run in the background to see what causes the system to fail?

I wish I had asked RLOEW before he passed, but I thought "I can still ask him about his patch later", oh well. :-/

I wonder if anyone has successfully booted Windows 98 on Z390 yet. I did not find anything about it yet.

 

Cheers,

schreiberstein

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...