Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


schreiberstein

Member
  • Content Count

    2
  • Donations

    $10.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About schreiberstein

Profile Information

  • OS
    XP Pro x86
  • Country

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello! Thanks for your reply! I will try his nvidia patch, though I do not intend to use this modern video card as the primary video device for Windows 98. My goal is to get it working and then swap in compatible PCI extension cards to make it usable. I have a working PS/2 keyboard and mouse attached. It works flawlessly. On a bare x86 Windows XP install, I get about 904 MB of RAM. (I guess onboard devices such as the Intel HD Graphics and my main GPU reserve the rest of 3.25 GB) I just wonder how all of this is related to VCACHE. I was unable to find any similar crashes online that were not due to faulty drivers on an already installed system. Cheers, schreiberstein
  2. Hello there! My machine: GIGABYTE Z390 Designare motherboard Intel Core i9 9900K 32 GB Dual Channel DDR4 memory kit EVGA nVidia GeForce 780 GTX (3 GB of VRAM) 1 TB SSD attached via internal Intel SATA AHCI controller --> CSM Mode enabled --> 4 External PCI slots via Exsys EX-1010 extension box -----> Currently Creative Audigy 2 ZS installed Currently, MS-DOS 7.1 standalone (from Windows 98 SE) works, but I needed to replace himem.sys with himemx.exe from FreeDOS, otherwise EMM386.EXE would not work properly and booting would take a long time. (Something like Machine type unknown occurred when running regular himem.sys) I am trying to get Windows 98 SE working on this machine, but I am hitting a major roadblock. I was able to complete the first stage of installation (before the first reboot) by doing the following: - Creating a new FAT32 partition using the aforementioned MS-DOS install (format /Q /S /V:WIN98 D:) - Adding himemx.exe into a new CONFIG.SYS file - Adding EMM386.EXE into a new CONFIG.SYS file - Starting setup from disk via setup.exe /is /pi (NO ACPI) After the first reboot, I was told that there is not enough memory to initialize the system. I worked around that by installing the RLOEW memory patch onto the system. (I bought it a couple months before he deceased.) I also tried adding the MaxPhysPages parameter to SYSTEM.INI, restricting maximum memory to 512 MB via burnmem.sys, and some other workarounds. Before that, I also checked that HIMEMX is actually being loaded. I deleted himem.sys from the Windows directory just to be sure. The AHCI patcher from RLOEW did not seem to make any difference on my system. Perhaps the legacy mode is not supported anymore. However, no matter what I do, with both Windows ME and Windows 98 SE I get the following black screen message: While initializing device VCACHE: Windows protection error. You need to restart your computer. Windows 3.11 also freezes when starting via win.exe. Not even the splashscreen is displayed. Do you have any idea how I could fix this and get Windows 98 to boot? Or how to troubleshoot this problem further? This is so strange. Usually, Windows 98 "just works" on any x86 compatible machine, from my experience. I guess a lot of things have changed since Skylake and Z170... I would be happy if anyone on here could give me an advise on this. Thanks a lot. Cheers, schreiberstein (PS: It's my first post on this forum, but I have been lurking on here for years and appreciate this place a lot!)
×
×
  • Create New...