Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Windows 98SE not 4X AGP, but 2X AGP

Recommended Posts


If I install a higher driver from Nvidia for my Geforce 4 ti 4600 on my Windows 98SE PC than version 45.23 then the PC switches back to 2xAGP. I have this driver version 4.38 from Via on it for the AGP port. Others via drivers unfortunately do not help to turn it into 4x agp again.

This is My Windows 98SE PC

Pentium 3 1400 mhz |
Video card: Geforce 4 ti 4600 128mb
Memory: 512 MB Memory
Motherboard: Shuttle AV18
SCSI adapter: Adaptec 29160N
HDD: ST373455LC
Sound card: Creative soundblaster live 1024

Here with 56.64

2x agp aida64.png


and here with 45.23

4x agp aida64.png

4x agp.png

Who knows what I can do about this?

I need newer drivers from Nvidia for The Sims 2 and 3d mark 2003 to work properly.


Edited by egbertjan
Link to post
Share on other sites

Does Sims 2 & 3DMark03 work with the newer drivers? If the game works with newer drivers then it might be nothing too concerning. I know that the AGPx2 supply voltage is 3.3V & AGPx4 is 1.5V but this should not have changed with the updated driver as it would be a BIOS setting. The AGPx2 cards had a better chance of working in an AGP Universal slot than did the AGP cards slotted to fit AGPx4 port/slot only. It would be the maximum transfer clock divided by 2, 4 or 8 for different AGP modes. See if BIOS is set up for AGPx4 because the 56.64 driver says AGPx2 bus. It might be set for auto or a driver reporting error. Although it will not be a concern, I have used AGPx1 or x2 setting in BIOS & chose a small video memory window when card is not working properly. Your card is good most likely. Check 3Dmark03 and see if it gives a reasonable result. When updating driver install a standard graphics driver first, reboot then install other driver, this is important.

Edited by Goodmaneuver
Link to post
Share on other sites

Did you try the 77.72 drivers? By the way, in my experience its better to reboot first after driver installation in safe mode and remove ALL Nvidia entries in MSconfig/ Startup. 

Link to post
Share on other sites
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...