Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
supernova777

looking for ATI XPERT 128 GL PCI bios/rom for PC

Recommended Posts

hey there i have a few mac pci video cards laying on a shelf that id love to get workign with some old vintage windows/dos PC i have

the rage 128 GL card that came originally with the POWERMAC G3 B+W computer

i have two of them on a shelf pmg4-pci-rage-128-1.jpg?fit=800,520

i need a PC VGA BIOS/ROM to flash them with to have them recognized on my pentium 75 computer; it  has a radeon 7000 in it right now 

but i need better driver support in windows 95; and getting a VXD error on boot up; and slow graphics speeds (refreshing IE5 pages lol)

if anyone knows where i can find a bios/rom for the card please help

https://www.vogons.org/viewtopic.php?f=46&t=31592&p=770251#p770251

see this page for more info 

https://www.techpowerup.com/gpu-specs/rage-128-gl-pci.c1718

Edited by supernova777

Share this post


Link to post
Share on other sites

Posted (edited)

If the card shows boot screen on the IBM compatible and nearly works, I do not think it would have special flash for MAC. Have you tried them on a newer/different machine. If your Pentium 75 machine does the same thing with both cards it still could be the machine. Some drivers drivers do not work properly and I think from memory it is the one that came with WinME that only works but this might have been for a different earlier card. If using 6-2_wme_dd_cp_30314, latest ATI driver, then ATI2CQAG.DL_ has to be replaced with an earlier driver file for all cards. Replacement ATI2CQAG.DL_ is from driver 4.15.1.9163 17/08/2005. ( Day/Month/Year ) If this file is not back dated then the performance will be as you experience. I tried my Rage 128 same as your picture in current machine and the machine pipped through the system board speaker but had no video output. It has been a good card and probably still is in the right machine.
 

Edited by Goodmaneuver

Share this post


Link to post
Share on other sites
Posted (edited)

i have a motherboard with an award bios. although released much later than a pentium 75 board, I had a pci SIS 6326 GPU card on it with an obselete bios. I couldn't upgrade it because it required a technique that could damage the gpu. But what i did was physically removed the GPU bios chip and loaded the updated GPU bios code into a section of the pc bios so it wouldn't need to load the updated bios as a system TSR at boot time. OEM options are endless with pc bios and an avenue to look into but not for motherboards with built in gpu option as it may overwrite it, interfere or just won't load more than one at a time (damn you again foxconn).

Edited by ZaPbUzZ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...