Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
sonyu

Intel UHD 600 drivers w8.1: Display adapters not showing up in Device Manager

Recommended Posts

On 4/3/2019 at 3:30 AM, sonyu said:

This is a bios dump I have made using FPTW64 (Flash Programming Tool) if somebody can analyze it:

http://www.mediafire.com/file/usb8lspzi59mw9w/biosreg.bin/file

And another backup I made using H2OFFT-W:

https://www.mediafire.com/file/d9jbkn2ju3gksfc/backup.bin/file

What BIOS do you have? Is it actually Insyde?

Share this post


Link to post
Share on other sites

@sonyu

The links you posted (not the mediafire ones, all the other ones) are not valid, they have been shortened, probably from a copy and paste from some other post.

 

jaclaz

Share this post


Link to post
Share on other sites

yes! sorry!! I edited all the links @jaclaz now are correct

 

Share this post


Link to post
Share on other sites

These Insyde BIOS are a real pain, there doesn't seem to be anything I can do with this as I do not have the tools. Everything I know about it involves hex editing and unfortunately there is no "key" for what is what.

Share this post


Link to post
Share on other sites

Hmmm,

WHOOOOSH!

that is the sound of this stuff just passing over my head :w00t: :ph34r: , anyway (and without any guarantee of sorts that it works, or that it is useful, or that applies to your BIOS, etc.) here is a detailed tutorial on how to check the modules and stuff and enabling the "Advanced" tab (which may be what is needed, or maybe it isn't :unsure::

https://web.archive.org/web/20150215185157/http://donovan6000.blogspot.com/2013/06/insyde-bios-modding-advanced-and-power-tabs.html

jaclaz

Share this post


Link to post
Share on other sites

If anything, there are some issues with this ROM that the OP is using. It has an RSA cert on it, so it cannot be modified like that, or (from what I understand) it can, but can brick the system when flashed, if the flashing util even allows it.

However, that link has lead me to this other thing that may be useful instead, without having to actually hack the rom (or fd) file itself.

https://www.bios-mods.com/forum/Thread-READ-FIRST-Access-Advanced-settings-through-EFI-shell?pid=56913#pid56913

Share this post


Link to post
Share on other sites

Hi everybody,

 

I2C & GPIO it's only related to touchpad and has nothing to do with Intel UHD 600.

I can boot a version between windows 8.0 and 8.1. This beta version: windows build 6.3.9369 and it recognizes in Device Manager my Graphic cards with Microsoft Basic Display adapter however the hardware id it's correct & detected (VEN_8086&DEV_3185).

So now.. I tried to make a modified INF driver with no lucky.

Can somebody help me?

I tried adding this to a inf file:
%iGLKGT2E12% = iSKLD_w81, PCI\VEN_8086&DEV_3185

and also tried what I supposed it's a compatible version based on what I read in notebookcheck (previous model Kaby Lake based): iBXTGTP12 Intel HD 500

https://www.notebookcheck.net/Intel-UHD-Graphics-600-GPU.271820.0.html
https://www.notebookcheck.net/Intel-HD-Graphics-500.182723.0.html

UHD Graphics 600 12 @ 300 - 700 (Boost) MHz 64/128 Bit
HD Graphics 500 (compare) 12 @ 300 - 700 (Boost) MHz 64/128 Bit

Well,

these are the interesting links I have about modding Intel HD drivers:

This is the -official- driver I am currently running on WINDOWS 10 RTM 10240 TH1):
https://forums.laptopvideo2go.com/topic/32095-2220164836-15491-8th-7th-and-6th-generation-coffee-lake-kaby-lake-skylake-gemini-lake-and-broxton-apollo-lake-windows-10/

It is possible to port it to w8.1? 

This is what I read:


https://www.techinferno.com/index.php?/forums/topic/12377-way-to-make-intel-uhd-620-graphics-driver-to-works-in-windows-7-no-crash-in-video-play-back-3d-function-normally/&tab=comments#comment-168268

"The graphics processors on not only Intel 6th gen mobile, but also all 7th and 8th gen processors are all based on Gen 9 LP (generation 9 Low Power) graphics core architecture.
" --> https://www.texpion.com/2018/06/Intel-7th-and-8th-generation-processor-graphics-driver-for-Windows-7-8-8.1.html


https://forums.laptopvideo2go.com/topic/33299-win-7-andor-win-81-display-driver-for-gemini-lake/
https://forum.videohelp.com/threads/390651-Way-to-make-Intel-UHD-620-graphics-driver-to-works-in-windows-7-(no-crash)

Can I use something from there forum links?:
Win 7 x64 Coffee Like UHD 630 Video driver (3)
[OFFER] 7th/8th Gen. Intel GPU drivers for Win7/8.1



Can somebody make a modded w8 driver for: %iGLKGT2E12% = iSKLD_w81, PCI\VEN_8086&DEV_3185

If I run dxdiag on 6.3.9369 it uses WDDM 1.3 (default 8.1 wddm)

When I boot to 6.3.9369 and opened device manager I can see yellow exclamation under Display Drivers -> Microsoft Basic Display Driver

and if I open Properties -> General I can see:

"This device is currently waiting on another device or set of devices to start. (Code 51)"

Just trying updating to win10 rtm uhd 600 driver and the same.

I also tried this one I just found right now which has the hardware id..but only installs an audio driver:

https://www.win-raid.com/t4346f42-OFFER-th-th-Gen-Intel-GPU-drivers-for-Win.html#msg103355
https://www.win-raid.com/t5684f52-Problem-installing-intel-UHD-on-Win.html

and the same, I get the code 51 error.. don't know why since I have all the devices installed on device manager and only 4 without install which are the ones commented in the first post:

ACPI\INT3453\1
ACPI\INT3453\2
ACPI\INT3453\3
ACPI\INT3453\4


I'm gonna try installing with the "adding legacy hardware" way in a full windows 8.1 6.3 rtm installation since I can't boot to w8.0 due to ACPI_BIOS_ERROR

It's a shame because windows 8 flies on this hardware compared to w10..

_____

It needs to be something related to w8.1

Some people with previous GEN (HD 500) has the same problem under windows 8.1 as you can read here:

_ttps://answers.microsoft.com/en-us/windows/forum/all/mysterius-intel-hd-graphics-compatibility/e8365c5c-5b5f-4b28-b250-c00780a05b64

I don't know how can I boot w8.0, I will try to get another beta build based on 6.2 and WDDM 1.2 to see what happen and if the code 51 disappears..

 

Maybe I need to change something in bios? You can see all my bios options here (attached .txt file)

 


Lot of thanks,

Regards

LENOVO BIOS OPTIONS - Section_PE32_image_DriverSampleDxe_SetupUtility IFR2.txt

Edited by sonyu

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...