Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


ruthan

Win98SE debug,normal boot freezing + Rloew patches (RAM/SATA/NVSIZE/AHCI) installation debugging, NVU 82 drivers

Recommended Posts

Quote

 

Uninstall my RAM Patch, disable the NIC Driver and try your Safe Mode Patch (it is not an IO.SYS Patch). See if it makes a difference.
Reinstall my RAM Patch, and nothing else, and see if the problems return.

  If you are talking about AMD970 machine, no NIC still there to minimize problem during testing..
  I was trying combo RAM patch, no patched io.sys yesterday, it was that 160GB HDD crashfest.. It dont need to patch io.sys when im using you patch, i thing that i tried your ram pach and patche io.sys together and it was ok, from point of view booting, but crashing was same..

 

I wonder, if split8MB (im using because of Gb NIC boot), couild be used without rest of rampatch, with himem.exe 3.32, which i im using for ro too much ram fixing?

I tried to find you what is exactly my io.sys magic patcher..
Its name as IO.sys patch to replace himem.sys by Himem.exe byRayeR.. compiled 2008, its using japheth.de HimemX.exe 3.32, but is renamem to Himem.exe i dont know why. I dont know if there is newer version but its working.
  Its all moding System.init - MaxPhysPages=4000;MaxFIleCanche=, MinFileChache =261120 ,32768 ChunkSize=4096

  All instalallation without our RAM patch was stable - 0 rundll issues on 160 GB hardware, until i have intalled Nvidia drivers, after that Gaming was or not freezes, but right click on desktop stopped working (nvidia panel is there) and explorer started to do errors, but no so much as with your ram patch and no any data corupptions, registry recovery infinite scandisk restarts etc..

So summary is:
Ram patch a non Nvidia driver - no go
Rl Ram patch + Nvidia driver - no go
Japhet Ram patch + No video - all ok, no issues
Japhet Ram patch and video - no go, game are working, but explorer is broken (desktop is using NV controll panel extender).. So question is how much are Japhet patch, Unofficial Nvidia driver and your patches compatible and on which side is a problem.

   I can say how many thing are doing fixed nvcore.vxd and what could be Nvidia driver problem, but i just expented that machine would work all together, because patch which still led machine not useful sucks.

Edited by ruthan

Share this post


Link to post
Share on other sites

If you are having data corruption issues then you will have to do a clean install as anything you have can no longer be trusted.

The only way to find out is to run your System twice, once without ONE of my Patches, and once with that Patch added back, everything else being the same.

You can combine my RAM Limitation Patch with any other RAM workaround. It would actually be a better comparison since the amount of RAM would not increase when you add my Patch.

SPLIT8MB can be used separately.

You can reflash your Video Card BIOS as an alternative to using the PATCHNVC Program. You probably will still need the PATCHOPT Program.

Share this post


Link to post
Share on other sites

I did lots of experimenting, i have not time for reporting.. but few main things:

1) At least on 1 machine a find root cause of microfreezing - Anvir Task manager free - it looks nice, show nice thing, but its broken, so it wasnt drivers thing, but on unraid machine, when i had freezes too i have this thing never installed and microfreezes were fixed by USP3 .. 

   On last freezing machine is this SW installed too, but i had to fix boot with AHCIBIOS - its now booting only into Safe mode.


2) I have tried on AMD970 and X99 machine AHCIBIOS patch, i wasnt able to boot with it, without parameters, no controller find, with NOINT boot freeze, i getting even freezes in Dos command prompt boot option i just tied cd directory.. i got freeze

3) Here some logs and pictures from AMD970 + 160GB  installation. I found in Device manager some problems (which i dont have in my imported AMD970 old install - which is now probably most stable..), i thought they are clasical missing drivers, but i have there some conflicts. On old installation im conflict free, but i have also USP3 installed - i dunno if it matters for it, but even components names are a bit different.

 Here is PCIscan output:
 

 0  0  0:  1002:5a14 1002:5a14 0600 00  02 
 0  0  2:  1002:5a23 1002:5a23 0806 00  00 
 0  2  0:  1002:5a16 0000:0000 0604 00  00 
 0  5  0:  1002:5a19 0000:0000 0604 00  00 
 0  7  0:  1002:5a1b 0000:0000 0604 00  00 
 0 17  0:  1002:4391 1043:84dd 0106 01  40 
 0 18  0:  1002:4397 1002:4397 0c03 10  00 
 0 18  2:  1002:4396 1002:4396 0c03 20  00 
 0 19  0:  1002:4397 1002:4397 0c03 10  00 
 0 19  2:  1002:4396 1002:4396 0c03 20  00 
 0 20  0:  1002:4385 1002:4385 0c05 00  42 
 0 20  1:  1002:439c 1043:84de 0101 8f  40 
 0 20  3:  1002:439d 1002:439d 0601 00  40 
 0 20  4:  1002:4384 0000:0000 0604 01  40 
 0 20  5:  1002:4399 1002:4399 0c03 10  00 
 0 22  0:  1002:4397 1002:4397 0c03 10  00 
 0 22  2:  1002:4396 1002:4396 0c03 20  00 
 0 24  0:  1022:1600 0000:0000 0600 00  00 
 0 24  1:  1022:1601 0000:0000 0600 00  00 
 0 24  2:  1022:1602 0000:0000 0600 00  00 
 0 24  3:  1022:1603 0000:0000 0600 00  00 
 0 24  4:  1022:1604 0000:0000 0600 00  00 
 0 24  5:  1022:1605 0000:0000 0600 00  00 
 1  0  0:  10de:0295 1462:0663 0300 00  a1 
 2  0  0:  1b21:1142 1043:85bf 0c03 30  00 
 3  0  0:  1b21:1142 1043:85bf 0c03 30  00 
 4  5  0:  13f6:0111 13f6:0111 0401 00  10 

 

DMAControllerError.pngDMAController.png

MOTHER10Error.pngMOTHER15Error.png

MotherSecondNoConflct.pngMotherBoardResourcesError.png

I dont know if this i also problem of 40 GB / AMD 970 installation, i will have to check it.

 How to fix these conflicts, in Windows 95 was possible change some adress range manually, but in Win98?

 

Edited by ruthan

Share this post


Link to post
Share on other sites

Did you run SCANPCI on your X99 system? I don't see any Intel ID's in that list. OK, saw this in the other thread.

I see ACPI issues for certain. ACPI controller and motherboard resources causing problems. This is very common.

You need to install Windows 98 with the "SETUP /p i" command to prevent ACPI from loading.
Then do not remove any devices and manually install PCI Bus.

If your motherboard BIOS allows setting the SATA controllers to IDE Mode then you shouldn't need AHCIBIOS unless you want to use AHCI in another OS.

Share this post


Link to post
Share on other sites

DISKBIOS/AHCIBIOS does not support CD Drives. You should not Install CD Drivers in DOS.

Share this post


Link to post
Share on other sites

I will write long post later, meanwhile im getting better and better i Windows 98 drivers ring of suffering..

  Justt 1 important note AMD970 im not able to boot with into normal mode with both memory patches (paid and Rayer) when is Intel 1000S MT Desktop adaper installed, even with Split8MB patch, im geeting System protection errors, or NIC or NIC protocol related errors in bootlog or ESDI related crash. I have all some strange 2D mouse freezes when im messing with NIC, so maybe time to do something with INT, otherwise i can say and RamPatch and Split8MB are not working how they suppose to.. I bought RAm patch because of GB NIC and never were able to boot with it inside - did minimally 3 clean installs, other OSes are still fine..

Share this post


Link to post
Share on other sites

NIC Errors have nothing to do with my Patches.

Why are you still using both RAM Patches. That was for bug verification only.

You already have a NIC in the AMD970. Adding another one may be causing problems.
I never promised my Patch would support two NICs. I knew it would work with the AMD970's Internal NIC.
You already said it booted when I sold it to you.

The fact that SPLIT8MB is needed suggests that an yet unknown limitation may be near.

Share this post


Link to post
Share on other sites
Quote

If your Disk Controller is not in AHCI Mode, you MUST have SATA.INF Installed. If you had, you would have seen both SATA and ATA0106 Drivers in Safe Mode.
You can't tell what is being recognized in Safe Mode. It tells you what Drivers are installed, not what is recognized.
Only in Normal Mode do you see what is recognized. You will have to Install SATA.INF, run  PURGEHDC P A  and reboot to redetect.
Later you can switch to AHCI Mode and reboot will redetect the ATA0106 Driver.

   Few clarification to Conroe fixing, i dont have today enough time for AMD970, this i hope would be quicker.

 1)  So if understand it right, have to for installation (i want to apply this to existing installation ) start with IDE mode, i cant do whole process with BIOS - AHCI settings? Im right.
       Problem is that is not posssible when i switch my board to IDE mode, my SATA disc is not even detected, so to do whole process in AHCI mode, i already wrote that.

       In safe mode i now see only ATA0106, but not SATA controller.

Quote

2) Later you can switch to AHCI Mode and reboot will redetect the ATA0106 Driver.

   Do you mean switch where in the BIOS, or by adding AHCIBIOS to autoexec, or how exactly?
 

Share this post


Link to post
Share on other sites

You switch between AHCI Boot Mode and IDE Boot Mode using the BIOS.

You can Install in either Mode.

Install SATA Patch, ATA0106.INF and AHCIBIOS if in AHCI Mode.
Install SATA Patch, and SATA.INF if in IDE Mode.

You cannot change the Mode after Installation without messing thing up, if you don't follow the proper procedure.

If you want to be able to change Mode, then Install everything for BOTH Modes when Installing Windows.
Boot in one Mode to activate one set of Drivers, then Boot in the other Mode to activate the other set of Drivers.

Share this post


Link to post
Share on other sites

We did, Conroe is now fully working with AHCIBIOS patch - no freezes (problem was in task manager replacement too), SSD transfer rates are at SATA I maximum (130 MB/s), audio is working,
Geforce 6600 GT is working, Intel 1 GB NIC is working, audio is ok, Command.com is working, shutdown is working, even DVD Write on Sata port is in device manager (not tested, but it looks fine)
   
 So everything for gaming is there.

  There two cosmetic details, but there but only first is really annoying (because i cant connect to machine through remote deskop / vnc or teamviewer or similar tool with it after machine starts..)
1) Right after start im getting blue screen some VXD error, i have to pres enter after it everything is fine.  
I wonder if it could be traced to source only with help this manage, this right before users login. It could be patches related, i also removed Magic ISO CD and installed VirtualCD Drive and finally
used nusb3.5


BootBlueScreen.jpg
   Translation On address XXX in VXD VDD(09)... happens major exception 00. Running application would be ended.  Press some key..

2) There still exclamation mark on some controller - error is no IRQ and its probably no device. 
I have tried, NOINT parameter for AHCIBIOS no change.


ConroeWorkingButExclamationMark.png

 

  Once one man said there are not big victories only small people, which feels too important.. but im happy.

  Thanks for help to everybody.

  AMD970 would be harder nut to crack, but i finally i one Windows 98 tower is not useless pipe of old hardware..

Edited by ruthan

Share this post


Link to post
Share on other sites

"Task Manager Replacement"?  What did I tell you about complicating issues with undescribed modifications.

VDD errors are associated with Graphics.

Remove the failing SATA Controller and see if it is redetected upon reboot.

If it is, post the Output of:

SCANPCI  All

Also display the Resources for the failing SATA Controller

Share this post


Link to post
Share on other sites

I still not had enough write to write proper and response, but i just isolated that problem is not ram patch, problem is combination of G7950GT patched driver + my Intel 1000 MT Desktop adapter NIC.

  I first time managed to make them boot  (clean installation) together with himem.exe  and its same as with Rloew ram patch, is Explorer is very unstable and all errors are nvidia dlls related.. No conflict in device manager, but something in that combination is really wrong. I will post some picture with error messages later. Games or other apps are working, but when i doing anything in explorer i dont have minute without error.

  I changed order of installation and installed NIC, Audio and first and videocard driver later and before it, all was fine. 

  There is very small change that unofficial driver is really bugged and that i normal, but i dont want to believe that, because otherwise make fix for it does not make a sense and whole Geforce 7 512 MB Windows 98 GPU case would be dead end, so it has to be conflict with the patched driver..

Share this post


Link to post
Share on other sites
24 minutes ago, ruthan said:

I still not had enough write to write proper and response, but i just isolated that problem is not ram patch, problem is combination of G7950GT patched driver + my Intel 1000 MT Desktop adapter NIC.

Did you install the RAM patch using the /M switch? This switch is specifically to address issues with Gigabit Ethernet cards and may help...

Share this post


Link to post
Share on other sites

You can debug the Driver by reflashing your Video Card Driver as described in the Manual for the NVSIZE Patch. After a reboot, NVCHECK can be used to verify that you did this correctly.
Then you can use the Unpatched nVidia Driver. You would still need the PCI Patch and the Interrupt Fix if you were using them.

There are a number of bugs in the nVidia Driver. My Patches fix the most serious ones.

Share this post


Link to post
Share on other sites

Ok, i finally had some time to check few things and write about my AMD970 situation.

 Little summary machine is otherwise stable and running fine in WinXP and Windows 7,
 component are always the same.
  
 HW:
 1) FX 8 core cpu + Asus M5A97 R2.0 - AMD970 board, last bios.
 2) MSI 7950GT 512 MB PCI-E (i have two of them, tested both)
 3) Soundcard CMI8738 PCI - no problems with soundcard on this setup, tried
 even different Soundcard in the process and no Nosound card or USB sound only.
 4) Intel PCI 1 Gb/s NIC, detected as Intel 1000S MT desktop adapter (by other oses,
 official Intel last driver) 
  
  
 Bellow is just 1 run of memtest picture without error, only 1 hour, but i ran whole
 day and was the was and my issues are consitent doent matters if is right after cold boot or  after of 10 hours of running, its not wary.
 
  Storages are test, all ok.
  
  I have 3 setups (below) and problems one 2 you them - cleans install are pretty
 consistent, thring older migrated install has problem before i would able to
 simulate, same issues. 
 
 A) Clean install, 40 GB HDD Seagate, WIn98 one and only partition on HDD.
   Sata patch - running fine.
   MEMpach and SPLIT installed, tested with or without System.in limiter to
   1024 MB.
   NIC installed before Nvidia drivers - running fine.
   Nvidia card - installed last
   Errors appeared.
     NO HW conflicts.
      
    No USB drivers for just to be sure.
    NO USP3.
    
      State:  Explorer errors related to Nvidia.dlls    
 
 B) Clean install,Seagate 160 GB, testing 10 GB partion on start of disk, but for sure Terabyte
 pack, ATA patche installed, LBA48 is ok.
   Sata patch no issues.
   Himem.exe limited to 1024MB.
   NO HW conflicts.
   
   No issue unless is NIC installed.
   No USB drivers for just to be sure.
   NO USP3.
   
   State: Explorer errors related to Nvidia.dlls
 
 C) Migrated install, installed without /p i option - i didnt know that 5+ years, but except USB audios issues (fixable) was tested on 7+ boards..
 ago.
  Czech Windows 98 SE, all other installation are ENG.
   SSD 120GB Intel 320 - first 10 GB for FAT32 Win98.
   Sata patch - running fine
   Patchmem (for to be sure limited to 1024 via System.ini), SPLIT8MB
  
    
  State: Machine running fine, unless is 1Gb NIC added, after that i cant even normal
   boot, bought RAM patch (SPLIT8MB) which should to fix it, but i never was able to 
boot after NIC driver installatiom.

 

    USP3 installed, USB stack removed to minimize issues, no HW conflicts..

   With Intel 100S - slower NIC is running fine.

   Error is System protection error and in boolog is error about ESDI_506 when i add Intel NIC, i 
really dont know why, because otherwise Sata patch is running fine.
 
   But Nvidia related errors are there even without NIC driver installed, errors are the same..

-----------
 D,E,F - had some memory cards in Sata or IDE adapters install to, it was
 all the same behavior.. nvidia dll erros, after all device drivers were installed..
 
  I have Geforce 7800 256 MB on the way but it could take 2 weeks, after
i would be able to test same setup without patched Nvidia driver.

  Bellow are Explorer errors related to Nvidia, are very often after 1 GB NIC drivers
are installed.

  As i maybe wrote, i see 3 main reasons for my problems:
1) Unofficial Nvidia driver is really junk and not working on any computer,
it was recommended for me here so i dont believe in it too much.
2) Something in the Nvidia patch need to adjusted /added to work with Intel 1000S 
MT Desktop (which could be in theory junk too, but i dont have any other on Nvidia
driver to collide with it)

  I hope that someone understand Windows on ASM registry level and could say something about it..

 

A) 40GB pictures, some picture are blurry but originals are readable..

2017-08-28%2016.01.41.jpg

2017-08-28%2022.40.11.jpg

 

2017-08-28%2022.58.49.jpg

 

2017-08-28%2022.58.50.jpg

 

B) 160 GB

Nvcheck:

Ncheck-Ok.jpg

 

2017-08-28%2003.02.18.jpg

Just after command.com run broken gui:

2017-08-28%2003.23.15-ColorsBrokenAfterC

2017-08-28%2003.35.00.jpg

2017-08-28%2003.40.41.jpg

 

2017-08-28%2003.44.09.jpg

2017-08-28%2003.52.18.jpg

 

2017-08-28%2004.09.58.jpg

2017-08-28%2004.10.30.jpg

 

2017-08-28%2004.10.46-ListOfDevices.jpg\

2017-08-28%2004.10.57-ListOfdevices.jpg

 

C) Bootlog hangs on ESDI after 1 GB NIC is driver is installed (Update added some new pictures here):

2017-08-29%2003.21.31.jpg

2017-08-29%2003.24.32.jpg

 

2017-08-29%2003.27.35.jpg

 

2017-08-29%2003.28.29.jpg

 


2017-08-29%2000.46.57.jpg

 

 

 

Edited by ruthan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...