Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


TsT

After usb prep - usb is locked readonly

Recommended Posts

Hi everyone,

 

So I was using WinSetupFromUSB 1.6.exe and the first time it worked for my server w2k3 R2 usb install.  Then I created a second with server 2k3 sp2.  This one errored out near the end with a message about setup.exe.  Unfortunately I didn't pay very close attention thinking that I would just retry the process. 

 

But when I did, I quickly discovered that the usb drive was readonly.  I tried several methods to remove the readonly but all of them have failed.  (editing reg, using dos - DISKPART to edit attributes, delete partition etc., win disk manager, and winsetupfromusb.)  I am at a loss.  Is there another suggested method to try to unlock the readonly usb flash drive? 

 

I haven't tried booting into linux yet.  (don't have anything set up just yet to do that.) What would have locked it and is it possible this usb drive is toast? it's brand new but only a 1 gig drive.  I can read the drive just fine and it boots up a machine but errors out on installing w2k3.  Any help would be greatly appreciated.  Thank you for your time.

 

J

Share this post


Link to post
Share on other sites

I'd say the drive is just faulty.

Share this post


Link to post
Share on other sites

Ok thanks for the reply.

 

I figured that might be the case when I couldn't change the readonly with diskpart.

 

J

Share this post


Link to post
Share on other sites

It is a - if not common - frequent enough issue, the stickl controller "decides" to turn itself into "read only".

There are some speculations about this being a form of "safety" when there is an error of some kind in the working, when writing files to it, possibly the idea is "better to keep accessible though read-only what has been written successfully".

 

Basically once the sticks are (mass) produced they are formatted/tested with this special software that more or less should find defective areas of the memory and exclude them from the area accessible to the user or allow to mark the stick as "bad", it is very possible that an area of the stick memory went bad after that test and "low level format" or that for *any* reason a defective area was included in the accessible area.  

 

In some cases it is possible to "reset" the stick to factory settings using some special manufacturer software, and there are reports of sticks that once reset successfully continue to work OK for years and of stick that re-lock themselves as soon as something is written to them or however very soon after having been reset.

 

For a 1 Gb stick, probably it isn't worth the hassle to find (if available) the Manufacturer's Tool and to attempt the reset.

 

jaclaz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...