Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
netbookdelgob

Intel G41,etc video chipsets no opengl support (Fix)

Recommended Posts

Hello!

 

There is a problem when updating to windows 10, your intel video graphics driver is updated to its latest windows update version, thats good, but... it doesnt have opengl support.

 

There is a solution.

 

1)Download the old windows 7 driver (G41 doesnt have driver for 8)

2)Remove the driver (with the software) from device manager (it will install standard vga controller)

3)Extract the .exe or .zip, go to "Graphics" folder

4)Open the .inf file

Find the line "CatalogFile=kit49659.cat" and put a ";" before it:

[Version]
Signature="$WINDOWS NT$"
Provider=%Intel%
ClassGUID={4D36E968-E325-11CE-BFC1-08002BE10318}
Class=Display
;CatalogFile=kit49659.cat

Go to

[IntelGfx.NTx86.6.2]; no install on Win8[IntelGfx.NTx86.6.0]

Swap it, put

[IntelGfx.NTx86.6.0]; no install on Win8[IntelGfx.NTx86.6.2]

Now save the .inf and close, right click and select install, it will prompt about the driver is not signed, install anyway, wait until a message appears.

Then go to device manager, select "standard vga", right click and update. Select the second option, then again the second option ("select from a list"), the .inf you installed shall appear, select it and click on next, it should install.

 

Now you have OpenGL support!

 

PD: I attached the .inf file, its for the Intel G41 express chipset

kit49659.inf

  • Upvote 2

Share this post


Link to post
Share on other sites

Of course! You failed to edit the .inf as directed in the post above.
If you hadn't, it would contain:

Quote

;CatalogFile=kit49659.cat

And cause no such message.
Instructions should be followed, not ignored.

Share this post


Link to post
Share on other sites
On 8/16/2015 at 9:48 AM, netbookdelgob said:

PD: I attached the .inf file, its for the Intel G41 express chipset

kit49659.inf

File not found

Share this post


Link to post
Share on other sites

Just follow the instructions, sorry, i dont have the inf. Well, just edit the original inf, with the instructions.

If you cant install the modded inf, just

Quote

Windows 10 enforces driver signatures by default. This can be disabled to install drivers that are not digitally signed. Use the following steps to disable driver signature enforcement.

Click the Start menu and select Settings.

Click Update and Security.

Click on Recovery.

Click Restart now under Advanced Startup.

Click Troubleshoot.

Click Advanced options.

Click Startup Settings.

Click on Restart.

On the Startup Settings screen press 7 or F7 to disable driver signature enforcement.

Your computer will restart and you will be able to install non-digitally signed drivers.

Share this post


Link to post
Share on other sites

Hi, this is the most interesting debate I've found about this topic, and I really would like to give it a try to this OpenGL support on win10 for this chipset graphics issue. Now, I have a question: I¿m using win10 64bit. Already downloaded the driver for win7 64bit. So the inf file is a Little bit different. Would someone help about modifying this inf file just the way it was done with de X86 versión? this is what appears in the 64bit versión of the inf file:  

;
; Driver information
;

[Manufacturer]
%Intel%   = IntelGfx, NTamd64.5.1, NTamd64.6.0, NTamd64.6.2

[IntelGfx.NTamd64.5.1]
; no install on XP

[IntelGfx.NTamd64.6.2]
; no install on Win8

[IntelGfx.NTamd64.6.0]
%iCNTG0% = iCNT0, PCI\VEN_8086&DEV_2A42
%iCNTG1% = iCNT1, PCI\VEN_8086&DEV_2A43
%iEGLG0% = iEGL0, PCI\VEN_8086&DEV_2E02
%iEGLG1% = iEGL1, PCI\VEN_8086&DEV_2E03
%iEGLQ4G0%  = iEGL0, PCI\VEN_8086&DEV_2E12
%iEGLQ4G1%  = iEGL1, PCI\VEN_8086&DEV_2E13
%iEGLG4G0%  = iEGL0, PCI\VEN_8086&DEV_2E22
%iEGLG4G1%  = iEGL1, PCI\VEN_8086&DEV_2E23
%iEGLGVG0%  = iEGL0, PCI\VEN_8086&DEV_2E32
%iEGLGVG1%  = iEGL1, PCI\VEN_8086&DEV_2E33
%iEGLGB0%  = iEGL0, PCI\VEN_8086&DEV_2E42
%iEGLGB1%  = iEGL1, PCI\VEN_8086&DEV_2E43
%iEGLGBU0%  = iEGL0, PCI\VEN_8086&DEV_2E92
%iEGLGBU1%  = iEGL1, PCI\VEN_8086&DEV_2E93

Share this post


Link to post
Share on other sites
2 hours ago, edward_77 said:

 I¿m using win10 64bit.

Enable Testsigning mode and edit the inf file:

[Manufacturer]
%Intel%   = IntelGfx, NTamd64

[IntelGfx.NTamd64]
%iCNTG0% = iCNT0, PCI\VEN_8086&DEV_2A42
%iCNTG1% = iCNT1, PCI\VEN_8086&DEV_2A43
%iEGLG0% = iEGL0, PCI\VEN_8086&DEV_2E02
%iEGLG1% = iEGL1, PCI\VEN_8086&DEV_2E03
%iEGLQ4G0%  = iEGL0, PCI\VEN_8086&DEV_2E12
%iEGLQ4G1%  = iEGL1, PCI\VEN_8086&DEV_2E13
%iEGLG4G0%  = iEGL0, PCI\VEN_8086&DEV_2E22
%iEGLG4G1%  = iEGL1, PCI\VEN_8086&DEV_2E23
%iEGLGVG0%  = iEGL0, PCI\VEN_8086&DEV_2E32
%iEGLGVG1%  = iEGL1, PCI\VEN_8086&DEV_2E33
%iEGLGB0%  = iEGL0, PCI\VEN_8086&DEV_2E42
%iEGLGB1%  = iEGL1, PCI\VEN_8086&DEV_2E43
%iEGLGBU0%  = iEGL0, PCI\VEN_8086&DEV_2E92
%iEGLGBU1%  = iEGL1, PCI\VEN_8086&DEV_2E93

Share this post


Link to post
Share on other sites

Thank you cdob, I will give it a try. In the meantime I would like to share with you something odd that happened to me with this chipset... after uninstalling the WHQL graphic driver that Microsoft installs for this chipset, like usual, Windows temporarily installs a generic basic driver. It allowed me to setup my resolution to 1024*768 , 1600x1200 and even 1920 x 1440. The thing is, the issue I've been trying to solve is that some Windows store apps fail to display , and have a black screen, so I supposed it was because of the lack of support for OpenGL (therefore I ended up here). But, while in this temporary state, using the Generic Basic Windows video driver, all those apps work and display flawless!! yes, this basic driver does support OpenGL. Like I said, its a little odd, but hey, it works. I'll be editing the inf file to use the correct 64bit driver for the G41 chipset, and report the result, but in the meantime, this temporary solutions Works better than I expected.

Share this post


Link to post
Share on other sites

As far as I know no part of the desktop / App environment uses OpenGL.

Things like Photoshop and games use OpenGL.

-Noel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...