Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
theelf

Windows 8.1 maximize

Recommended Posts

Hi !! sorry my english

 

 

 

I bought a Windows 8.1 tablet, and im happy,  but I have a problem

 

 

Every windows is maximized .  Every time i open a new application, open maximized, even if the program dont have any maximize button

 

It seems like windows  "force" every windows to maximize

 

Not only explorer windows, everything.. 

 

 

 

for example, VirtualPC, instead of open in a normal window (the tablet have a resolution of 800x480)

 

max0.gif

 

I get a maximized window, even is obvious that the virtualPC dont have any maximize button, or is possible to do in normal way

 

 

max1.gif

 

 

 

 

Any ideas?

 

This is a problem, because some times, this "feature" hangs some old software, like Paint Shop Pro

 

 

 

 

Thanks to all

Edited by theelf

Share this post


Link to post
Share on other sites

Update the main post, with images, i think is easy to see the problem

 

 

Any ideas? this "feature"...ejem... prevent me to use windows 8.1 normally, because two old software i need to work, hangs :(

 

 

Thanks!

Edited by theelf

Share this post


Link to post
Share on other sites

Did you install that skin, or whatever it is? It looks very non-standard, including that taskbar to the right of the screen. How did it look after a clean install?

Also, at least for desktop use, I think the minimum required resolution for Windows 8 is 1024x768.

Edited by shae

Share this post


Link to post
Share on other sites

Yup, i made the  theme,  to mimic old Windows.  The default 8.1 look is ugly like hell

 

 

But is the same  with stock theme, no difference

 

 

Just to check there is not a problem from something i did,  I make a factory reset,  but same problem, every window is maximized with a clean window

 

 

 

I check with msconfig if there is any software that made this, but nothing,   i check with regedit same but i dont see nothing abnormal

 

 

 

In desktop im a XP user, thats why my knowledge of 8.1 is still limited,  i dont have 8.1 in any other PC to test, just in tablet

Edited by theelf

Share this post


Link to post
Share on other sites

I tried Win 8.1 in a VM, running similar resolutions, but using VirtualBox's "guest additions". I don't see such a problem.

Does it happen with other software, like Windows' calc.exe? How did you get Virtual PC to be non-maximized if the window button is disabled? fb2k looks okay there, no?

Did you try updating Windows? I've tested on Windows 8.1 updated to about mid-2014 (includes at least the first big update).

VGZvWSM.png

Edited by shae

Share this post


Link to post
Share on other sites

Hi, thanks for reply

 

 

Ok,   i get another Tablet from same maker,  this one is 7"  1280x800 (my tablet..phone is 5"  800x480), and same problem

 

 

About VirtualPC, for one second, when open, the size is the correct, and then, maximize, then i have a micro-second to capture :) jaja

 

 

 

About Foobar, i think keeps the size and position the software itself,  because when it open for a second the main window is maximized, and then return to normal size

 

 

It happen to all software that save size/position in the ini,   open maximized, and then return to normal size

 

 

 

 

I updated windows and same problem

 

 

 

For now i tried

 

 

1 - My tablet 800x480 and second tablet 1280x800... both do same... maximize all windows

2 - Update windows 8.1

3 - Check with msconfig and regedit, no software doing strange stuff from maker

 

 

 

Nothing :(

 

 

 

I dont have Windows 8.1 to install in my PC and test.... it happen in all windows?  besides my tablet,  i never use 8.1 in any other PC, thats why i ask

 

 

 

EDIT:  A good example, is the Street Fighter 4 launcher

 

 

the launcher need to look like this, a small window in middle of desktop...

 

 

sf1.jpg

 

 

 

But, looks like this... maximized to full desktop....

 

This is not correct or normally POSSIBLE to do, because the window have no maximize button!! (this on 1280x800 tablet)

 

 

sf2.jpg

Edited by theelf

Share this post


Link to post
Share on other sites

A longshot, but search the registry for "MaximizeApps" and set it to 0 or delete it. This behavior looks like that, maybe something has set it.

GL

Edited by GrofLuigi

Share this post


Link to post
Share on other sites

Hi guys!!  sorry the delay, and thans for help

 

 

Finally i found the problem.. not the solution yet

 

 

 

The problem, is the intel video drivers.  Detect that the screen is  7" and activate this property, maximize all windows

 

If the intel driver, detect a bigger screen, DONT activate this property, and all windows open in a  normal way

 

 

If i uninstall intel drivers, the system works normally, of course, is not a option, i need correct drivers...

 

 

Ahh... some experts here with intel drivers?

Share this post


Link to post
Share on other sites

Very strange. Are you sure? How did you find it's the drivers?

If there's no option in the settings to disable it, maybe try asking in the Intel forums. The forum software sucks, but there are Intel guys over there. :)

Share this post


Link to post
Share on other sites

Very strange. Are you sure? How did you find it's the drivers?

If there's no option in the settings to disable it, maybe try asking in the Intel forums. The forum software sucks, but there are Intel guys over there. :)

 

 

Thanks for reply

 

Yes im sure,  i uninstall drivers, and windows works normally.  I install intel drivers, and the "property" is back again

 

BUT, if i connect the pad to a external screen, the system works normally again... no more maximized windows !!

 

 

When i realize about this, I contact the  maker of tablet (is a local company, very good technical support), and they confirm, that intel drivers, detect the screen size,   if is 7" or less, maximize all windows,  if is 10" and up,   dont activate the property

 

 

 

Yes, i will ask in intel forum,  and ... yes... the forum sucks... but i hope someone cna help me there

 

 

Ahh.... intel is horrible... every laptop or desktop computer with integrated intel i had... always problems with drivers...  i can say that intel make good hardware... but drivers totally sucks

 

 

 

Thanks for all help

Edited by theelf

Share this post


Link to post
Share on other sites

Nothing like "features" in drivers. Hopefully there's an easy way to disable it.

I don't see anything majorly wrong in the Intel drivers (HD 4000), besides the ugly Metro design for the settings utility, and having multiple EXEs with unclear purpose running in the background. Both awkward GUIs and junk running in the background are common problems in AMD and Nvidia drivers, so Intel are in good company.

Share this post


Link to post
Share on other sites

I just signed up here to say, yeah... me too.

 

However, I'm not positive it's an Intel driver issue. My mate has an 8" ASUS tablet running Windows 8.1 on a 1280x800 screen and he has no issues with applications maximizing. I have a Linx8 tablet with the same size screen and Windows 8.1 and since the day I got it, I have this same maximizing issue.

 

We both have Intel drivers! So I find it highly unlikely it's a driver issue. I've tried updating to the latest of the latest drivers and it makes no difference. I've done the same searching of the registry, and can find nothing related to "maximize" that is of any relevance.

 

Interestingly running Calc, it doesn't start maximized, but running other applications (either directly running the exe, or a shortcut with startup size set to "Default") does result in them being maximized - Doesn't seem to matter where they get launched from is what I'm saying.

 

Opening a File Explorer window also starts maximized. Very irritating and I can find no solutions online to this issue.

 

If anyone has any suggestions, please, I'm all ears! :)

Share this post


Link to post
Share on other sites

The Windows 8 native Calc desktop application CAN'T be maximized - that's why.

 

I'm sorry I can't offer a suggestion about how to correct or work around the problem.

 

-Noel

Share this post


Link to post
Share on other sites

I would like to add my 2 cents here.

 

Microsoft has made an arbitrary decision that devices with screen sizes smaller than 8 inches will behave differently than the norm. A lot of users are somewhat aware of this, but unaware that this is where your problem originates.

 

Windows determines a screen's size by reading the EDID information from the screen, which contains sizing information in it, in centimeters.

 

If no sizing information is present in the EDID, or the sizing information is below Microsoft's arbitrarily chosen 8 inch threshold, you get this apparent misbehavior which is at the very least, aggrivating to those who notice it and don't want it.

 

The solution is to override the default driver for the monitor in Device Manager with one that informs Windows that the screen is in fact, 8 inches or larger.

 

To do so, you need to first read the EDID information from the registry with a tool such as Deltacast's E-EDID Editor (free, last time I checked), and modify the size values and save the modified file someplace you can find it.

 

After you have modified your EDID file and saved it, download Monitor Asset Manager from EnTech (also free) and use it to create an INF file.

 

Once the INF file has been created, you need to restart Windows with the Advanced settings menu and choose to Disable Driver Signing Enforcement, since the INF file you created won't be digitally signed. Once disabled, open Device Manager in Windows and update the driver for the monitor using the INF file you created. You will need to confirm that you do in fact want to install the unsigned driver file.

 

Reboot and Windows will now behave normally with the one catch that, the onscreen keyboard will now appear a different size and will have more options available.

 

I have attached an EDID override INF from an HP Stream 7. It is likely suitable for use with other sub-8" tablets as well.

HP Stream 7 EDID Override.inf

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for the info. Too bad people have to jump through hoops to do simple things.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...