Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  

SMART error, wrong size in BIOS

Recommended Posts

I recently had acquired a computer that I had used a long time ago. The power supply is busted and I'm donating the rest of the parts. I kept the hard drive and decided to see if there was anything worthwhile on it. However there are some problems. Since I can't boot it on the original hardware, I am using an MSI G31 board (the only one in the building with a PATA port) using an 80pin cable. Originally, I had the IDE drive and booted from a SATA drive with Windows 7. Windows detects the drive, but if I try to open it in Computer, the green progress bar never completes.

It is a Western Digital Caviar AC23200 3.4GB.

I booted into the BIOS and it shows it as Primary Master and 211.1TB! :blink:

Sometimes (not always) the POST will show this error:

WDC AC23200L 21.10N21 Ultra DMA Mode-5 SMART status BAD

Using DLGDIAG 4.15, I am running the Extended test now, the quick test was not available. The info in DLGDIAG shows just symbols, as can be seen here:


Corrupted hard drive by Tripredacus, on Flickr

As far as expectations, I expect the disk to have Windows 95 or 98 on it, and likely be FAT32. Everything I try to do that does anything with the disk is extremely slow. For example, it took 20 minutes or so to give me the menu in DLDIAG.

EDIT: Test completed. Code 0250. Can't find what this code means.


Final code 0250 by Tripredacus, on Flickr

What are the chances that I can access this data? What other tools/tests can I run?

Share this post

Link to post
Share on other sites

The error code list and from the picture, i'm reading error 0258 instead of error 0250 so it says:

258 ECC 10+ Error Correction Code. At least ten errors have been detected. ECC is a hardware correction technique that corrects errors. If ECC occurs, use Data Lifeguard for additional error correction. Please re-test the drive with Data Lifeguard.

Share this post

Link to post
Share on other sites

ARGH! Funny feeling that the BIOS will have to be manually set (?) on that MoBo -


Then select the AC23200. I had one of these beasties (Caviar, BTW) at one time.

This is the version you are using (apparently) -


edit - If I'm not mistaken, I've seen that krazy "model" recognition before a loooong time ago. Unsure if I wound up manually setting params or not...

edit2 - more detailed info on that HDD here -


...and the CHS in your picture is WAAAAY off!

Edited by submix8c

Share this post

Link to post
Share on other sites

Here is the exact board: MSI G31TM-P21.


Sorry I mistyped the error code. :angel

From the linked txt file, it says that setting it to Master means that it is expecting a slave. I set it to the single drive mode just in case. It still gives a smart error at boot. I checked the BIOS and there are no manual settings to set for the hard disk. Only DMA mode, SMART and LBA, which are all set to auto. The other options for SMART or LBA are disabled, and there are about a dozen choices for DMA Mode.

As far as running Data Lifeguard, that is what I am running already isn't it? I can't use the newer version, I tried and gave me a message about the drive not being supported. So I had to download the older version.

Another sign of hope is that while I can't seem to be able to access the disk, if I try to boot off of it, I get the 0x7B STOP error. So I will re-run DLG and see what happens.

EDIT: I re-ran the test and now get Error 0207 from the Extended Test. The Error code list just says to replace the drive. :}

But it now shows some actual data, including a different CHS.


Bad disk by Tripredacus, on Flickr

Edited by Tripredacus

Share this post

Link to post
Share on other sites

Might I suggest that you use some method of backing up the complete disk (as jaclaz has many times suggested in other threads)? It appears that it MIGHT be an NTFS-type system (?) like 2K or XP (really? on that small?). You know the drill...

Next, try the "Write Zeros" for funsies (after FULL HDD cloning) and then rerun the Extended. I won't swear to this, but AFAICR, I did this once and it APPEARED to clear the whole disk AND recheck the "bad sectors" and (in apparently some cases) reassign the "alternates" back to the Original sectors. This may or may not work, but hey, worth a shot.

Of course, this depends on the (now) correct parameters ALTHOUGH they MAY have been different in the original MoBo (been there too). FWIW, now that CHS seems correct, check LBA=on/off and UDMA-Mode2 (according to specs).

If you had REALLY needed a couple of older HDD's (as a necessity due to BIOS) for donations, too bad I recycled mine - I had a couple of shoeboxes full. Nada left now but a couple of 20G's...

edit - go here (scroll down to v2.8) -


Error 207 is SMART displayed BEFORE media scan - it MAY clear up on second runs (as I suggested the Zero above). :unsure:

...and good luck! :(

Edited by submix8c

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.