Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Win2k on Intel Z77

Recommended Posts

BlackWingCat released a new AHCI SATA driver version 8.9 dated 02/23/2014, purportedly workable with Windows 2000 on the Z77 platform (7 Series / C216 chipset). I decided to conduct a prelimary test to see if it worked using an Intel Sandy Bridge i7-2700K CPU on a Biostar TZ77A motherboard, and the results look promising.

The problem before, when integrating the XP driver, has been the error “iastor.sys is corrupted,” which stops the show early in the installation process, and leaves IDE mode as the only available option. While I’m still uncertain just how great a performance improvement there is running “true” SATA mode (compared to IDE), this has nonetheless remained a W2K grail of sorts for me.


8.9 Driver requires Extended Core.

If you use normal ntoskrnl.exe then you must use 7.6 iastor.sys.

Share this post

Link to post
Share on other sites

I've now installed all my software, which went fine in AHCI mode, no hangups or glitches at all there. The first thing I tried was to rip a DVD disc to the HDD, and found it took twice as long as IDE mode.

My initial thought was that I had neglected to set the controllers to DMA mode for the optical drive, but apparently that concept doesn't apply to AHCI, so there was no option for doing so. I uninstalled the optical drive and rebooted to let the system reinstall it, but it couldn't; the specific drive model is listed correctly in Device Manager, but there is a yellow exclamation mark over it, although this same drive installed fine during the OS installation in AHCI mode. I uninstalled the AHCI controller and rebooted, but this produced the same result.

Share this post

Link to post
Share on other sites

I previously tested using BWC’s AHCI driver version 8.9b. Now version 8.9c is available, so I decided to re-test, and the results show a definite improvement on my system.

As before, the first thing I tried was to rip a DVD disc to the HDD, and found, once again, that it took twice as long as IDE mode. I used Device Manager to uninstall the DVD drive, as before; but this time, when I re-booted the DVD drive re-installed properly. I decided to rip the DVD again, and it ripped twice as fast – in other words, about the same as IDE mode. So driver version 8.9c seems to have fixed the optical drive problem (at least after a reinstallation). Good news there.

Next I ran the following tests:

These comparisons involve very few variables. I made two separate OS discs: one with the AHCI driver (integrated using nLite), the other without the AHCI driver. The only different installation setting was, of course, to the BIOS SATA mode (AHCI or IDE). I installed the OS on the exact same hardware, in the same way, deleting the old partition and creating a fresh partition of the same size in each instance. I used a WD Black 2.5” 7200 RPM HDD to save wear and tear on my SSD, and did not overclock.

At some point I would like to try these tests again using an SSD, since the main performance advantage ascribed to AHCI is Native Command Queuing (NCQ), which may be nullified when using a solid-state drive.

Share this post

Link to post
Share on other sites

I've now completed an OS re-install on my frontline Z77 machine in order to change it over to AHCI mode.  Fernando was nice enough to make a W2K Pro AHCI driver, which has worked well, so I took the opportunity to use it here, and to post one last CrystalMark result.  I'm running USP5.1 and the most recent UUR (20140103) by tomasz86.  The hardware is listed at the end.




My only firm conclusion is that real-world results, using one's own applications, are probably the best test.


Although newer computer processors may be superior clock-for-clock, Sandy Bridge "K" in a Z77 mainboard arguably stands as the ultimate in 4-core desktop performance.  As the manufacturing process continues to shrink, from 32nm (Sandy Bridge) to 22nm (Ivy Bridge and Haswell) to 14nm (Broadwell), a CPU's thermal limit remains too dominant a factor, in terms of overclocking, for the new technology to be put down by the newer.  Unfortunately, each succeeding generation of hardware also poses tougher problems for those of us who run Windows 2000 Professional.


For now, unless someone makes a v11.2 AHCI driver for the 7-Series, I think I've taken my favorite platform as far as I will.  To paraphrase the lyric, I got 99 problems and (this) ain't one.


So it's on to the neXt 99 problems.



Central Processing Unit:  Intel i7-2700K Sandy Bridge (3.5GHz) CPU @ 5.0GHz
OS Drive:  Intel DC S3700 Taylorsville SATA III 100GB SSD (Intel Controller) [4GB Pagefile]
Secondary Drive:  Intel 330 Series Maple Crest SATA III 180GB SSD [4GB Pagefile]
Motherboard:  Biostar TZ77MXE Z77 Micro-ATX UEFI Motherboard
Memory:  G.SKILL DDR3 1333/10600 4x1GB 8-8-8-21 SDRAM

GPU:  nvidia GeForce 630 2GB 128-bit  DDR3 PCI Express 2.0 x16 Video Card

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...