Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


tomasz86

A bug in XP SP3?

Recommended Posts

A think there's a (minor) bug in XP SP3 installer. If you unpack it and open the "UPDATE\update.inf" file you can find these lines:

[Save.Reg.For.Uninstall]
HKLM,%SMIEAO%\%SECURITY%\CACHE_FLUSH,"RegPoliciesPath",,"%SPMWCV%\%SET%\%CACHE%"

[IE.AdditionalSettings.AddReg]
HKLM,%SMIEAO%\%SECURITY%\CACHE_FLUSH,"RegPoliciesPath",,"%SPMWCV%\%SET%\%CACHE%"

but if you look for the "%CACHE%" variable under [strings] you will see:

[Strings]

CACHE="Cache

As you can see the second ' " ' is missing so the variable will probably not be processed correctly :unsure: I can't check it myself as I don't have access to any XP SP2 or lower at the moment (in order to install SP3 and check it).

The correct line in the registry should be:

HKLM,SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\CRYPTO\CACHE_FLUSH,"RegPoliciesPath",,"SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\CACHE"

Could anyone check it? And check if you haven't got sth like this:

HKLM,SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\CRYPTO\CACHE_FLUSH,"RegPoliciesPath",,"SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\"CACHE"

Edited by tomasz86

Share this post


Link to post
Share on other sites

I've found another bug...

[[WMP.CopyAlways.Help.Tours.WindowsMediaPlayer.Video.Files]
viz.wmv, , ,0x20

should be

[WMP.CopyAlways.Help.Tours.WindowsMediaPlayer.Video.Files]
viz.wmv, , ,0x20

Share this post


Link to post
Share on other sites

My XP SP3 has:

RegPoliciesPath=SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Cache

al right. But, with so may updates already added, I'm quite far from plain-vanilla SP3, as of now.

In any case, thanks for the heads up! :thumbup

Share this post


Link to post
Share on other sites

I'm not sure about it but this problem may only occur if you actually install SP3 manually, not when you use a slipstreamed XP SP3 source (I can't find the key in hive*.inf files, and I haven't really got time to go deeper into this now).

Share this post


Link to post
Share on other sites

My AVAST AV reported that the SP3 Service Pack had corrupt CAB files, if that is any help.

It installed all right but I now have a few problems with shutdown...

Share this post


Link to post
Share on other sites

@NATO, I'm not sure what your post has to do with the OP. And you got the message that the SP3 Service Pack had corrupt CAB files and you installed it anyway? ? ? ? ? And you are surprised that you have a few problems? ? ? ?

Cheers and Regards

Share this post


Link to post
Share on other sites

@NATO, I'm not sure what your post has to do with the OP. And you got the message that the SP3 Service Pack had corrupt CAB files and you installed it anyway? ? ? ? ? And you are surprised that you have a few problems? ? ? ?

Cheers and Regards

No, I found out that it was corrupt AFTER it was installed.

Share this post


Link to post
Share on other sites

I've found a bug in SP2 for Windows Server 2003.

[[R2.NasNewBinsEnt.Files]
sis.inf, ia\sis.inf

There is a double bracket "[[". The file "sis.inf" is probably not slipstreamed when the SP2 is integrated into Windows Server 2003 R2 Enterprise (x86) edition's source. "R2.NasNewBinsEnt.Files" stands for "cmpnents\r2\packages\nasnewbins_ent\i386" directory.

Edited by tomasz86

Share this post


Link to post
Share on other sites

I've found another bug...

[[WMP.CopyAlways.Help.Tours.WindowsMediaPlayer.Video.Files]
viz.wmv, , ,0x20

should be

[WMP.CopyAlways.Help.Tours.WindowsMediaPlayer.Video.Files]
viz.wmv, , ,0x20

since there already exist:

[WMP.CopyAlways.Help.Tours.WindowsMediaPlayer.Video.Files]
copycd.wmv, , ,0x20
mdlib.wmv, , ,0x20
nuskin.wmv, , ,0x20
rtuner.wmv, , ,0x20

changing the [[ into single [ , makes a duplicated sections headers with different content.

should the content merged?

Share this post


Link to post
Share on other sites

Yes :yes:

It's the same in case of W2K3 SP2 - there exists "[R2.NasNewBinsEnt.Files]" section and the "sis.inf, ia\sis.inf" should go there.

Remember that you can't use the original update.exe directly after you've changed the update.inf but you've got to patch it first.

Edited by tomasz86

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...