Jump to content

Make a recovery disc from a Toshiba Recovery Partition

Recommended Posts

Hi guys, first of all, sorry for refloat the thread, i know its to late, I just wanted to inform you that at the end the laptop works perfectly.

At first I had problems with step number 6, when wrote the command c: / fs: ntfs / q / V: Windows not created in C: but on D: and I had to do it several times until finally stayed in C :

So big thanks to jaclaz for you help and tips and Ntantor for those steps :).


Link to comment
Share on other sites

  • 6 months later...

  • 6 months later...


I gave to my gf my laptop and my gf's nephew dropped milk on it and burned the motherboard. She gave it to a technician to repair in china, since the windows was in english, i guess the tech format it and erased all even the HDDRECOVERY.

Now, I came to visit my gf and the laptop has problem, so I used MiniTool Partition Wizrd to recover my partition. Luckily, I found the HDDRECOVERY.

I tried all the step but I got stuck on imagex command. I got a msg error : "Error opening file [E:\ZZIMAGES\ZZIMAGES\PREINST.SWM]"

Im using win7 x64, model: Toshiba L740. i tried imagex (64bit) same error.

I wonder if my files are corrupted, here is a list of my file. Total size = 11.6 gig. I notice my PREINST14.SWM file is 0 kb. Is this normal???

I appreciate any help,




Link to comment
Share on other sites

No, unfortunately those files are corrupt.

SWM files are more or less similar to "spanned" .zip or .rar archives, you have a number of files of or below a given size (let's say 640 Mb as the size that would fit on a CD or 4700 Mb as the size that would fit on a DVD) and the last one is smaller.



Link to comment
Share on other sites

  • 7 months later...

Hi, I'm new here. This (old) thread has been enormously helpful but I think I might be out of luck since ONE of my .swm files seems to be corrupted. They all open in 7zip except for the first one, PREINST.SWM

This is so frustrating! I love my Toshiba z935-P300, it's sleak, ultra-light, and still relatively fast, but without the factory install windows 7 is plagued by drivers issues. For example, the function keys don't work, the keyboard backlight doesn't work, and I get a BSOD from USB drivers sometimes, and my sound card stops working sometimes until I disable/re-enable it within device manager! (I've installed all the drivers I can from toshiba's support section, but they don't seem to have everything I need for Windows 7 x64)

I wish I had a friend with a Z935 that I could copy the SWM file from :wacko: Does anyone know of a way to download the original recovery disk? I see one offered for $20 by "restore.solutions" but I wonder if that site can be trusted, and what are the chances that they actually have the files I need...

What I would give to go back in time and make a recovery disk...


Edited by jesseZ935
Link to comment
Share on other sites

Well, but a .SWM opening (or failing to open) in 7-zip is not a real test of *anything*.

What happens using normally imagex (which is what is suggested/explained in this thread)?

Also, depending on the OS you can use, maybe DISM would be a valid alternative.

Or, you could try Wimlib (namely Wimlib-ImageX):


to export the split into .swm's image into a "monolithic" .wim, before despairing/panicking.

Semi-random :w00t::ph34r: thought, what if you make a copy of PREINST.swm and rename it (the copy) to PREINST1.swm? :dubbio:

These are multi-part archives and the inbuilt 7-zip naming convention may play a role in this.



Link to comment
Share on other sites

  • 1 month later...

I have been going through these dramas for around a week now, I made a set of recovery disks (which are totally useless & fail EVERY time I try to install)as I got a few notifications my hard drive was going bad to no avail!!!

The recovery disks are a total waste of time(I'm assuming they MIGHT work If I was reusing the same dodgy hard drive with the recovery section in it but now it won't even load & I'm stuck with a P750 that most of the stuff won't function on. I even went to the trouble of buying another copy of windows 7 as I couldn't find my original disc & went to the microsoft site & after putting in my serial they refused my download as it was an OEM supplied number!!! So frustrating!!! Now I'm stuck with a P750 laptop with no .SWM files, a new 1tb Sandisk SSD & a new Copy of Windows 7 X64

Link to comment
Share on other sites

  • 8 months later...
On 1/10/2012 at 9:20 PM, NextClick said:

Using SWM files to recover my drive.

Hello everyone I’m here to share a simple process that could help hundreds of people that have the same problem I had today. I have a Toshiba Laptop and the drive was going bad. So I tried to reset to factory so that I could clone the drive. But while in the factory reset process the system froze and forced me to reboot! Yep that’s right I lost the factory reset option!

Luckily I was able to copy the swm ( 13 files in all ) files from the D:\HDDRecovery\ zzimage folder from the Toshiba recovery partition to a flash drive. Then I created a bat file named “ resettofactory.bat “ in notepad to use imagex to apply the swm files to the main drive partition.

My batch file command “ imagex /ref PREINST*.SWM /apply PREINST.SWM 1 C:\ ”

Then I edited a iso of a Windows 7 repair cd and placed all the swm files along with imagex and it’s associate files to a folder named Factoryreset in the root directory on the iso, then burned to dvd. Yep works like the manufactures recovery discs .

I boot to dvd

then click on “ repair your computer “

then click on “ Command Prompt “

then X:\Sources> displays

then switch to my dvd drive letter

and type “ cd factoryreset “ and press enter button to switch to factoryreset folder where the files are to recovery my computer. Then I just typed resettofactory then pressed the enter button and it starts. You will see a progress bar 100% when done then reboot that’s it. Their it is, a way to make your own factory recovery disc from a Toshiba recovery partition

I am having same issue and trying to make use of HDDRecovery folder to factory reset my Toshiba laptop. followed steps mentioned however when I execute resettofactory.bat on command prompt, imagex execution fails with error 'The subsystem needed to support the image type is not present. Please let me know what may be causing this.   



Link to comment
Share on other sites

It greatly depends on WHAT exactly are you running (I presume a PE of some kind) AND on HOW exactly you built the PE (from which sources).

Had you actually READ the thread, you would have seen that Ntantor:

had your same issue and solved it by using an updated version of imagex:


Link to comment
Share on other sites

The error you see, the "subsystem needed" indicates you are using the wrong architecture version of imagex.exe for your PE. It means you have a 32bit WinPE and your imagex.exe is 64bit, or your WinPE is 64bit and your imagex.exe is 32bit.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...