Jump to content

Hotfixes for faster Windows 7 boot/startup


Recommended Posts

During the last months Microsoft released several hotfixes to improve the startup time of Windows 7:

KB2510636 - An update that improves the startup performance of Windows 7 and of Windows Server 2008 R2 is available

Svchost.exe holds a lock on a service when the libraries for the service are loaded. This behavior prevents other services in the same Svchost.exe instance from starting until the call to the LoadLibrary function is returned.

KB2555428 - The Windows 7 startup process is slow when you create many restore points

Consider the following scenario:

You have a large hard disk installed a computer that is running Windows 7.

You create many restore points on the computer.

You try to start the computer.

In this scenario, the startup process may be very slow.

This issue occurs because the boot plan for the ReadyBoot feature exceeds the size limit of 512 kilobytes (KB). Each restore point creates a snapshot of Windows that Volsnap.sys must validate during the startup process. When you create many restore points, the boot plan for the ReadyBoot feature eventually exceeds the size limit of 512 KB, and cannot be stored. Therefore, startup I/O operations are not precached, and the startup process is slow.

Note The boot plan is stored in the following registry entry:


KB2505454 - The startup process is delayed on a computer that has a large hard disk installed and is running Windows 7 or Windows Server 2008 R2

Assume that you install a large hard disk on a computer that is running Windows 7 or Windows Server 2008 R2. For example, the size of the hard disk is larger than 2 terabytes. In this situation, there is a short delay before Windows starts.

This issue occurs because the Microsoft Software Shadow Copy provider is being initialized.

So if you have one of those issues which slows down Windows boot, install the hotfixes.

Link to comment
Share on other sites

  • 2 months later...

New Hotfix:

Unexpectedly slow startup or logon process in Windows Server 2008 R2 or in Windows 7

When you perform one of the following operations on a computer that is running Windows Server 2008 R2 or Windows 7, the operation may take a long time to complete:

Start the computer

Log on to Windows

For example, the computer takes three or more minutes to start. This issue occurs because the Windows Management Instrumentation (WMI) component unnecessarily performs a full validation of the WMI repository.


Edited by MagicAndre1981
Link to comment
Share on other sites

  • 1 month later...

Hi Magic Andre

Sorry to disturb you. Over the past few weeks I have applied these hotfixes in order to help with my boot speed. I just wondered if the hotfixes had any side effects? I can't be certain but I think one of these hotfixes has triggered this problem on my Windows 7 Ultimate (x64). Do you get this same odd behaviour & know how to fix it?

Basically I'll boot up my machine (alienware m17rx3) and then open ‘My Computer’. Then I’ll insert a USB stick or a dvd. Everything happens normally. However with ‘My Computer’ still open I will right click the USB stick and click eject & a message will always pop up. Most commonly ‘Explorer.exe – No disk’ ‘There is no disk in the drive. Please insert a disk into drive\Device\Harddisk1\DR1’. The box gives options to cancel, continue & re-try. If I click cancel the box will re-appear. Basically I have to click through it about 5 or 6 times before it eventually disappears. After that all is fine and dandy.

If I eject using the icon in the system tray I don't get the same problem. Likewise with a DVD, if I use the button on the top right of the laptop to eject the dvd the error message doesn't happen. It's only when ejecting using right click, eject on the drive within 'my computer'. I’ll get same message but instead of please insert to device\harddisk\DR1 it will say ‘Please insert a disk into drive D:’.

It’s also odd because it only does it once. Subsequent ejections of a dvd or USB stick are then fine. Until the next boot anyway. I have managed to stop / suppress the error by changing the errormode in the registry to 2. However it’s not a real fix & can suppress other error messages that I'd need to possibly see in the future.

As far as I can see there are no side effects, everything works absolutely fine but it does concern me. I have trawled google til I’m blue in the face with no joy. The common issue being that the USB stick has been assigned the C: letter and to change it in disk management but that doesn’t apply to me as it always gets assigned as E: whilst my DVD drive is D: I did try changing the drive letter for the sake of it but it didn’t help. Also tried disabling all start up items & clean booting with only MS services running – again no joy. Finally tried logging in with a new user profile and again no help. Other things I did was clear recent documents so nothing points towards either the optical or USB drives.

It’s getting kind of irritating. I am inclined to think hotfixes may of introduced this. But I can’t confirm this for certain as I don't know exactly when this started happening as I don’t normally eject this way. But now I have noticed the problem it is something I am keen to fix.

I did download process explorer to see if this gives a clue as to the cause but unfortunately I do not know what to look for.

Many Thanks,


Edited by Scottyboy99
Link to comment
Share on other sites

  • 1 year later...

MS released a new Update which is called "Enterprise hotfix rollup" which also includes the Speedup fixes and many network related fixes.

An enterprise hotfix rollup is available for Windows 7 SP1 and Windows Server 2008 R2 SP1


Download the Update from the update catalog (only works with Internet Explorer):


Link to comment
Share on other sites

To use this Web site's full functionality, you must be running Microsoft Internet Explorer 6.0 or later.

one would think after 10 years that this will stop being a problem

btw can anyone provide a normal installer link for this ?

Edited by vinifera
Link to comment
Share on other sites

ok found alternate links


well this is a blow in a face, it won't install

I get event viewer log:

Fault bucket , type 0

Event Name: WindowsUpdateFailure

Response: Not available

Cab Id: 0

Problem signature:

P1: 7.5.7601.17514

P2: 80073712

P3: 5A9F89BA-19C7-4154-B413-2D601154C7E9

P4: Install

P5: 101

P6: Unmanaged





Attached files:

These files may be available here:

Analysis symbol:

Rechecking for solution: 0

Report Id: 54bdd448-9534-11e2-b902-001617927af0

Report Status: 0

Edited by Tripredacus
removed links
Link to comment
Share on other sites

That error seems to indicate the publisher certificate is invalid - which would lead me to believe the package has been "manipulated" by whomever posted those "alternate" links. The Windows Catalog site requires an ActiveX control to work, hence it requires IE. Since you have Windows, you should have IE, and should be able to visit that site in IE, download/install the control, and get the hotfix.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...