Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Issues on some machines with Small ISO method

Recommended Posts

DBAN is definitely overkill.

At the most you have to write 00's to the MBR.

I don't run a full DBAN since a few minutes are more than enough to wipe out a MBR

Sure, but compare with the fractions of second to write a bunch of 00's...

Yes I can try a "vanilla" setup and report back...

Wait until ilko_t has made his tests, the creator of WinsetupFromUSB having a laptop on which the proogram won't work is a nice twist to the otherwise lately fundamentally boring plot. :angel:lol:

ANd before anyone says anything different:

  • YES, Lenovo's are queer :w00t:
  • YES, DELL's are MORE queer :ph34r:


Edited by jaclaz

Share this post

Link to post
Share on other sites

Latitude E6400 - FAILS

Latitude E5410 - FAILS

Vostro 3700 - OK

Vostro a860 - OK

Vostro 1015 - FAILS

Help, all Hell systems. The most USB trouble manufacturer.

Write more details, which part fails?

Remember to adjust ntdetect.com, compare FAQ.

A BIOS may behave different at CD and USB boot.

And a BIOS may map a missing floppy drive. Windows setup wait for floppy drive.

Floppy is never detected, because there is no floppy drive, blank cursor for ever.

Share this post

Link to post
Share on other sites

A few quick tests:

Dell OEM XP Pro SP3, came with the laptop, setup from CD works with USB stick connected.

Same source does not work from USB and beta6.

No floppy drives reported by grub4dos.

Newer grub4dos version does not make any difference, neither did AHCI/IDE mode, nor Standard HAL, nor the modified ntdetect.com.

In IRRT (Inter Rapid Restore Technology) mode (SATA options are DISABLED, IDE, AHCI and IRRT) grub4dos reports the internal disk mapped in a funny way:



To test with older grub4dos version, WinSetupFromUSB 0.2.3, cdob's firadisk ISO setup, newer/older BIOS and check if some seemingly unrelated BIOS options matters.

Out of town for the weekend so updates most likely will be after Monday.


My laptop is also Latitude E6400, BIOS A20 and vanila 2003 SP2 hung the same way with blank screen right after "Setup is starting Windows", in both IDE and AHCI modes.

In AHCI only the USB light flashes, in IDE only the HDD light.

Windows 7 MBR on HD, Grub4dos MBR on USB stick, no other mass storage devices.

Will post later on after a few tests.

To clarify- in Text mode, when partitions are supposed to show up screen goes completely black/blank.

And guys, please, no jokes about Dells :lol:

Share this post

Link to post
Share on other sites

Thanks very much guys... needless to say I will hold off any further testing until you have a chance to make some sense of this... plus I have a lot to learn about this :)

Share this post

Link to post
Share on other sites

And guys, please, no jokes about Dells :lol:

Naah, you CANNOT get away with this so easily! :realmad:

Actually most of the jokes around are about DELL's customers :angel :


and not about the smart guys that actually manage to create completely UNstandard BIOS and hardware, but we can adapt a few old ones:

down vote

A physicist, an engineer and a DELL programmer were in a car driving over a steep alpine pass when the brakes failed. The car was getting faster and faster, they were struggling to get round the corners and once or twice only the feeble crash barrier saved them from crashing down the side of the mountain. They were sure they were all going to die, when suddenly they spotted an escape lane. They pulled into the escape lane, and came safely to a halt.

The physicist said "We need to model the friction in the brake pads and the resultant temperature rise, see if we can work out why they failed".

The engineer said "I think I've got a few spanners in the back. I'll take a look and see if I can work out what's wrong".

The programmer said "Why don't we get going again and see if it's reproducible?"

But I have a scoop :w00t: the original handwritten source of the BIOS part that creates drive assignments in DELL's BIOS:



The 1.0 beta6 - 7.March.2010 is this version the last one or Finale one?

Strangely enough, the 1.0 Beta 6 is the 1.0 Beta 6, thus NOT the last (hopefully) one, nor the Final.

But yes :), it is the more recent one. ;)


Share this post

Link to post
Share on other sites

A few tests on Latitude E6400:

The ~BT & ~LS USB method and starting setup from a CD worked.

What didn't help, hangs on blank screen when partitions are supposed to show up:

-newer BIOS, A25

-various grub4dos versions- 0.4.5a 2010-02-09, 0.4.5b 2010-08-12, 0.4.4 2009-03-30

-small ISO method, also usb drivers moved to bus extender and input devices groups

-ISO + firadisk method

-SD card in the reader

-XP CD in the DVD drive

-DVD drive removed

-no hd0-->hd1 and vice versa mapping

-modified ntdetect.com

-some devices turned off in BIOS

-IDE/AHCI mode

-2003 SP2 source

Running out of ideas... :ph34r:


Check in Program directory\winsetup\files\PyronSetup\I386 if setup.ex_ exist. Most likely an antivirus program either deleted it or doesn't let copying it. Download fresh copy of the program or turn off your antivirus.


These rumours and jokes must be based on true stories :lol:

Share this post

Link to post
Share on other sites

I am still chasing this one...

Dell released new BIOS, A27- same issue.

Tried to start Setup from a floppy image with setupldr.bin, ntdetect.com and txtsetup.sif in it mapped to fd0 and fd1- setup hangs the same way, this works on other machines.

Use latest chenalls grub4dos build- http://code.google.com/p/grub4dos-chenall/downloads/detail?name=grub4dos-0.4.5b-2010-11-21.zip&can=2&q= - same result.

Interestingly, the firadisk method hangs the same way.

What the heck is wrong with these Dells... :wacko:

Any ideas and clues are more than welcome :ph34r:

Share this post

Link to post
Share on other sites

Success, at last.

It seems loading the ISO image in memory causes the hang. Mapping it with no ---mem option seems to do the trick. Of course the file has to be contiguous.

The only change is in winsetup.lst:

map  /WINSETUP/XPpSP2.ISO (0xff)

As a side note- Syslinux memdisk also seem to work on this system:

title Boot memdisk
kernel /memdisk
initrd /flp.img

flp.img is an image of floppy disk with SETUPLDR.BIN, NTDETECT.COM and TXTSETUP.SIF and bootsector invoking SETUPLDR.BIN.

Txtsetup.sif has a few lines added in order to change boot and source paths:

SetupSourcePath ="\WINSETUP\XPpSP2\"

Memdisk was used just for testing purposes, it won't be suitable as we cannot change on the fly rdisk values according to th enumber of hard drives connected as we can do with grub4dos and

cat --locate=rdisk(X) --replace=rdisk(Y) (0xff)/I386/TXTSETUP.SIF

I am going to open a new thread in grub4dos support forum at boot-land.net and check if the good guys there have a workaround or clue what's going on.

Share this post

Link to post
Share on other sites

This sounds like the BIOS e820h memory map function is returning incorrect memory size data. grub4dos will place the iso at the top of RAM. It is quite common for BIOSes to incorrectly report the size of memory and so grub4dos may load the ISO into memory locations that are being used for something else - shared UMA graphics memory for instance - and then the code gets trashed by the BIOS before it can be run!

MemTest86+ reports e820h memory size parameters when you run it - but for this test you should not load it into memory using --mem via grub4dos or it may crash or itself modify the parameters returned - I would recommend booting from CD and running it. MemTest86+ may even fail if it tries to test memory near the top which is not there...

I have reported many such errors to mainboard and notebook manufacturers over the years! Basically, Int 15h e820h reports free memory - if you try to use all the memory reported as 'free' and then test it, it fails because the values returned by the BIOs were incorrect. See this post for an explanation of what this does http://www.masm32.com/board/index.php?PHPSESSID=7c1e51e2a37a3e2e9e5873bffc9c8c21&topic=1399.0

Edited by steve6375

Share this post

Link to post
Share on other sites

Thanks Steve, quite useful explanation. Must have missed this post.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...