Jump to content

WPI 7.7.0 Buglist

Recommended Posts

Is this during an install when maybe no user accounts have been set up yet? Or is this on your desktop?

Did you do the command prompt test?

Of course


shows my username and I tried it on my running system.


Edited by AlBundy33
Link to comment
Share on other sites

  • 4 weeks later...


there is encode problem with chars Turkish file>lang_tr.js.


lblProgBarsSkin[lang]		   = ['Ýþlem çubuðu'];

shoul be:

lblProgBarsSkin[lang]		   = ['İşlem çubuğu'];

I have face this problem with 7.7.0, not old ones.

also language selectbox has bug i think..

I opened optionswizard_languagecombo.js with notepad++ and saved with UTF-8 not UTF-8 without BOM and now it's correct.

I attached corrected files.



Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

Hi !

Two problems I found:

1. Commandline parameters seem to get ignored with the wpi.exe. They do work with the wpi.hta

2. Please don´t get rid of wpi.hta in favour of wpi.exe. I am starting WPI through a script that maps a drive using pushd, then starts wpi and stays open while wpi is installing apps. Then, when WPI closes, the script deletes the network drive using the popd command.

This works great with wpi.hta but with wpi.exe the script starts WPI and instantly continues and therefore deletes the network drive. Thats probably because WPI.exe only starts wpi.hta and then closes.

So for me this is no real solution. At least tell us what wpi.exe does so we can do that manually before starting wpi.hta or keep wpi.exe open or something :-)

Thanks !


Link to comment
Share on other sites


WPI always skip one command after reboot under Win 7. I have the following commands: install SPTD driver (exe), reboot then run daemontools script (exe). I tested on several machines and none of them run the daemon script, after rebott WPI just jumped to the next app. I can't find in the log either.

It works in Win XP.

I still have a jumping page problem in the app selection page. Sometimes I can't acces the second page, because it's jump back to the first one. Usually I run WPI on a clean Windows XP or Seven. If I change the desktop resolution, then it's working.

Link to comment
Share on other sites

  • 4 weeks later...

This is probably not a new bug, nontheless...

When having two entries that both have each other as excludes and one of them has a grayed condition that evaluates to true, that entry will have the name (correctly) set to the disabled color but the checkbox will not be disabled.

Link to comment
Share on other sites

Greyed condition does NOT disable the checkbox. It just tells you that the condition was met by changing the color....

Wait I think I know what you are getting at...

Probably shouldn't have used the word 'disabled' as that could be taken as 'not visible'. What I meant was that the checkbox will not be grayed out under those conditions.

Link to comment
Share on other sites

  • 3 weeks later...

I think I found a bug. I'll explain it with an example. I have 3 programs:

1) Comodo Internet Security - if it's selected, avast! is excluded. Also there is a check if the system is 32-bit. So if the system is 64-bit this entry is hidden.

2) Comodo Internet Security x64 - if it's selected, avast! is excluded. Also there is a check if the system is 64-bit. So if the system is 32-bit this entry is hidden.

3) avast! - if it's selected avast! Comodo Internet Security x64 and Comodo Internet Security are excluded

However there is an error with this configuration - Could not find UID and it lists all of the UID which have connection with the hidden one. I've attached the config file for this 3 applications


Edited by colornokia
Link to comment
Share on other sites

Yes I know that :/ Obviously I need some suggestion how to do that. I need on 32-bit OS 64-bit programs to be disabled and via-versa. But some programs are not compatible with either versions. Probably I'll have to write a program which will be executed before WPI, determinate if the OS is 32/64 bits and select the correct config file. Thanks anyway :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...