Jump to content

WPI Not Installing Before Desktop Loads


 Share

Recommended Posts

There seems to be some confusion about why WPI is not doing the installs before the desktop is loaded. We always had a problem with Office not installing correctly for some people. It worked for me, but not others, seemingly randomly. We finally figured out, by pure chance, that 2 reg keys needed to be changed from their default values. How this is handled is determined by when/where you start WPI.

From desktop, network share

When started from here, WPI starts, checks the reg keys, if need to be changed it changes them, quits, restarts to refresh the new key values, then runs normally. When quit, it puts the keys back to their original value.

After a fresh install from DVD

This is where the problem is happening. Like above, starts, checks, changes, quits, DESKTOP STARTS TO LOAD, restarts, does installation. Since WPI had to quit, the calling scripts continues on not knowing that WPI is going to restart. No way to tell it that. So what you have to do is change the reg keys in your cmd script before WPI is started.

YOU MUST CHANGE THE REG KEYS IF YOU ARE INSTALLING OFFICE OR NOT. IT MUST BE DONE!!!

Here are the files you need to use with the reg key changes. These are as basic and old school as can be. Put these in the $OEM$ folder.

cmdlines.txt

[COMMANDS]
"RunOnceEx.cmd"

RunOnceEx.cmd

@ECHO OFF

REG ADD "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main" /V "Disable Script Debugger" /T "REG_SZ" /D "no" /F
REG ADD "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main" /V "DisableScriptDebuggerIE" /T "REG_SZ" /D "no" /F

for /f "delims=: tokens=1" %%i in ("%~dp0") do set drive=%%i:
set wpipath=%drive%\wpi

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

REG ADD %KEY%\001 /V 1 /D "%wpipath%\WPI.hta" /f

EXIT

If you have something better, please post it. This is just something to get you started.

Edited by mritter
Link to comment
Share on other sites


one thing I am noticing that didnt happen with my old setup is that on some pc's, there will be a dialogue box that pops up as wpi is starting up that requests a restart.... "windows has finished installing new devices" blah blah. Do you know if there is a way to suppress this?

Edited by gospeed
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...