Jump to content

I got the problem during installing Win XP SP3 from HFSLIP


Recommended Posts

Before I got to know this wonderful script, I was the nLite users. Although nLite is also nice, it has some problems, mainly, not working with .Net Framework integration.

I needed to spend some time to get to know how to use HFSLIP, but now it makes me save more time than nLite does.

Just as indicated in the manual, I followed every step and could get the final ISO image. It looked so nice first.

However, I faced the "one" error. Still, I did not got further step so that I know just one problem by now.

Before installing this integrated Windows XP on my desktop directly, I tested it under my VirtualBox machine 2.0.4. It looked great, but I got this problem:


The file, HFGUI1.EXE is located under [sOURCE]\i386

After several trials of pressing Enter, I just decided to skip the copying step and went up for the next. Fortunately, there's no further problem.

My question is to know if I can skip the copy of HFGUI1.EXE? Or, after the installation, can I manually execute the file?

Please let me have the right answer for me.


Thank you so much.

Link to comment
Share on other sites

DNF_all.exe is a silent installer to all .NET FRAMEWORK, created by SNM.CMD from TOMCAT.

More info here.

Using hfslip-2.0.0pa_80630a I have similar problem with WindowsXP-KB942288-v3-x86.exe in HF folder, try remove this file and run again.


Link to comment
Share on other sites

Just for info:

I don't have HFGUI1.EXE in my SOURCE & SOURCESS folder. But I do encounter this kind of msg once during textmode setup. I managed to trace to HFGUIRUNONCE application. My problem at that time was that the application name contains space, such as "Virtual PC 2007.exe". By removing it all the spaces, removes the error.

U can also try matching the file size on source & sourcess. I believe it is just a rename of file.

Link to comment
Share on other sites

  • 1 month later...

I'm running HFSLIP 1.7.8 on an XP-Pro install and having what seems to be the exact same problem. The program works flawlessly until I try adding files to the HFGUIRUNONCE folder. When I do I get the exact same error that is screen capped above. I've tried renaming my files but thus far it hasn't helped. Now I'm going through and adding each installer one at a time to see if it is an issue with one specific silent install. I'll keep working on it but if anyone has any tips I'd be grateful.


Every .exe that I place in the HFGUIRUNONCE is renamed to hfguiX.exe and placed in the SOURCESS\I386 and causes this error.

Edit 2:

I thought that this may have something to do with using NLite after HFSLP to create an unattended and bootable disk, so I had HFSLIP create the ISO and I'm still having the same issue.

Then I thought that the renaming might be done to conform to a set of formatting so I renamed all files with a 6 digit code of just letters and numbers, no spaces, ., -, _, etc.. This did not resolve the problem either.

I compared the renamed files in the SOURCESS folder with the originals and they are identical. I even tested them and they work perfectly. I even extracted the renamed .exe's from the .iso and tested them and they work perfectly.

I'm lost, but this seems to me like my version of XP just does not want to tolerate any unknown files in the I386 folder. I have an XP volume license that I've used /integrate with SP1a, SP2 and SP3. As I've previously stated the exact same configuration without any .exe files in the HFGUIRUNONCE installs, boots and runs beautiful.

I'm attaching my setup files, maybe I've done something incorrectly.

It is possible I'm not understanding correctly what should go in the HFGUIRUNONCE folder. What I've put in the folder are unattended and silent installers created using the methods in this tutorial. I'm using the Silent Switch Maker from that thread. Some also have autoit scripts, but they are within the .7z file that was transformed into .exe with silent switch.



Edited by Caspean
Link to comment
Share on other sites

Interesting. Feel like testing something out? Try running modifype on the files in the hfguirunonce folder, re-run hfslip and report back. Maybe hfslip needs to invoke the modifype on the files in that folder for that function to work properly.

Link to comment
Share on other sites

Yeah, Tommy is right! I remember this issue myself, as i used to use HFGUIRUNONCE along time ago, and if not running modifyPE on the exe's first, then that exact error came up(Tommy also helped me with that issue back then!)...

It's because if Windows is copying files during setup, then setup calculates the exe's checksum and compares it to the PE checksum stored in the exe's header, but on e.g. 7z sfx's, then the PE checksum in the header comes from the 7zs.sfx module(which is the actual header on 7z sfx's) and hence, will always be the same value and not match the actual exe's checksum, as the real checksum would obviously vary from exe to exe...

Link to comment
Share on other sites

It's not hard. Go here:


download the exe file and put it in the hfguirunonce. Click start/run type in CMD and navigate to the hfguirunonce folder. Since you were nice enough to post your hfslip log :) , type this into the dos box:


cd dualcorebackup

cd cdrive

cd hfslip

cd hfguirunonce

modifype filename.exe -c

where filename.exe is the exe file. I'd suggest to do it one or two files (make a backup first) and put the rest of the installers into a different folder, and run hfslip afterward. If it works for the one or two "test" files, then chances are that you'll need to do all of them to make hfguirunonce to work.

BTW, I have run two test cases on two different OSs on a VM and do not get the copy error prob with hfguirunonce installers.

Link to comment
Share on other sites

Oh... I was thinking there was going to be some long involved process. I'll write a batch file to process all the files in the folder. I already made a backup of them before renaming them. I'll give this a shot and then post back. I did do some searching around the web today before you guys posted and I think you've both hit the nail on the head, but I'll post back my results.

Thanks to both of you :thumbup

Edited by Caspean
Link to comment
Share on other sites

Sorry, what i wrote before was not entirelly accurate...

When using the standard 7z-sfx module, then there's no text-mode file-copy errors, but there are file-copy errors, when using the modded module from Oleg S.

I don't really myself understand how the official module can escape from having this issue, since even though the part of the PE header where the checksum is stored in, is called 'Optional', then it shouldn't be optional for executables, or atleast that's what i've read...

In short: modifyPE.exe is your friend as Tommy said :)

Link to comment
Share on other sites

I can confirm that you are both correct. Running the modifype on all the switchless installers I created has solved the problem, I no longer get that error message. Everything seems to be installing perfectly now.

From what I've read on the net there are really a few things that can cause this error. In my case this was the solution. This same error can occur when a computer has any of the following: malfunctioning PSU, hardrive, RAM, CD/DVD drive or a bad install disc. In my case none of these five made sense since it was happening on multiple machines. I only mention it so if someone has this issue in the future and this either doesn't apply to them or fails to resolve the issue for them, they can look into these other possibilities.

Thank you both for responding so quickly. I really appreciate the help.

Edited by Caspean
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...