Jump to content

How to install Windows from USB- WinSetupFromUSB with GUI

Recommended Posts

WinSetupFromUSB updated to version 1.3, list of changes:

  • Fixed bug when adding NT6 source with missing new line feeds in WinPEShl.ini
  • Fixed handling of NT6 sources with install.esd
  • Fixed bug with NT6 sources with EFI directory but no BCD file in it
  • Added Ei.cfg and CVersion.ini Removal Utilities in \tools\winisoutils directory should one needs those files removed from the NT6 source ISO file
  • WimLib updated to version 1.6.0 for compatibility with new WIM formats
Link to comment
Share on other sites

  • 1 month later...


The software you are mentioning is still warez. MSFN board rules are strict about that. Period.

Back to your problem- how was the flash partitioned last time?

What Windows are you running the program on?

Have a look ate FAQ #14 and post here a download link with the log files.

Link to comment
Share on other sites

On Windows 7, the flash drive was auto-formatted with FBinst. [/] align [/] copy BPB, fat32. The flash drive worked ok. After using it a few times, I went to add another OS and it gave the MBR error message.

Trying to upload the log files: Error You aren't permitted to upload this kind of file

I reduced it to 93KB, but still no...


Edited by mraeryceos
Link to comment
Share on other sites

I've had similar case (grubinst output "Should be a disk image", yours is "Unknown image type" ) on my computer recently and was going to dig further why that happens.

It seems something (read Windows) changes the FBinst data at some point and grubinst no longer accepts the first 512 bytes as a valid MBR, hence the error.

For a quick workaround- use the advanced option "Do not check and install grub4dos MBR", it should get you going, there won't be any checks if grub4dos MBR is present and install if not.

In the next version it should be fixed.

Link to comment
Share on other sites

  • 3 weeks later...

Hi @ilko_t,

I use your WinSetupFromUSB 1.3.. this month I want to add UEFI supprt to my USB. I changed it to FAT32. I have win7aıo and win8 aıo. win7 is 4,7 GB and win 8.1 is 5,3 GB. I install the latest windows 8.1 update 1 adk to my computer. I convert my windows 7 install.wim to esd with this command:

set workfold=%cd%Set dism=%workfold%\amd64\Dism%dism%\dism /export-image /sourceimagefile:%workfold%\install.wim /sourceindex:1 /destinationimagefile:c:\install.esd /compress:recovery%dism%\dism /export-image /sourceimagefile:%workfold%\install.wim /sourceindex:2 /destinationimagefile:c:\install.esd /compress:recovery%dism%\dism /export-image /sourceimagefile:%workfold%\install.wim /sourceindex:3 /destinationimagefile:c:\install.esd /compress:recovery%dism%\dism /export-image /sourceimagefile:%workfold%\install.wim /sourceindex:4 /destinationimagefile:c:\install.esd /compress:recovery%dism%\dism /export-image /sourceimagefile:%workfold%\install.wim /sourceindex:5 /destinationimagefile:c:\install.esd /compress:recovery%dism%\dism /export-image /sourceimagefile:%workfold%\install.wim /sourceindex:6 /destinationimagefile:c:\install.esd /compress:recovery%dism%\dism /export-image /sourceimagefile:%workfold%\install.wim /sourceindex:7 /destinationimagefile:c:\install.esd /compress:recovery%dism%\dism /export-image /sourceimagefile:%workfold%\install.wim /sourceindex:8 /destinationimagefile:c:\install.esd /compress:recovery%dism%\dism /export-image /sourceimagefile:%workfold%\install.wim /sourceindex:9 /destinationimagefile:c:\install.esd /compress:recovery

now it's size 3,06 gb and it fits good with FAT32. I changed it's name install.esd to install.wim, but windows 7 didn't read from install.wim now. after that, I put my "windows 7 install.wim, $OEM$ folder and autounattended.xml" to windows 8 set up dvd. and it worked very well on virtual machine.

and after that with WinSetupFromUSB, I decied to add this to my USB, and first it acted like it's a windows 8 dvd and created and copied to WINSETUP\W81 and on windows boot manager screen it shows windows 81. anyway, I changed "WINSETUP\W81" to "WINSETUP\W7_SP1". after that, I download Visual BCD Editor from http://www.boyans.net/ .. I load the bcd file from "myusb\boot" folder and here is what I changed that.

all is the;

aplication device from "W81" to "W7_SP1",

description from "Windows 8.1" to "Windows 7 SP1"

and OSDevice to W7_SP1

but when I try to boot, it couldn't find the usb device.

here is the error;:


here is the Visual BCD Editor screen:


Link to comment
Share on other sites

I decied to add this to my USB, and first it acted like it's a windows 8 dvd and created and copied to WINSETUP\W81 and on windows boot manager screen it shows windows 81

Version is detected from the strings in VERSION tags in [1].xml in boot.wim. Can you post this file to see if detection was incorrect.

I changed "WINSETUP\W81" to "WINSETUP\W7_SP1"...

You'd also need to edit \Windows\System32\WinPEShl.ini with the new path in the boot image in boot.wim, typically image 2.

Edit BCD store in \EFI\Microsoft\boot\ as well, it is the one used when booted in EFI mode.

A side note, there is an advanced option to use custom folder and boot menu names for such sources, in case if you haven't noticed it.

Link to comment
Share on other sites

Can you post [1].xml to see if detection was incorrect?

now I use a modified boot.wim in my windows 7 dvd. a user made this. I think it's a kinda windows 8 winPE but have a shell like windows 7 screen.. there is no version.xml in it.


detection was correct. I had add "my windows 7 install.esd(wim), oem folder and unattended.xml" to windows 8 DVD case windows 7 couldn't read .esd file.. so with windows 8 boot wim, WinSetupFromUSB read from windows 8 dvd's boot wim for version I think. then It created "W81" folder and add "Windows 8 SP1" to windows boot manager I think. anyway, WinSetupFromUSB didn't make any mistake i think.

Link to comment
Share on other sites

Correct, as mentioned, version is determined from boot.wim, since it's extracted from the ISO file anyway and install.wim is too large to be extracted just to determine version.

Link to comment
Share on other sites

  • 2 weeks later...

Programs updated to version 1.4.

Changes since version 1.3:

  • added better handling of illegal characters for Linux/Other ISO source file name
  • added advanced option for adding persistence partition for Linux sources. Each source has its own persistence space associated with it
  • added better handling for Kon-Boot, source is to be added as ISO file using the Linux/Other ISO option
  • added advanced option to add custom folder with boot critical drivers for NT6 sources (Vista and later). These drivers are added in boot.wim and loaded with DrvLoad before start of Setup, scratch space is increased accordingly. Only drivers for present devices will be loaded. Use it to add USB, SATA/SCSI or Chipset/USB drivers for example. Loaded drivers will be staged and available to the OS being installed. For non boot-critical drivers (Lan, WLan, Video etc.), have a look here
  • added internal check for NT6 sources with multiple boot.wim, only default osloader entry in BCD store and the corresponding boot.wim will be added
  • fixed errors when USB disk was initially prepared with the auto-format option, and on next run of the program it may complain about missing MBR and partition table

Link to comment
Share on other sites

  • 1 month later...

hi all,

I've got a trouble. that's mean I created a file setup all in one for win 8.1. but the point is file size too big. about 4.47GB + 58MB, so I can't add it to boot usb. anyone can help me???

thanks for reading this post!

Edited by damtac84
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...