Jump to content

vLite on Vista SP1


Tihiy
 Share

Recommended Posts

Ok, so i got my fresh 6001.18000.080118-1840_x86fre_Client_en-us-FRMCFRE_EN_DVD.iso and of course the first thing to do was vLiteing!

First, i've tried Ultimate version with my previous preset (all [+winsxs] removed except Aero, nForce storage controller and... Paint, lol :blushing: )

There were some some errors:

sp1ck8.png

And resulting image weren't booting with 'cannot load volmgrx.sys' error.

So, to be safe, i've excluded Storage Controllers and Dynamic Volume Manager and went with Home Premium.

Same 'registry' error, but now everything was installed properly!

asste2.png

Oh, and Vista still a slow a**. But we have some hope :rolleyes:

So be aware. Exclude those components for now.

....

And now some shocking news (to me, at least):

Windows Update and Remove programs are working even with winsxs removed! (I dunno, maybe they were working for someone after integrating some updates - but not for me... or may be registry error is the culprit??)

lolhowvp4.png

The driver for VMWare audio was found and installed.

Some sizes for comparsion:

- Windows folder: 1,24GB

- WinSxs folder: 151MB (8,060 files, 336 folders)

Edited by Tihiy
Link to comment
Share on other sites


I tried running Process Monitor, and got this result (using same source as Tihiy):

111239	20:57:59.6960528	vLite.exe	2736	QueryOpen	C:\Users\Administrator\Local Settings\Temp\vsTemp19\Windows\System32\config\SYSTEM	FAST IO DISALLOWED	
111244 20:57:59.6971759 vLite.exe 2736 RegLoadKey HKLM\VTEMP 0xC000017D Hive Path: C:\Users\Administrator\Local Settings\Temp\vsTemp19\Windows\System32\config\SYSTEM
111387 20:57:59.8018777 vLite.exe 2736 SetEndOfFileInformationFile C:\Users\Administrator\Local Settings\Temp\vsTemp19\Windows\System32\config\SYSTEM.LOG NOT FOUND EndOfFile: 8,192

111525	20:58:00.4927220	vLite.exe	2736	QueryOpen	C:\Users\Administrator\Local Settings\Temp\vsTemp19\Windows\System32\config\COMPONENTS	FAST IO DISALLOWED	
111535 20:58:00.4937659 vLite.exe 2736 RegLoadKey HKLM\VTEMP 0xC000017D Hive Path: C:\Users\Administrator\Local Settings\Temp\vsTemp19\Windows\System32\config\COMPONENTS
111705 20:58:00.7114115 vLite.exe 2736 SetEndOfFileInformationFile C:\Users\Administrator\Local Settings\Temp\vsTemp19\Windows\System32\config\COMPONENTS.LOG NOT FOUND EndOfFile: 8,192

It's on XP, and that's a custom profiles directory.

I haven't seen Process Monitor produce a result like "0xC000017D" before, normally they're human readable. The entries after those are just winlogon.exe querying for sound scheme and loading the "Critical Stop" sound to sound the error.

vLite_Business.ini

Edited by redxii
Link to comment
Share on other sites

I have managed to slim down vista business sp1 refresh2 to 648 MB , leaving aero, and disk drivers, Sidebar, remote assinstence, sharing over network, and it worked, removed a lot of services, the only problem i had was logitech setpoint not installing, actualy it did, but couldnt update the Mice driver, so it loaded just the program, but not the driver.....

Good job MR Nuhi

Link to comment
Share on other sites

I used vLite in Vista SP1 to edit the preintegrated Vista SP1 ISO, and it didn't produce any error messages using the same preset.

How do I make a "preintegrated Vista SP1 ISO"

You can't make one you have to download it straight from MS and to do that you have to be a tester or have access to an MSDN account.

Link to comment
Share on other sites

re*s.t.a.r.s.*2, read the note in the first post:

http://www.msfn.org/board/index.php?s=&amp...st&p=731085

Thanks Nuhi but its not missing the tabs, the driver dont install, setpoint get installed but becouse the driver is the default from MS it wont give you all features its should have, what I managed doing is to get old drivers for XP and extracted just the Mice driver and updated it manually, and worked fine, software and drivers works now......

Unless you are trying to tell me that i have to save that file to load the drivers fine for logitech....

Thanks again much apreciated...

Link to comment
Share on other sites

re*s.t.a.r.s.*2, yes the CDDRV from the installer fails if that system restore file is missing. But apparently it fails for other reasons as well because I posted that info on the Logitech forum and it didn't help to this guy.

It did help to me, I have Logitech mouse and keyboard. That file will be saved by default from next vLite.

Link to comment
Share on other sites

re*s.t.a.r.s.*2, yes the CDDRV from the installer fails if that system restore file is missing. But apparently it fails for other reasons as well because I posted that info on the Logitech forum and it didn't help to this guy.

It did help to me, I have Logitech mouse and keyboard. That file will be saved by default from next vLite.

Thanks for this important info...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...