Jump to content

Compatibility Tab and System Restore Small Fix Tool!


Recommended Posts

Nuhi what other files are removed with Error Reporting or registry entries?

If anyone knows how to can you search the registry for any instances or "wer.dll" thanks

Don't expect him to answer that, doesn't matter how much you helped before....


Edited by Clint
Link to comment
Share on other sites

  • 3 weeks later...


Well im here because i also removed error reporting and probably something else as well that causes the issue im having.

BF2 used to work on the full install of vista only when "run in xp sp2 mode" was enabled under the Compatibility tab.

Ive checked for everything else, gfx drivers, directx, patches etc they are all up to date.

I followed the instructions as stated by legolash2o but in no way do i get the compatibility tab back. Attached is a screen shot as to how

far i have got (or not). Ive searched for other topics etc about this but yeah ..zip. I'm not really in the mood to make another vlite vista (this one is 2 days old)

and then do a reinstall so I'm hoping I've made a "stupid' mistake or overlooked something and that one of you can point me in the right direction ?

Oh yeah, the component fixer straight away showed me that the wer.dll was already present, so i rebooted and rechecked... same deal, no "com tab". I then copied the one

in the component fixer folder (yes the x86 one) into system32 folder, but that gave no changes.

To date I only need the compatibility tab for BF2 as everything else i use runs fine on vista, so if there is some other way I'm also interested.

Thx and am looking forward to any reply on this,


p.s BF2 = Battlefield 2 (just in case)

Edited by Buddhaserver
Link to comment
Share on other sites

do you have a preset for when you used vlite?

you can try going to "C:\Program Files\EA Games\Battlefield 2\" and right click on BF2 itself to see if it appears, i dont think compatibility shows on all shortcuts.

you can also try to delete/replace wer.dll in the system32 folder and then use either my program to copy it or copy it yourself from the x86 folder, its worked for everyone else so it might be just a case of removing something accidently using vlite.

EDIT: Just released a newer version, some things have been changed, possibly some fixes (i say probably because it was done ages ago just didnt upload it), and some more options i.e. help you manually copy the files, remove current files, and so on.


Edited by legolash2o
Link to comment
Share on other sites

Thanks for the reply.

Im not too sure on what you mean with a preset for when I used vlite. Do you mean a list or settings of exactly everything i removed? If so.. nope..!

Yeah it was always on the shortcut before but i had also already tried from the original .exe (just in case another screenshot)

Once i deleted the wer.dll from system32 folder... well you can see that the fix it option is still grey! If i copy and paste it back to system32 folder from the x86 folder of your

app, still no changes and goes back to the same as the first screenshot i posted.

Vlite is not installed atm either.


Although you say no reboot needed etc I did reboot but no changes. Worth a shot :)

Dont know if this is non-sense, but perhaps there might be a service NOT running that is needed for it ? To show the compatibility tab ?

Link to comment
Share on other sites

yep the preset is the list of everything you removed, did, etc... it might be on the vista disk you burned (last_session.ini)

try the new version... because before you had to close and re-open the program (as it scanned for the files when it opened)

in services(start > run > services.msc) check for.... "Application Experience"

Edited by legolash2o
Link to comment
Share on other sites

Yeah okay I got the list of presets, rather long though so rather ask if it's okay to copy paste into here ?

I tried the new version, the text "Compatibility Tab System Restore" is grey but the "Fix" botton is black but will not react. Same with Inkball section.

I did Advanced options -> Delete All then checked in system32 folder... both are gone. Closed your app and started again .. same as sentance above.

Application Experience is not present in services.msc list. I do however have "Andrea ADI Filters Service (AEADIFilters)" there and read that it also has something to do

with application experience. Stopped it and re-tried your app. Same deal.

Ill post the list of presets if thats okay... on my next post!

Thx for your imput!

Link to comment
Share on other sites

EDIT: Looks like you'll have to reinstall Vista but keep Application Experience and Error Reporting :)

Why to keep Error Reporting? You can remove it safely and you will not have any problems. When you are in components part of vLite just add this two lines in File Protection and you don't need to worry about anything:


Cheers :}

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...