Jump to content

[GUIDE] Creating WIM images of Windows XP for system deployment using


Recommended Posts

Sorry P4ntBoy and Thankyou P4antboy and Iceman.

I guess we may be singing from different hymbooks. I was doing this on an XP machine (not vista). Hardware is Dell Optiplex GX620 and optiplex 745). I have set my PC to boot from Cd-rom in bios, but it does not give me that 'press any key to boot from CD...' prompt;it just boots straight into caldera DOS. Where this came from I do not know. I have also followed a Microsoft Walkthrough, which is in the help section of WAIK, but it gives me the same effect.

Even where you say in your guide we should not close the window as this will cause the machine to reboot. There is no way I could close mine as I do not really have a modal window. Myabe I should start a new thread as suggested.

Thanks for your help.

Link to comment
Share on other sites

that new thread suggestion wasn't for your problem it was for Tripredacus.

when you are walking through the guide are you using the cmd scripts in it or are you typing in all the commands manually?

On page 7 step 13, where the winpe_x86.iso file is created, how are you burning this CD image to your CD? Its default location in my guide is c:\winpe_x86\

If you have virtual machine software, create a virtual machine with at least 384MB of memory, then set this CD ISO image file for the cd. and then boot the VM and boot form the cd and see what you get. You can get Virtual PC from Microsoft or VMWare Server from VMWare for free.

Link to comment
Share on other sites

Hi Iceman,

Iam not using the batch files you you provided. I am typing them in. Everything goes smoothly, but I may have gotten something wrong when creating the CD. I use Nero to burn the CD, I select make data disk, then bootable disk, then I browse tothe C:\winpe_x86 and select the .iso file. What could I be doing wrong here?The .iso file is about 202MB. It is obvious I am either not creating the right image or not burning the CD correctly. I have tried burning the .iso file as a normal data file, but the boot process does not read the CD at all, and as a bootable file, it starts referring to caldera DOS. Is there another option of creating the CD??

Please help.


Link to comment
Share on other sites

I have not used nero in a long time, but I believe there should be an option to burn an image to disc or something similar. That is what you want to use to burn the cd. Select that option browse to the ISO and then click burn.

Link to comment
Share on other sites

God Bless you Iceman!

I misunderstood the 'burn image to CD'. I was just burning a bootable CD. Should have gone for the nero option which says "Burn image to CD". If this helps you may want to update the guide for idiots like me whodonot knowthere is a difference betweemburning a CD and burning an image.

Cheers and Thanks for sticking with me through this task.

joe b

Link to comment
Share on other sites


Very good tutorial.

Having some problems... if someone could help me, i thank you very much.

So... I am creating the CD, I am booting the source system from the CD, I type the command imagex /capture c:\ d:\C_Image.wim “Drive C” “My image description” /compress maximum

(page 9 step 5)... and it starts scanning files. The problem is that after 8500 files scanned it stops with an error (related to a file - c:\windows\system32\camocx.dll) - Error:0. I also tried imaging other systems - I receive errors in the same step - but not on the same file. Sometimes it steps scaning at boot.ini - Error 8, sometimes at other dll.

Can anyone, please, help me with correcting this ?

Thanx very much in advance.

Link to comment
Share on other sites

So let me get this straight...

I can no longer (with wds) walk up to a workstation, hit F12, select my image and walk away as I did with RIS...

This seems like alot of work to make an image now.. and even more to deploy it...

Link to comment
Share on other sites


I take it d: is your external drive?

I would do a chkdsk on your vol first before you do a capture I have had this happen to me once before.

I think the cmd line is chkdsk /r

Correct me if am wrong.


You can so many things with this...

SMS OSD FP Deploy by SMS.

you can have a lite touch deployment based on serial number or mac address subnet anything really.

or maybe a fully zero touch deployment will be better but your need a "Provisiong Server"

You can have just a straight F12 Ris to boot your winpe or os or use WDS.

This is all extra stuff thats not covered in the guide.

The BDD2007 Workbench is very good as well as the BDD2.5 wait till you read thru the whitepapers took me ages to read.

This is a guide to produce a reference image and guide you thru the steps required so that you can understand and not just follow the steps without understanding.

Iceman please dont get put off posting further guides :-)

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

In by case it didnt worked. Followed ur guide to create an image inside VM.

And applied it to the Fresh Pc it shows up BSOD?

Where am i wrong. Tried partitioning both with Diskpart and Acronis Disk Director.

PS: Does WinPE disk contains Bootsect.exe by default or i have to add it?

Link to comment
Share on other sites

What was your BSOD? Did you sysprep your image and have sysprep add the Mass storage controllers? What are you using for your VM (VPC, VMWare, etc.)? What HAL is installed in your image and what HAL is required for your destination PC?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...