Jump to content

Joseph_sw

Member
  • Posts

    218
  • Joined

  • Last visited

  • Donations

    $0.00 

Everything posted by Joseph_sw

  1. to compare the differences between .dll versions you may use Depenency Walker. currently i'm kinda worried about shlwapi.dll (6.00.2800.1938; 393 KB) in my system files it call unresolved export "CoWaitForMultipleHandles" in ole32.dll (4.71.3328; 776 KB, from winME cabs) that shlwapi.dll also call apphelp.dll & userenv.dll, which afaik winXP files... i'm worried because that shlwapi.dll was used by shell32.dll for msdmo.dll i'm using the 6.05.01.0900 version, with same reason as Dude111
  2. i'm understand about wide character, however theres problem with english win98SE system. to demonstrate the problem, i have created a .rar archives. (see attachment) files on that archives may be extracted on winXP system (or perhaps non-english win98SE), but extraction will fail on english win98SE system. no, they all have different filename (blame the underlying font), none of that files can be extracted on english win98SE system so the problem why certain wide-characters can be used as file names in English win98SE system or while the others were not, is wether the 2-to-4 ASCII wide-character representated contain such character that depicted in archives above. i wish that english win9x filename characters limitation may somehow removed ... Invalid_Characters_for_filenames__english_win9x_.rar
  3. in my case, for some weird reason, i can't get installer to works on my win98SE. even if i download it from: http://java.com/en/download/windows98me_manual.jsp the only works for me was from oldversion site.
  4. your topic remind me of this: http://www.grc.com/freeware/dcom.htm
  5. i having problem installing the MDDACU, however when i copied ole32.dll from winME cabs into windows\system (in real dos), MDDACU installed just fine. i guess, my ole32.dll got corrupted somehow.
  6. i'm a English win98SE user. on my system, i can create a directory succesfuly with name like this: ティンクルベル or the ansi equivalent: ƒeƒBƒ“ƒNƒ‹ƒxƒ‹ ... however when i tried to create a directory like this, it would be failed: 巫女一番-麻雀編-インテグラル or the ansi equivalent: ›Þ—ˆê”Ô-–ƒ•Ò-ƒCƒ“ƒeƒOƒ‰ƒ‹ above are example of what installer, archiver, torrent downloader, or other application would do. sometime it met with success as #1 example, but most of the time, it will failed as #2, and the whole process become incomplete and failed. i wonder if there any patch / (un-official) service pack to fully enable the Far East Character (China, Japan, Korea) for usages into filenames / directories on English win98SE? UPDATE #1: i just checked wether certain (high) ansi character can be accepted as filename or not. The result as follow: english win98SE rejects directories or filenames creation/changing if it contain folowing chracter keystroke (from character map): Alt+0129 Alt+0141 Alt+0142 Alt+0143 Alt+0144 Alt+0157 Alt+0158 the test was done by copying a character from character map, then tried to rename a file/directory with it using windows explorer, character from Alt+0128 to Alt+0255 were tested throughly. I also tried by saving a new file using such character (from mspaint, notepad, word, etc...). The result was perfectly the same. modifed image from ChracterMap.exe: character marked with red were denied, while other character was accepted. which module that define such behaviour on English win98SE? is it possible to patch/fix it? UPDATE #2: today i decided to do another test about restricted (high) ansi character, using example above. if i not allowed create file/directory with name using that characters from windows, what-if i directly (low-level) rename it? reboot into dos mode, start-up DISKEDIT.EXE, editing the LFN so it'll contain troubled character, finally i come up with this: or if viewed without any C.J.K viewer apps: so far seems good, but when i tried to double click it this message pop-up: or, if viewed with any C.J.K viewer apps: if i tried to delete it on explorer, it will complain with: Cannot delete file: File system error (1026) i can still delete it via command prompt using it 8.3 filename though. why can't english win98SE use that characters in file name? is there something special about it? i believe if that characters can be enabled for usages in filename, that might the key to fully enable the Far East Asian filename supports for english win98 SE. any help on this matter would be very appreciated.
  7. thank you for all, the problem finaly solved thanks to starcraftmaster for pointing that may be something wrong with system files, you're right it was. thanks to chromatic47 for pointing the registry key, indeed the problem was related to it, without your advice i'm probably still looking in the dark. the problem was related to vdd. story: i notice that it was something minivdd. so i thought, if it was 'mini' what about the non-'mini' ? i looked for vdd in that key, found something stuff like this: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Display\0000\DEFAULT] "vdd"="*vdd,*vflatd" iirc, i saw something like that in drwatson report backthen. i checked file that have similar name both in windows directories and installer .CAB files. it seems vflatd.vxd existed in windows installer cab, but not in windows system directory... i decided to extract that file, copy it into windows\system directory, reinstall driver, restart, and ... it works. it works? to make it sure, turn-off computer, turn-it on again, restart once again. confirmed: problem solved! joy. the problem is now solved, but there thing that make me wonder: vflatd.vxd wasn't bundled in downloaded driver packages, it seems driver maker assume that file was already there in each computer? well, i go to check friend computer who also using ATI graphics card (also using win9x), i don't found the vflatd.vxd in his computer, but nothing wrong with his display driver. i also have bootlog.txt that was created when there was the problem, the enty on bootlog.txt: (when there was no vlfatd.vxd file)... [000FBEEA] Loading Vxd = vflatd [000FBEEA] LoadSuccess = vflatd .. [000FBEEC] SYSCRITINIT = VFLATD [000FBEEC] SYSCRITINITSUCCESS = VFLATD ... [000FBF53] DEVICEINIT = VFLATD [000FBF53] DEVICEINITSUCCESS = VFLATD [000FBF53] DEVICEINIT = Display1 [000FBF53] DEVICEINITSUCCESS = Display1 [000FBF53] DEVICEINIT = Display2 [000FBF53] DEVICEINITSUCCESS = Display2 ... [000FBFA1] INITCOMPLETE = VFLATD [000FBFA1] INITCOMPLETESUCCESS = VFLATD [000FBFA1] INITCOMPLETE = Display1 [000FBFA1] INITCOMPLETESUCCESS = Display1 [000FBFA1] INITCOMPLETE = Display2 [000FBFA1] INITCOMPLETESUCCESS = Display2 ... yes, i even re-run setup.exe from win98SE installer disc before i come up with this solution, re-running setup doesn't solve it. (thankfully, i doesn't go to complete OS re-install, yet) what was exactly going on with my system? anyway thanks to you all, this problem was solved
  8. i'm have already try the hardware acceleration slider before starting to make this thread. however, you may be right, something probably happened to other system files. anyway i found a bit more info: it seems if i reinstall ATI Radeon 9250 driver, then i open regedit, and remove the string value minivdd, minivdd2, on registry key mentioned by chromatic47 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Display\0000\DEFAULTor HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Display\0001\DEFAULTonly delete those whose used by primary display. i can start windows using ATI Display Driver BUT in standard vga mode (640x480x4bit), at start windows will give choice to change the video mode resolution, but it won't works, as its require restart (not a forced restart, thankfully) and, per restart it will revert back into the std vga mode. value of minivdd was "ATI2VXAG.VXD" the secondary also use it, but i don't delete it from registry.
  9. thank you for the suggestions. i tried it all, reinstalling mobo driver, removing all traces of ATI drivers, reinstalling ATI display driver, even restoring user.dat/system.dat/system.ini/win.ini from various rb####.cab that created while everything was ok. the problem still persisted... is this problem was in the hardware? but Dos Application, that use other modes better than 640x480x4bit was works normaly, such as SEA graphics viewers (tried both on real DosMode & full-screen command prompt), dos games, even VBETest from scitech display doctor... i need to run bussiness application, but that application won't run on 4bit video modes. for time being is the alternative drivers for ATI Radeon 9250? it doesn't need to have full hardware support, but enough to have other video modes to works normaly.
  10. this stupid thing never happened to me before. i'm win98SE user Mobo: P4B533 VGA: Hightech Excalibur (ATI) 9250 i can't start windows normaly, it just hangs with black-sreen & unresponsive keyboard after the "Starting windows 98...", i have to hit the reset button i do however can access the safe mode, and i found out if i uninstall the ATI display driver, windows will start normaly. if i tried to install the ATI display driver again (any offical version for win9x/ME), it will hangs again at restart. EDIT: Problem solved by copying vflatd.vxd into windows\system directory. see also: http://www.msfn.org/board/98-fix-t12005.html
  11. sorry for necroing the thread NJSTAR Communicator can be used to view East asian / CJK character. but i have other problem with CJK filename on (english) win98SE system: Sometime i run into condition where the need to create file/directory with CJK character on it, wether via Compressed files, torrent or installer. the problem is some of that filenames works, but the other doesn't. after closer inspection i found out that if that ANSI converted directory/filename contain win9x illegal filename character ( such as: ><:| ) windows would refuse to create the respective directories / files, thus the process failed i have tried installing Microsoft Global IME and change the regional setting into Japanese, but that doesn't help i know that CJK filename works on respective localized win9E version, is there a way to make it works on english win98SE?


×
×
  • Create New...