Jump to content

[possible serious nLite bug] Nlited installs are very prone to


tsk
 Share

Recommended Posts

I installed Nlited (1.2.1) XPSP2 a few days ago. Today, I got my 1st BSOD in this install (caused by driver of now MS Sysinternals new app - Process Monitor 1.0). After reset, I ran Flashget and noticed right away that ALL my custom settings/reconfiguration in this app were gone - it reverted to the state like on 1st start after install (default FG settings). Then I ran IE6 and it asked me if I wanted to keep Autocomplete on - whereas it already had asked me the same a few days ago (right after OS install when I ran it) and I had chosen no back then - and IE6 lost this setting and reverted 1st-run-like behaviour (asking me again the same thing).

Haven't tried other apps/places yet but chances are there are more similar problems with lost settings.

Question is is it a known issue and if someone else experienced it as well? And how to fix it if possible without reconfiguring lost settings from scratch again?

I'll add that it's not a new bug/issue as I remember that I had very similar problem with many lost settings in various apps/Windows with install made with nLite 1.0 RC3 about 1 year ago - also a few days after install lots of settings got lost probably after system crash. And more recently (a few months ago), I had another such issue with the same Lite 1.0 RC3 made install when also probably after OS crash OpenOffice 2.0.3 suddenly started reporting that it wasn't installed in my OS - its all app shortcuts stopped working with error that OO is not installed (can't remember ecact wording now) and I couldn't even uninstall and reinstall OO as its setup program also claimed that OO wasn't installed at all on my machimne (it lost ability to recognize OO installation probably because relevant settings again got lost somehow).

All partitions are NTFS, no FAT - chkdsk doesn't report any errors.

Anyone knows what's going on and how to prevent it from happening (even when BSOD occurs) in the future? It shouldn't be happening and I never had the same problem with normal Windows installations on the same machine (they survived numerous BSODs without ever losing any settings).

Edited by tsk
Link to comment
Share on other sites


wanna know what I experienced ? I experienced not being able to boot because of strange damage to a ntfs partition, get rid of them they suck, use ext3ifs if you need large file support.

other than that when a winblows BSOD or a power failure etc happens, it does not get a change to write to the registry all the settings you have chosen in your programs, so it is not possible to save your settings and it is not an exclusive problem of nLite or anything else, and it will always happen when you are not normally rebooting, if you serious problem with that, I recommend you fix your system so it does not BSOD, my system does not, but my system is also very heavily deleted, and that may require of you to be able to know what you are doing.

fix BSOD's and power failures, that should be the solution for you, and don't use ntfs, it may mess up your entire drives (It messed up 2 of my partitions) especially with power failures even worse if you chkdsk, don't use chkdsk it will also mess up your files, use ext3ifs with a linux boot disk to repair your ext3 file system and use FAT/32 for your C: drive, it is much faster and less prone to errors.

Link to comment
Share on other sites

tsk, nope can't confirm that.

Try to avoid quick reboot tweaks like autoend services or tasks...

In essence avoid any system registry tweaks other than visual or funtional for some period.

Not to mention if you overclock or have incorrectly set memory or even cpu.

And the most assured guess would be a bad (or weak) HDD.

Link to comment
Share on other sites

hi huhi, thanks for the reply.

yes, I'm using quick reboot tweaks - thanks for the tip (maybe they're set to low for my hardware).

No overclock, RAM is ok (checked).

HDD is not faulty - checked many times with chkdsk, manufacturer util, checked SMART status (is ok).

What do you mean by ~weak~ HDD? Too slow? Poorly manufactured (low quality)? It's 7200rpm 8MB cache PATA bought as new last year.

Link to comment
Share on other sites

> monohouse right about the registry not saving intill you shutdown/restart.

what might be causing this? It's possible as I reboot as rarely as possible these days.

thanks for the reply and confirmation - maybe if more folks report it, nuhi will look into this :).

Link to comment
Share on other sites

Now when I'm thinking of it, it could be relatively easy to test:

- make nLited CD and install (obvious)

- install Flashget, Raxco DiskState (another app I've noticed lost all settings), install latest OpenOffice.org, run IE6 once, go to Google, fill search form, perform search (IE will ask about autocomplete and sending forms over non-secured connection). Configure Flashget, DiskState, OOo - change a few settings.

- close FG, RDS, OOo, IE6.

- wait a bit, do other things (like starting new apps)

- after say 5 or 10 minutes (or maybe more - to be discussed) pull out power plug :) OR, if you know of an app which causes fast/certain BSOD i.e some incompatible software - maybe even try Sysinternals Process Monitor 1.0 if it BSODs for you, too - run such an app to invoke BSOD.

- (re)start computer

- start above mentioned apps like FG, RDS, OOo, IE6 (go to Google again etc) - and check whether they behave as if being run for the 1st time - that is - lost/forgot all the settings you had changed it them previously. OOo main apps like Writer etc probably won't even start from shortcuts saying OOo is not installed; you also won't be able to uninstall OOo for same reason (its installer thinks OOo is not installed at all) - like in my case.

Then: try the same above on normal Windows installation (non nLited). See if it keeps apps' settings under same conditions.

I'm talking about XPSP2 all the time.

Edited by tsk
Link to comment
Share on other sites

The horror with losing settings continues :(.

Made and installed a brand new nLited XPSP2 CD yesterday evening (~15 hours ago), then installed a couple of basic apps (no reboots), all was fine - until I installed Foxit Reader 2.0 (~12 hours since Windows install) and immediately opened a .pdf in it. On .pdf open attempt system froze, and I had to reset using reset button on case, after boot and login I noticed:

- Total Commander lost all my settings, behaved as if running for 1st time (showed options dialog), all settings are at defaults.

- Windows Explorer lost my changed settings in tools/folder options/view

- Irfanview lost all file associations set by me

- Winrar lost all settings and file associations and setting - behaved as if running for the 1st time

- Utorrent lost it .torrent file association (default .torrent file opener/handler) - on 1st run after freeze it asked if associate with .torrent files - as if being run for the 1st time

- probably lost settings in Control Panel/Internet Options as well

- Windows start menu (I use classic) lost my changed setting to use small icons in SM - reverted to default big icons - had to change it again

- quick launch bar was gone from taskbar - had to re-enable it (toolbars/quick launch) - was enabled and visible before freeze

- Opera preserved its settings (didn't look everywhere) it seems

- Add or Remove Programs is empty - doesn't show any of the above apps installed by me. Corresponding reg key: [ HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall ] doesn't have entries for these apps as well (they're gone!)

- probably many other things not mentioned above got completely lost - basicly all my configuration work after install.

Can anyone tell me what is going on here and how to prevent it from happening? Looks like there is something wrong with registry writes or it gets corrupted on BSODs/freezes/power outages etc - losing all stored settings (just my guess).

@nuhi: PLEASE investigate it as it's one maddening bug/glitch.

:(

Edited by tsk
Link to comment
Share on other sites

> You have hardware problem

of what kind?

hdd checked - is ok

RAM - ok

BIOS settings - OK

what else could be bad and affect it/trigger this glitch?

Although I've no idea why Foxit Reader froze whole PC instead of just hanging itself and leaving the rest alone/unaffected? Could anyone explain this? System freeze with mouse pointer in BUSY state just on opening some PDF file?

Link to comment
Share on other sites

> Deificient power supply

PSU is very good - much more than sufficient for my config.

> the list of addons and hotfixes you added

only RyanVM UP 2.1.4 - nothing more - no WMP, no IE7 etc.

Drivers: same as since years (graphics card: Nvidia reference drivers, NIC - Realtek drivers, sound card - last Hercules drivers). No betas etc.

> Please use Autoruns and save a report of what you got.

why from Autoruns? nothing special in autorun - only Nvidia CPL thing - as always. No strange drivers/entries etc.

And how to save a report in Autoruns - can't see any option.

Edited by tsk
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...