Jump to content

Remote Desktop


nitroshift
 Share

Recommended Posts

Hi guys!

I've got a box running w2k3 server enterprise edition connected to the internet through an ADSL router. I want to be able to connect from home to the server (which is running DNS, DHCP, AD). How should I configure the server so I can remotely access the desktop? Thanks guys.

nitro

PS WAN IP is static, set by the ISP.

EDIT:

I installed UltraVNC on the server, how can I translate the WAN IP to the server LAN IP in the router? :blink: The web control page of the router presents 3 options:

- virtual server

- DMZ

- dynamic DNS through dyndns.com

Edited by nitroshift
Link to comment
Share on other sites


First you need to NAT your connection to the server, or use port forwarding.

On the Server box you need to enable Remote Access (Windows key + Pause button, clik Remote and turn on Allow user to connect remotelly to this computer, make sure you select users who should have remote access.

Link to comment
Share on other sites

PS WAN IP is static, set by the ISP

like Valter said, Setting up Routing and Remote Access to NAT your connection would help, but if you already have a static IP from you ISP, you can just enable remote desktop and connect via IP address

Link to comment
Share on other sites

You'd be far better off using a VPN. I sure wouldn't want to let anyone on the internet (hackers) access to TS/VNC, you know they'll be trying dictionnary attacks against it and such. And with VPN, you have full network connectitivity (just like being connected locally), fully encrypted, without NAT or such.

Link to comment
Share on other sites

You'd be far better off using a VPN. I sure wouldn't want to let anyone on the internet (hackers) access to TS/VNC, you know they'll be trying dictionnary attacks against it and such. And with VPN, you have full network connectitivity (just like being connected locally), fully encrypted, without NAT or such.

one would hope that you connect through a VPN first then remote to the server as needed, but mattering the situation that maybe all he can do

Link to comment
Share on other sites

in most common case, NAT will be enabled on your dsl router/modem. foward port 3389 (default remote desktop port) to your server's internal static ip. unless your server has public ip address you will need to port foward. in your case, it would be under virtual server in your router/modem. also, like the others said make sure to turn on remote desktop and select users allowed. users must have a password to be able to connect.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...