Jump to content

how to disable the annoying "http://runonce.msn.com/runonce2.aspx


chee
 Share

Recommended Posts

  • 5 weeks later...

thank you !

but , before setting

RunOnceHasShown & the RunOnceComplete Dword values to 1

i need 2 more tweaks :

1. keep the default searching provider

2. check the antiphishing box

where are theese keys in registry ?

Link to comment
Share on other sites

  • 3 weeks later...

hi,

i would like to post a same situation although there are plenty of ways to solve in your posts but i tried some of it but still have not fix yet.

just wanted to ask clearly my problem.

problem:

1. my home page always starts with this url

http://runonce.msn.com/runonce2.aspx

2. when i open a new tab and already set it opening a home page, the "welcome to tabbed browsing still always open even thou i check the "dont show this page again"

tried to disable the protection homepage from norton

3. i tried to change a new default search provider but everytime i click a new search provider it does not respond

i thought the norton is responsible for this problem

hope i can find answer in this topic, tnx

im using windows xp home sp2, 60 gb, 1.7 ghz, 448mb, toshiba satellite laptop, norton protection 2006 with internet security

Link to comment
Share on other sites

  • 2 months later...
I installed last nights release today. Had a problem loading the RUNONCE page. After hanging for 5 minutes or more, the page finally loaded. I recorded two registry keys that was created. I closed IE7 and reopened and the RUNONCE page did not attempt to load. I removed the registry keys and the RUNONCE page attempted to load.

I did a Google search and could not find this resolution anywhere, hope this helps somebody.

To prevent RunOnce from loading.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"RunOnceComplete"=dword:00000001

"RunOnceHasShown"=dword:00000001

Also posted in my Tips and Tricks

Source: http://it.megocollector.com/detail.asp?iFa...0&iType=25

Thanx, this is the right solution!

Link to comment
Share on other sites

  • 1 month later...

To prevent RunOnce from loading.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"RunOnceComplete"=dword:00000001

"RunOnceHasShown"=dword:00000001

Also posted in my Tips and Tricks

I just become a member here....I just wanted to say thank you thank you!

the above instructions "fixed" my problem

~yorky~

I would like to confirm this, RunOnce* is NOT a value under HKLM - it only exisits under HKCU. My system doesn't have a problem, but for those who do:

Windows Registry Editor Version 5.00

[HKCU\Software\Microsoft\Internet Explorer\Main]
"RunOnceComplete"=dword:00000001
"RunOnceHasShown"=dword:0000000

Save as IE7FIX.REG and run it.

For those who manually open Regedit and are not familiar with it - KEYS are FOLDERS, and the things inside the Keys are the VALUES (whereas normally files are inside values). Each value contains DATA. For instance:

"HKCU\Software\Microsoft\Internet Explorer\Main" is a KEY.

"RunOnceComplete" is a VALUE.

"dword:00000001" is DATA.

You could also do this with a batch (.CMD or .BAT) file:

REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /V "RunOnceComplete" /T REG_DWORD /D 1 /F

REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /V "RunOnceHasShown" /T REG_DWORD /D 1 /F

Thank YOu Very much This was the easiest solution for us that do not know a lot about registry thank you!!!!!!!

I did this and it worked!!! Thank You Thank You Thank You!!!!!!!!

Link to comment
Share on other sites

  • 4 weeks later...
I installed last nights release today. Had a problem loading the RUNONCE page. After hanging for 5 minutes or more, the page finally loaded. I recorded two registry keys that was created. I closed IE7 and reopened and the RUNONCE page did not attempt to load. I removed the registry keys and the RUNONCE page attempted to load.

I did a Google search and could not find this resolution anywhere, hope this helps somebody.

To prevent RunOnce from loading.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"RunOnceComplete"=dword:00000001

"RunOnceHasShown"=dword:00000001

Also posted in my Tips and Tricks

Source: http://it.megocollector.com/detail.asp?iFa...0&iType=25

This worked for me. I have a brand new HP laptop with vista and it keeps coming up to the runonce screen, with an HTTP Error timed out or something like that.

Adding the two DWORDS above fixed my problem.

Thanks,

Phil

Link to comment
Share on other sites

Play around in my Registry? Sorry guys, that, in my view is that this a Geeks solution.

The runonce problem came up yesterday when I "upgraded" my wife's PC to IE7. It was quickly fixed by going back to the previous day's System Restore point, i.e back to IE6. QED!!

However, there is an even better solution, which is to dump Internet Explorer and to use the much more reliable Firefox browser - this is installed on my other PC's and there is no way I am going to use IE unless some application demands it.

Link to comment
Share on other sites

I want to thank everyone for their kind responses regarding the solution to resolve the RunOnce problem.

I have revamped my website, the old link is no longer valid so please update your bookmarks.

The new link is: http://it.megocollector.com/?p=56

An excerpt of what can be done using a batch file:

REG ADD HKCU"\Software\Microsoft\Internet Explorer\Main" /v RunOnceComplete /t REG_DWORD /d 00000001 /f
REG ADD HKCU"\Software\Microsoft\Internet Explorer\Main" /v RunOnceHasShown /t REG_DWORD /d 00000001 /f

Or AutoIt script:

RegWrite ("HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main", "RunOnceComplete", "REG_DWORD", "00000001")
RegWrite ("HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main", "RunOnceHasShown", "REG_DWORD", "00000001")

Not only is the solution available for those who would prefer to use regedit. I have compiled a couple of executables that will also resolve the RunOnce problem. These executables come in both silent and with an interface. Something for everyone.

Thank you again,

Canon

Link to comment
Share on other sites

I mentioned this earlier in the thread, but without having to play with the registry, you can easily disable the annoying "http://runonce.msn.com/runonce2.aspx" using the Group Policy editor. (only works with XP pro, though)

1. Go to "Start --> Run..."

2. gpedit.msc

3. Go to "User Configuration --> Admin Templates --> Windows Components --> Internet Explorer"

4. Change "Prevent performance of First Run Customize settings" to "Enabled" and select the action you wish to take instead.

(many other tweaks here too).

I find this to be a very easy way to do it, especially when deployed accross a domain.

disclaimer: gpedit, like regedit, does allow you to potentially make changes that could turn your PC into a brick. Use caution (or at least some common sense).

Link to comment
Share on other sites

  • 4 weeks later...
Download Internet Explorer 7 Service Pack 2!!! This will solve everything. Go to Microsoft's Internet Explorer Page and at the bottom, find Service Pack 2.

http://www.microsoft.com/downloads/details...;displaylang=en

thats Internet Explorer 7 FOR XP Service Pack 2 not Internet Explorer 7 SP2 (no such thing)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...