Jump to content

RC8 "Advanced INF Install Failure"


Recommended Posts

I also had this problem

I used hfslip to integrade the NISTWin2kProGold.inf, and then nlited the sourcess folder, on installation everything works fine, but when I create a user, and login as user, I get the described error "advanced INF install failure"

you can read, don't you?

Link to comment
Share on other sites

uhhh you are so cool .... I'm so scared ... :lol:

(if you clicked on that link, you would have seen that there is my preset, there is no sense in posting my nlite.ini in every thread)

Edited by vci
Link to comment
Share on other sites

  • 2 weeks later...

This reply follows Zhoerd's line of investigation.

I agree with your assessment of where the problem lies but am not entirely clear on your solution. I, too, have a solution which is shared below, however, my lack of deep understanding of how XP creates user profiles doesn't leave me with the ability to state my solution is a 100% fix. I, too, would be interested in anyone elses comments on the subject.

As to my approach,

RC6 of nlite.inf adds the registry entries of section C when the nliteReg section is executed (in cmdlines.txt) - RC8 of nlite.inf ONLY adds the registry entries of section C when the nlite section is executed. so I modified the line "rundll32 advpack.dll,LaunchINFSection nLite.inf,nLiteReg" in cmdlines.txt to "rundll32 advpack.dll,LaunchINFSection nLite.inf,nLite". by doing this, I can ensure that the Default Profile's RunOnce registry entries are populated with the nlpo_01 to nlpo_10 commands to be executed the first time any user logons.

at this point, Zhoerd and my solution diverge,

I don't add any additional lines to cmdlines.txt. it is not clear to me why you would want to execute section R of nlite.inf (via executing "rundll32 advpack.dll,LaunchINFSection nLite.inf,S") which clears the Default User's RunOnce registry entries. I want the Default User profile to always have its RunOnce registry entries populated so that any new user will likewise have their RunOnce registry entries populated. Just to be sure, I have commented out section R of nlite.inf.

Further, as the nlite section of nlite.inf is executed from cmdlines.txt while logged on as the Default User, I thought it might be "cleaner" to add the nlpo_01 to nlpo_10 commands to HKCU rather than directly to HKU.

Finally, similarly to Zhoerd, I have deleted the final two nlpo commands from section C - all they appear to do is rerun nlite.inf sections T, H & B each time a user logons - is this really necessary? - and continue to delete the Default User's RunOnce registry entries (through section R), which I don't want delete anyways.

Anyhow, I would be very interested in any additional, constructive contributions to this issue.

Link to comment
Share on other sites

  • 4 weeks later...

Like you all I get this error when regular users login. Does anyone know if this been fixed in 1.0.1? If not can some one let me know a dummys guide to the workarounds mentioned as I can't follow them easily. I have found the nlite.inf file but opening this up in Notepad I just get garbled text (code).

Just tried to download RC7 to try this version out but the links to the old releases has dissapeared.

Many thanks.

UPDATE: I have tried 1.0.1 and the problem is still present. Finally found an old mirror with RC7 and this works fine.

Edited by modo
Link to comment
Share on other sites

  • 1 month later...

I get a similar error which says:

Advanced INF: Access Denied

but can't find anything obvious that relates to it :S

I use BTS's DriverPacks and RogueSpears AutoImage so its hard to troubleshoot which is causing the problem :(

AutoImage doesn't seem to be the problem tho, so I'm thinking it might be a issue with BTS or with nlite.

Any ideas how i can find out?



Link to comment
Share on other sites

  • 1 year later...
  • 4 weeks later...

yeah i'm encountering this problem too now, having been trying to take it in stages so I can spot when it is breaking, but still working on that

could possibly be after i've slipstreamed BTS Driverpacks in though, but yet to be confirmed for sure


have double checked txtsetup.sif, and nlite.inf is listed in there...

second edit..

oh double fun...as a test, i stripped out the $oem$ folder, and tested again, no advanced inf error seen :huh:

edit...11th Aug...

nailed it to the Adobe Reader 9 Lite installation...for some reason if I included this in the GUIRunOnce installation, it would eventually generate that error. Moved it to cmdlines and now fine, even when creating a new user and logging in...no error seen

Edited by SyKik
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...