Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


cancerface

[beta] User Creation Tool

Recommended Posts

That's bad news for me then since I am not getting this error!

Do you get anything logged by DrWatson?

CF

PS Assuming that the handle calls cause the error, I am attaching another version that uses a different approach to call the main EXE. Could you test this and see if you are still getting the memory overflow?

What OS are you running? Is the program in a looong path *with* spaces? Do you have AntiVirus soft. running? Not sure where to start :no:

[Edit] Removed file - check first post

Edited by cancerface

Share this post


Link to post
Share on other sites

Tested the new version.

I extracted it to (C:\Documents and Settings\MAXXIN\Desktop\TestNewUser) and it worked several times without errors.

When I moved it to D:\TestNewUser, it gave the same error, several times, too.

OS: XP-SP2

AV: SAV CE

Thank you for taking care of this.

Share this post


Link to post
Share on other sites

I am baffled then. I'll try to work it out ...

I appreciate the input :)

CF

Share this post


Link to post
Share on other sites

New version Same error.

drWatson

The application, C:\Scripts\CreateUser.exe, generated an application error The error occurred on 07/23/2006 @ 04:26:03.546 The exception generated was c0000005 at address 7C80A260 (kernel32!WideCharToMultiByte)

OS : XP SP2

AV: SAV CE

Even with SAV disabled same error.

Root of C: same error

%USERPROFILE%\Desktop same error

Hope you can work this out. And if you need more info let me know.

Share this post


Link to post
Share on other sites

For me some times work good and some times got error.

I do not have idea whot hapend

Share this post


Link to post
Share on other sites
Not had a problem with it here, but I only use it @T13

If I am sure it will, then it's good enough.

Share this post


Link to post
Share on other sites

I am still not sure what the problem was. I can also confirm that there were random errors upon execution: the program would execute fine for a number of times then it would give an application error. Or it would not execute at all in certain cases.

I changed as much as I could and I think that I found the error, if it was indeed an error. Changed the user enumeration function and at least now I am not getting any errors. I would however appreciate it if the those of you who had a problem in the first place, could download and test this version, and report back any problems. If everything is OK then I will release it also on the first page of this thread.

Here it is:

CF

[Edit] Removed file - check first post

Edited by cancerface

Share this post


Link to post
Share on other sites

@ cancerface

Tested!

SWEET!

No errors!

Thanks!

Share this post


Link to post
Share on other sites

I did try many times afrer extractin and work good.

Now i go to instal OS and i will see be good or not.

Share this post


Link to post
Share on other sites

Good news :yes:

It seems that it is stable again, so I uploaded v1.4 and updated the first post.

Changelog

v.1.4

  • Rewrote the MAC address detection function
  • Fixed some GUI dependencies for enabling/disabling sections
  • Rewrote the User enumeration function (caused errors in some systems)
  • Corrected the Rename Administrator function (it now is disabled by default if the user running the tool is called 'Administrator')

Enjoy

CF

Share this post


Link to post
Share on other sites

OMG i do not finish testing lost version. :thumbup:w00t:

I like You i will try again new version. :whistle:

THX Yurek3

Share this post


Link to post
Share on other sites

@Yurek3

I am using an image of a virtual PC (XP Pro) which runs a batch file that pauses at cmdlines, so it's easy to copy over new versions and try them. The last version I uploaded worked fine in the above image and it didn't crash in several PCs when invoked from random folders... Thanks for testing it, and please post your findings! :)

@All

Thanks for trying it out and for providing feedback!

CF

Share this post


Link to post
Share on other sites

@CF

I don't know what you did. But you did GOOD. :thumbup

It works fine now. Tested on vmware and in real.

Test => PASSED

Great job CF

:w00t:

Edited by The Glimmerman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...