Jump to content

USB 2 / SiS chipset


Recommended Posts

these are the ones for 98 with sis and the disk has 2000/xp on it if needed

Your file, WIN98.7Z , seems to contain only a WIN2K foder. Did you not forget to include the 98/ME part, or am I missing something ?

i"m sorry

added 98/me/2000

now u have a option of choosin

I assume you use the win2000 driver but not sure

becuz i'm usin xp right now

Link to comment
Share on other sites

  • 2 months later...
see USBMan's Sis USB page on how to setup USB 1.x and USB 2.0 with SIS USB chipsets:

Erpdude8, unfortunately that page has inaccurate and misleading information, namely where it states :

USB 2.0 Drivers for Win 98Se and Me are found on the SiS Motherboard Installation CD

Not so - as I stated (and others have confirmed) in this thread, SiS only provides hiding of the USB 2.0 capability from Windows for mostly cosmetic reasons.

I have since abandoned all hope of making the SiS 741 based USB 2.0 work in Windows 98 SE (or ME). If I be proved wrong so much the better... but don't hold your breath ;=)




Edited by Ninho
Link to comment
Share on other sites

you might want to replace your Sis motherboard or sis 2.0 usb card with a different board or usb 2.0 card with ALi or VIA chipsets. At least VIA post their USB 2.0 drivers online, ditto for Adaptec.

2. Orangeware trial driver for developpers (cf. Petr) :

The link provided to the expiring trial USB 2 driver by OrangeWare is password protected. Could we be lucky enough to find a non-protected download, for evaluation (cough) ?

Orangeware USB 2.0 drivers are not available from the Orangeware web site (at least not directly).

Link to comment
Share on other sites

you might want to replace your Sis motherboard or sis 2.0 usb card with a different board or usb 2.0 card with ALi or VIA chipsets.

I strongly recommend against ALi/Uli USB 2.0 boards. I have tested two of them (both with M5273-A1 chip) and both failed both with Orangeware driver and with ALi/Uli driver. The first was no-name China brand, the second was Kouwell brand.

Both boards immediately after connecting the USB 2.0 device (I have tried 2 GB Kingston DataTraveler Elite, 512 MB Phison Pen Drive and Western Digital Passport USB drive) switched from USB 2.0 to USB 1.1 protocol. Then I have tried these boadrds under Windows XP, Ali/ULi driver caused the same behavior, with default Microsoft EHCI driver one board worked fine but the second switced again to 1.1 protocol. I tried this second board under Windows Vista Beta 2, it did not switch to 1.1 protocol, but had too many errors and failed finally.

At present I have the best experience with VIA based add-on boards, these ones with old VT6202 chip were supported by both Orangeware and VIA driver, new ones with VT6212 chip are supported by the VIA driver only. I have achieved twice higher transfer speed with boards with VT6212 chip than with boards with VT6202 chip so VT6212 is definitely better solution.

Another possibility are board with NEC chip, now it is uPD720101, older boards had uPD720100A. The speed of board with uPD720101 chip is somewhere between VT6202 and VT6212.

The price of these boards may range somewhere between $5 and $10 so if there is free PCI slot it should be no problem to use it.

There are rumors that some add-on boards work in PCI 2.2 slots only, I cannot confirm this.

Maybe other people have other experiences, maybe there are devices better compatible with some boards, I don't know.

The latest USB drivers are here:

Ali/Uli Integrated driver package v2.20, contains USB 2.0 controller driver ver. 1.76 for Win98SE/WinME/Win2K/2003/WinXP.

DriverVer = 09/07/2005,5.1.2600.0176


Orangeware driver ver. 2.4.2, supports all boards with VIA VT6202, Ali/Uli, uPD720100A/720101, some ATI, some Nvidia, specific boards with SiS and Intel ICH4 southbridge.

DriverVer=3/1/2006,2.04.0002.0 (the latest)


DriverVer=1/15/2005,2.04.0000.0 (the latest from Kouwell)


VIA USB 2.0 driver



Here are modified INF files to show exact chip used.



Link to comment
Share on other sites

Here's a list of Intel boards that support USB 2.0:


There's a file called USB20.EXE that can provide USB 2.0 support for Win98se/ME for certain Intel boards.

You mean probably OrangeWare USB 2.0 driver for ICH4 and ICH5 southbridges.

Intel offers versions: - ICH4 support

http://downloadmirror.intel.com/df-support...0/eng/USB20.exe - ICH4 support

http://downloadmirror.intel.com/df-support...3/eng/setup.exe - ICH4 and ICH5 support


The latest release ( can be downloaded also (for example) here: ftp://ftp.abitshop.com/pub/driver2/intel_usb/1102.exe

ICH4 and ICH5 southbridges are used in the following Intel motherboards: D845, D850, D865, D875. D915 and D925 motherboards use ICH6 southbridge and D955 and D975 motherboards use ICH7 southbridge.

The Orangeware driver itself supports all EHCI compatible USB2 controllers (i.e. all I know) but just controllers produced by manufacturers that pay fees are enabled. Intel does not support Windows 98 on chipsets with ICH6 and ICH7 southbridges and therefore it is blocked in the driver.


Link to comment
Share on other sites

  • 4 months later...
Can it be update to the latest drivers

What do you mean by this? The file on Rapidshare is:


File in the post above is


This Orangeware driver is referenced here: http://www.orangeware.com/developers/faq_usb2.html

and this version can be downloaded by OEMs from http://www.orangeware.com/oemusb2.html

This driver: http://www.orangeware.com/oemusb2.html works with any USB 2.0 controller but is timebombed and available to OEMs only anyway.

Apparently there is no possibility how to obtain this driver. It is bad to know that there is driver that works with SiS motherboards, all new Intel chipsets etc. - but there is no way how to get it. Every $5 USB PCI card has license for USB driver - but motherboards not.


Link to comment
Share on other sites

Have you tried the USBview utility to check if the device is connected as 1.1 or 2.0 device?

here are other versions of the USBView tool I found at these sites:

USBView.exe version 5.1.2600.1106 (july 2004 version)


USBView.exe version 4.10.1721:


also see Petr's latest post in this thread on getting version 5.1.2600.2180 of the Usbview tool:


Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...