Jump to content

KLITE mega codec pack, unattended?


Jedi82
 Share

Recommended Posts


also note that -make unattende loads the normal setup wizard,

so dont get scared it wont install but, rather make you a settings.ini file to pars with the setup, and if not mistatking also a runme.cmd

this way you are fully in charge of what components are to be, and wich are not to be installed.

Link to comment
Share on other sites

  • 1 month later...

sigh, don't work for me i don't know why but here the steps i followed:

1) START-RUN --> klmcodec149.exe -makeunattended

2) follow the wizard and then i have 3 files:

*the .exe (klmcodec149.exe)

*xx.bat file with this wrote inside

@echo Installing the K-Lite Mega Codec Pack ...

@klmcodec149.exe /verysilent /LoadInf=".\klmcp.ini" /MERGETASKS="!ff_audio\aac\realaac,ff_audio\aac\libfaad2,speaker\stereo"

@exit

*an ini file with this wrote inside:
[setup]

Lang=en

Group=K-Lite Codec Pack

NoIcons=0

Components=player\mpclassic,ffdshow,ffdshow\plugins,ffdshow\vfw,video\xvid,video\divx,

video\vp6,video\vp7,videovfw\xvid,videovfw\divx,videovfw\3ivx,videovfw\wmv9vcm,

videovfw\vp3,videovfw\vp6,videovfw\vp7,qt\codec,qt\codec\browser,qt\directshow,real\codec,

real\codec\browser,real\directshow,audio\mp3,audio\ac3\101a,audio\vorbis,audio\musepack,

audio\ape,audio\wavpack,audio\flac,audioacm\mp3fhg,audioacm\ac3acm,sourcefilter\mp4,

sourcefilter\matroska,sourcefilter\ogg\haali,sourcefilter\shoutcast,subtitles\vsfilter\233,tools\gspot,

tools\sherlock,tools\vobsubstrip,tools\graphedit,tools\mmcompview,tools\lamedropxpd,tools\avifixed,

tools\fourcc,tools\minicalc,compat\g400,compat\divxaf,compat\ivideo,compat\directshow,

compat\brokencodecs,compat\brokenfilters

in my installapp.cmd i wrote:

ECHO.

ECHO [K-lite codec pack]ECHO wait...

start /wait %systemdrive%\install\klmcp.bat

ECHO fatto!

what's wrong?? :whistle::no::no::blushing:

Edited by Jedi82
Link to comment
Share on other sites

ECHO.

ECHO [K-lite codec pack]

ECHO wait...

start /wait %systemdrive%\install\klmcp.bat

ECHO fatto!

what's wrong?? :whistle::no::no::blushing:

instead of calling the bat, call the line in it, something like:

ECHO.
ECHO [K-lite codec pack]
ECHO wait...
start /wait %systemdrive%\install\klmcodec149.exe /verysilent /LoadInf=".\klmcp.ini" /MERGETASKS="!ff_audio\aac\realaac,ff_audio\aac\libfaad2,speaker\stereo"
ECHO fatto!

Edited by mrshark
Link to comment
Share on other sites

if you put a @ in front of every line, you'll get only the output of that command, without seeing the command itself. Example:

@echo...

@start...

Another way to do this is to turn the echo feature off at the start of the script. Unless I need echo on for troubleshooting purposes, every batch script i write starts with:

@echo off

This has the same effect as preceding every line in your script with the @ sign.

Just thought I would point that out for people who may be unaware of that option.

Thanks to those who provided instructions on setting up a silent install of the new K-lite pack. I have been using this pack for a while now and am quite happy with it. It annoyed me to no end to find out that the latest version has been packaged in a new installer so that I have to re-learn how to install it silently. ;)

Oh, and just FYI, 1.51 is out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...