Jump to content

[Help] - Windows XP Won't Play CD-ROM


rickcremer
 Share

Recommended Posts

Suddenly I can not get windows xp home (sp2) to recognize or play any file (audio, text, executable, etc.) from my cd_rom. The only software I've installed recently is Norton Systemworks 2006 but the CD-ROM worked after that. I haven't installed or removed any hardware.

I have tried to correct the problem myself by using a number of steps but to no avail.

The device is recognized by windows. When I go to Control Panel>System>Hardware>DVD/CD-ROM Drives my hardware is listed (Mats***a UJDA330). Selecting Properties>Drivers>Driver Details shows drivers present including C:\Windows\system32\drivers\cdrom.sys and C:\Windows\system32\drivers\cdr4_xp.sys (provided by Roxio) plus a couple of others. I deleted the cdrom.sys file and restarted windows and a new cdrom.sys file was created with the same date as the deleted file.

I can see the drive (D) in Windows Explorer. But clicking on the drive doesn't bring up any files even though there are some on the CD.

I've searched the Microsoft Knowledge Base and Symantec web site couldn't find anything there that helped me with my specific problems. I also checked with the manufacturer (Dell) and they too were not able to help. They could only suggest that I reinstall the cdrom.sys driver which I've already done.

Any help you can provide would be appreciated.

Best

Rick Cremer

Title Edited - Please follow new posting rules from now on.

--Zxian

Edited by Zxian
Link to comment
Share on other sites


They could only suggest that I reinstall the cdrom.sys driver which I've already done.

Actually from your post it seems like you did NOT do that.

It seems like you:

1) deleted the cdrom.sys file

2) at next boot Windows File Protection recreated it

Some releases of Roxio (DirectCD) are known in a few occasions to generate conflicts.

have a look at these:

http://www.winportal.com/chat_sin.asp?ObjectID=7611

http://aumha.org/win5/a/xpcd.php

Cannot say more, without knowing more details, (version of Roxio, how it was installed, etc.)

jaclaz

Link to comment
Share on other sites

Heyyyyyyy..........

Hmm sooo ur CD/DVD drive is not working... Okie...

Would recommend u 2 steps...

1) Check for any boot sector virus.. I know u have Norton System work which is pretty good, however I recommend u to run an online scan... How to Run Online Scan.. Hmmmm Check out the following link then...

housecall.trendmicro.com/

2) If u dnt find any virus, would suggest u to run Dell Diagnostic on ur CD/DVD drive and let me know the results... The reason y i want to know the results because I was working with Dell Tech support before.. If all tests pass i.e read nd seek test... try another CD drive, if available....

Regards,

Minbugs

Link to comment
Share on other sites

Well, from my perspective, this looks like a conflict between Roxio and Norton Systemworks.

I'd suggest you backup everything as best you can (this is why I use an external 120 GB usb hard drive for backups).

Do a complete re-install (with nLite) and take care not to remove anything vital.

Test it out and see if it works, then install norton and make sure it works, THEN install the roxio stuff and see if it works.

Trial and error, but it seems obvious to me that there's just conflict.

Norton does a lot of stuff that makes it incompatible with many programs that "do not want to behave themselves". Particularly Norton CrashGuard (not sure if its in the newer versions) causes lots of conflicts. If all else fails try disabling (not uninstall, disabling it via their preferences/options) norton stuff completely (make sure you are disconnected from the internet first). After this, reboot and try the drive again.

Always keep track of what programs you install. The less, the better. Stick to the essentials and don't bother with uninstalling anything, just use Norton Ghost and restore to a previous state before the program was installed. If you don't have Norton Ghost then there's freeware/open source progs available also.

Till then...

Link to comment
Share on other sites

key the LowerFilters value in

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

Rename to oldLowerFilters, reboot and try the drive. If it works then either one of the files listed is missing or corrupted or conflicts with another filter.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...