Jump to content

Version 3.5.1 Discussion


Recommended Posts

why ?

3.5 work ok for me. thanks for.

usualy I test my WPI fron my harddisk , most of my programs were in

d:\winapp\...

now in 3.5.1 , after I copy config.js+useroptions.js,

WPI try to find them in

d:\wpi\winapp\...

where is some wrong , because in wpi.cmd i cannot see something !

how can I cut "\wpi" from path ?

anyway , because I am here now and I see the effect

I subscribe for a couple of dashes before - del desktop links - line

in wpi.cmd .

Link to comment
Share on other sites


ok . before , my path for WPI was d:\wpi

I re-download wpi3.5.1

and i put it in d:\WPI_3.5.1\WPI_3.5.1 after uncompress

wpi expect now my app's in

d:\WPI_3.5.1\WPI_3.5.1\winapp\...

look like we have somewhere an extra <<%wpipath%\>> in

the chain of path of my app's.

Link to comment
Share on other sites

yes , first time , I rename to d:\wpi .

in the second test I use d:\wpi.3.5.1\wpi.3.5.1 ( had same problem)

I use d:\wpi , d:\winapp\... for app's , d:\drivers, d:\windows\XPpro\postSP2hotfixes, D:\Games\...

so my app's are not in

d:\wpi\winapp\...

3.5 have no problem with that , work Ok with the same config.js + useroption.js.

with no other changes , 3.5.1 say me that can't find "d:\wpi\winapp\nero\nero6.exe" , and it is real ,

because i have it in "d:\winapp\nero\nero6.exe"

//

cmd1[pn]=['%cdrom%\WinApp\\nero\\nero6.exe']

//

(this all with launch from hdd, I do not test yet from CD.)

now , must to put them in wpi directory ?

it is a reason for that ?

in this case must to cut "\wpi" from paths in config.js !?

maybe I do not see something there .

Link to comment
Share on other sites

Okay since you are using absolute pathes make you cmd file read only=

"D:\WPI\common\cmdow.exe" @ /hid

regedit /s "D:\WPI\common\wpi.reg"

start /wait D:\WPI\WPI.hta

del /s/q "%userprofile%\desktop\*.lnk"

exit

and use that since the paths to your apps are absolute you don't need to use the varable of wpipath at all.

the cmd file that you used from 3.5 can probably be subsituted also.

Try that first.

Link to comment
Share on other sites

I'm having the same problem as Oneless with 3.5.1.

I install my apps from cd like so:

%CDROM%\\Software\\path\\to\\filename.exe

and since I updated mine to 3.5.1 I now get this error:

Windows cant find: C:\XPCD\$OEM$\$1\Install\wpi\Software\path\to\filename.exe

I changed

for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\WPI.ico set CDROM=%%i:

to

for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\WIN51 set CDROM=%%i:

As I dont think it cant find WPI.ico

Ok whatever the problem is its not in the cmd file. Original from older WPI.cmd wont run either.

I ran the WPI.cmd with a sleep to read the variables.

REM Example, how to look for CDROM-drive. Must have a file to identify in its root (like WIN51 or WPI.ico).
for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\WIN51 set CDROM=%%i:
echo Found CD-Rom as drive %CDROM%

REM Determine the WPI startup path.
REM if wpi should run off the cd the replace %~dp0 with %cdrom%.
set wpipath=%~dp0
echo Found WPIPATH as drive %wpipath%

sleep 50

I get

CD-Rom as drive G:

Found WPIPATH as drive C:\XPCD\$OEM$\$1\Install\wpi

So the variables are being set correctly, just somewhere its not being called correctly.

I need it to look for %cdrom%\Software\path\to\filename.exe. Too tired to keep looking right now. If the developers know an easy fix please let me know.

Link to comment
Share on other sites

Okay since you are using absolute pathes make you cmd file read only=

hei man , I do not use absolute pathes . what for ?

I use : cmd1[pn]=['%cdrom%\\WinApp\\app\\app.exe'] ?

i think it is a small mistake there , maybe not in wpi.cmd ,

I use 3.5_wpi.cmd in 3.5.1 , same error.

in my case

%wpipath% was "d:\" , or maybe must be "d:\" and in fact is "d:\wpi"

when lunch from hdd : %cdrom% = %wpipath% !?

anyway , here , somewhere , somehow, the launcher , add an extra %wpipath% to my app's pathes.

Link to comment
Share on other sites

I know that it worked before on my harddisk without any troubles, but it seems to me the %cdrom% variable isn't set anymore.

When you do wpi.cmd >> debug.txt you will see something like this:

Found CD-Rom as drive

instead of this from wpi.cmd:

echo Found CD-Rom as drive %CDROM%

Notice the %cdrom% variable is not set.

A temporary fix could be to manualy set %CDROM% for testing purposes on hard disk.

Link to comment
Share on other sites

Ok found the problem, had to trace the whole program mind you, if anyone knows of a debugger for .hta apps lemme know. A step by step would been awesome.

Go to C:\XPCD\$OEM$\$1\Install\wpi\WpiScripts\ and open generate.js

Earlier I thought the problem was in the .cmd file being that it was looking for the WPI.ico as the CD drive distinguisher. I thought I was wrong because the fault was not just in the .cmd file.

In the generate.js u will see this:

function FindCDRom()
{
position = "generate.js";
var i, li;
if (foundCDdrv) return cddrv;
li = GetCDRomDriveLetters();
 for (i=0; i<li.length; i++)
 {
 if (FileExists(li[i]+'\\WIN51')) //it did say WPI.ico
 {    
   cddrv = li[i];
   debug("Found CDROM as drive " + cddrv,1,2);
 }
 }
 
 if (cddrv=="")
 {
 a = fso.GetAbsolutePathName(".");
 while (a.length>=3)
 {
   //debug("Trying ... " + a, 1);
   if (FileExists(a+'\\WIN51')) //it did say WPI.ico
   {
   cddrv=a;
   debug("Found CDROM as folder " + cddrv,1,2);
   break;
   }
   if (a.length==3) break;
   a = a + "\\..";
 a = fso.GetAbsolutePathName(a);
 }
 }

 if (cddrv=="")
 {
 cddrv = WshShell.RegRead("HKLM\\Software\\Microsoft\\Windows\\CurrentVersion\\Setup\\SourcePath") +

"\\";
 cddrv = cddrv.substr(0,3);  
 debug("Found CDROM as from registry " + cddrv,1,2);
}

foundCDdrv = true;
 return cddrv;
}

You see its looking for the WPI.ICO and finds it in:

C:\XPCD\$OEM$\$1\Install\wpi or %systemdrive%\Install\wpi

both of which are wrong to us. You need to look for the WIN51 object, as thats what is in the base of CD-ROM drive.

Using the icon is not a great way to check for the drive letter, especially when people might customize their icon. Anyways try this it should work.

Ok color and Bold quotes not working inside

 so open GENERATE.JS change all WPI.ICO to WIN51.
Link to comment
Share on other sites

So a question for the developer:

Could you integrate an option, where everyone can specify the file that is checked for?

Because I use the WIN51 method, too. Just set the options default to wpi.ico, so that there are no probs with noobs, or just add it to the FAQ on the WPI HP.

Thx in advance.

Link to comment
Share on other sites

I think I was not correct.

I realize now that I hide a thing not with bad intention .

My WPI is in

%cdrom%\wpi\ , directory .

In the downloaded archive of wpi_3_5_1 ALL the files

are in the same directory including wpi.ico

so , wpi.ico is not by default in the root of cd/hdd_path

I move

wpi.ico+autorun.inf

from there in the parent directory

and I leave all other files there

because I want in the final CD to see wpi.ico as CD icon.

and use the autoinsert of windows_XP_32bits (now)

I change autorun.inf to point an \wpi\wpi.cmd not \wpi.cmd

so can be that bad for wpi_3_5_1 ??

can be this the cause of an extra path there ?

maybe no !?

I made the same move in 3_5 where

I did not find any trouble ?

Link to comment
Share on other sites

  • 2 weeks later...

Hello. I don't know if this is the right place where post a feature suggestion however here it is.

It often happens that some applications don't work/install under certain windows versions (for example some may install on windows xp and may not install on windows 2003).

What about adding a special dependancy expression to require a certain windows version?

Thanks in advance and sorry for my crappy english :P

Btw great work :P

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...