Jump to content

A New Cd-switching Utility

Recommended Posts

  • 1 month later...
  • 4 weeks later...
  • 2 weeks later...


I'm using Version as downloaded from page1.

I used the CD Switch Generator to create the switches to use within RunOnceEx.cmd, which is below

REG ADD %KEY%\130 /VE /D "Requesting CD2" /f
REG ADD %KEY%\130 /V 1 /D "%systemdrive%\install\misc\cdswitch.exe /g:Apps /r:autorun.inf /rw /b /k" /f

It does create a log file, just confirming the switches used and number of them, and that is it.

As you can see it runs from the C:\ drive and not CD-ROM.

Yes i have checked that the file exists, and yes Apps is label of CD, and autorun.inf is on root of CD.

Even running the most basic switch of cdswitch.exe /s /o D: from start | run when finished with CD1, as it continues straight to desktop, doesn't work.

Any thoughts on why it isn't working are appreciated, as i can't see what i'm doing wrong.

Thank you

Link to comment
Share on other sites

You'll have to excuse me, but I remember very little of the switches as I haven't worked on it for a while. :P

REG ADD %KEY%\130 /V 1 /D "%systemdrive%\install\misc\cdswitch.exe /g:Apps /r:autorun.inf /rw /b /k" /f

So, let's see here:


is correct, as it's running. *yay* :)


replace this by "Apps". The "/g:" is to detect a drive holding the disc with label "Apps".


the second parameter should be the drive you want to use. Check the help-file for different methods to do this: by drive letter, by drive number, by the disc inside (which holds a certain label or file).


Windows always takes the path you're currently "working" in , so it could be you're referring to the wrong path. I could be mistaken, but just to be save, use the *DRIVE*-parameter.

So therefor, try this line:

REG ADD %KEY%\130 /V 1 /D "%systemdrive%\install\misc\cdswitch.exe Apps D: /r:*DRIVE*\autorun.inf /rw /b /k" /f

Hope that helps, sorry if I explained it too complicated. XD

Edited by Nanaki
Link to comment
Share on other sites

  • 2 weeks later...

Via a quick scan of the code, I can only assume you're using CDswitch 0.9a, correct? The only cause I can think of is that no disc can be found.

Now, this could be CDswitch its fault (it's still "alpha" :)), but the quick tests I did worked.

Therefor, mind posting your RunOnceEx code you used to launch CDswitch? For now, you can always switch back to 0.8.4.

Link to comment
Share on other sites

this is the contents of the RunOnceEx.cmd :

cmdow @ /HID

@echo off

FOR %%i IN (D E F G H I J K L M N O P Q R S T U V W X Y Z) DO IF EXIST %%i:\2003.CD SET CDROM=%%i:

SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

FOR %%i IN (D E F G H I J K L M N O P Q R S T U V W X Y Z) DO IF EXIST %%i:\WPI.ico SET CDROM=%%i:

REG ADD %KEY%\0020 /VE /D "Switching to Applications CD..." /f

REG ADD %KEY%\0020 /V 1 /D "cdswitch \"Appz_CD\" %CDROM% /d /r:\"%CDROM%\WPI.cmd\"" /f


Thanks for the suggestion. im going to use the 0.8.4 version.

Link to comment
Share on other sites

i use this

%CDROM%\Apps\cdswitch.exe WINXP_2 /g:WINXP_1 /r:%CDROM%\Apps\WPI.cmd

when it during installation in vmware,.. the dialogue asking for the cd comes up but its all blank.. no image.. nothing on it ..just plain blan brown background

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...