Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Yet another Promise SATA/RAID problem


Recommended Posts

The hpt3xx driver was for another motherboard that I had problems with (BSOD). I got it working with this configuration also. The ulsata2 driver was actually needed on this motherboard when i hooked a drive to the VIA controller so windows xp would find the SCSI driver for the promise controller. Weird, huh? If i hook a drive to the promise controller it only shows this:

VIA SATA RAID Controller (viamraid.sys)

WinXP Promise SATA378 IDE Controller (ulsata.sys)

When I hook a drive to the VIA controller is shows three devices!!

VIA SATA RAID Controller (viamraid.sys)

WinXP Promise SATA378 IDE Controller (ulsata.sys)

Promise SATA Console SCSI Processor (ulsata2.sys)

I have messed with this problem for way too long so i really don't care why its working I'm just glad it is!!

One more thing: If i hook a drive to only the VIA controller and leave the ulsata2 driver out of my dvd, windows has a question mark for the promise controller. If i include ulsata2 windows finds everything on the frst try.

Link to comment
Share on other sites

  • 1 month later...

WinXP Promise SATA378 ™ IDE Controller (ulsata.sys)

is "PCI\VEN_105A&DEV_3373.DeviceDesc="WinXP Promise FastTrak 378 Controller" (FASTTX2K.inf) ?

it should use FASTTX2K.SYS not ulsata.sys.......

Link to comment
Share on other sites

  • 5 months later...

hey thius might be helpfull to all the people out there that are having problems finding the right drives to get your SATA378 working properly. try this site its got just what the doctor ordered to get you back in the action.. read all the option discriptions carefully to see the one for your SATA divise. http://support.asus.com/download/download_...ct=1&model=SK8V

Link to comment
Share on other sites

  • 10 months later...
After 5 weeks of working on the Promise Driver problem I have finally got it working flawlessly. I have an Asus A8V Deluxe Motherboard with the Promise 20378 SATA Controller on it as well as the VIA SATA controller. Using Bâshrat the Sneaky's Mass Storage Driver Pack the VIA would install everytime but the promise would always fail to detect. This is how i got it working no matter which controller that you attach the drives to. This solution is not perfect but it works for me!!

Here is my TXTSETUP.SIF Config


hpt3xx.sys = 1,,,,,,4_,4,1,,,1,4
ulsata.sys = 1,,,,,,4_,4,1,,,1,4
ulsata2.sys = 1,,,,,,4_,4,1,,,1,4
fasttrak.sys = 1,,,,,,4_,4,1,,,1,4
viapdsk.sys  = 1,,,,,,4_,4,1,,,1,4
viamraid.sys = 1,,,,,,4_,4,1,,,1,4


PCI\VEN_1103&DEV_0004 = "hpt3xx"
PCI\VEN_1103&DEV_0005 = "hpt3xx"
PCI\VEN_1103&DEV_0005&SUBSYS_100415BD = "hpt3xx"
PCI\VEN_1103&DEV_0006 = "hpt3xx"
PCI\VEN_105A&DEV_3373&SUBSYS_80F51043&REV_02 = "ulsata"
PCI\VEN_105A&DEV_3373&SUBSYS_80F51043 = "ulsata"
PCI\VEN_105A&DEV_3373&CC_010400 = "ulsata"
PCI\VEN_105A&DEV_3373&CC_0104 = "ulsata"
PCI\VEN_105A&DEV_3D75 = "ulsata2"
PCI\VEN_105A&DEV_3D18 = "ulsata2"
SCSI\ProcessorPromise_SATA_Console____ = "ulsata2"
PCI\VEN_105A&DEV_5275 = "fasttrak"
PCI\VEN_105A&DEV_7275 = "fasttrak"
PCI\VEN_1106&DEV_4149 = "viapdsk"
PCI\VEN_1106&DEV_3149 = "viamraid"
PCI\VEN_1106&DEV_3149&SUBSYS_80ED1043&REV_80 = "viamraid"
PCI\VEN_1106&DEV_3149&SUBSYS_80ED1043 = "viamraid"
PCI\VEN_1106&DEV_3149&CC_010400 = "viamraid"
PCI\VEN_1106&DEV_3149&CC_0104 = "viamraid"
PCI\VEN_1106&DEV_3164 = "viamraid"
PCI\VEN_1106&DEV_3249 = "viamraid"


hpt3xx = hpt3xx.sys,4
ulsata = ulsata.sys,4
ulsata2 = ulsata2.sys,4
fasttrak = fasttrak.sys,4
viapdsk = viapdsk.sys,4
viamraid = viamraid.sys,4


hpt3xx = "HighPoint HPT3xx ATA100 Controllers"
ulsata = "WinXP Promise SATA378 (tm) IDE Controller"
ulsata2 = "Promise SATA Console SCSI Processor"
fasttrak = "WinXP Promise MBFastTrak133 Lite (tm) Controller"
viapdsk = "VIA ATA/ATAPI Host Controller"
viamraid = "VIA Serial ATA RAID Controller"

I only have the ulsata and the ulsata2 drivers in the same folder. The problem all along was the promise drivers not playing nice with one another. I think the problem is actually the "fasttx2k" driver but i have not tested to see if this is the actual culprit. You can leave all of the drivers included in bashrats mass storage alone but i chose to remove the other promise drivers because i got tired of seing the BSOD! Hope this helps everyone having problems with Promise drivers!!

I've been working on this same problem for a few days now. Can you give more specific information on how the file structure for the CD works, and what guide you used to help set this up? When I attempt this myself I get "The file 'ulsata.sys' was not found". I tried using GreenMachine's guide modified with this information, which got me to this point.

Any added constructive comments or links would be much appreciated!

And the last few posts with links to the Asus website are broken :(

Link to comment
Share on other sites

I have an Asus K8V SE Deluxe with the promise pdc20378 and the via 6420 raid controlers.

I have had the drivers integrated into text mode for a long time now this is what I do.

My winnt.sif has



as well as





D\raid folder is located at on my CD root


In the D\raid folder I have both controler drivers files.


You must put the cabbed files

fasttx2k.sy_ and viamraid.sy_

in you i386 folder so they are copied in text mode.


fasttx2k.sys = 1,,,,,,3_,4,1
viamraid.sys = 1,,,,,,3_,4,1

PCI\VEN_105A&DEV_3376 = "fasttx2k"
PCI\VEN_105A&DEV_3373 = "fasttx2k"
PCI\VEN_1106&DEV_3149 = "viamraid"

fasttx2k = fasttx2k.sys, 4
viamraid = viamraid.sys, 4

fasttx2k = "Promise FastTrak 376/378 (tm) Controller"
viamraid = "Via VT8237 Sata Raid Controller"

You must put that before the sometimes invisible marker at the end of txtsetup.sif.

Note if you use nlite you must do this after nliting it. Everytime I did this before it would crash at install.


You should see the drives attached without using F6.

I hope this helps.


When I attempt this myself I get "The file 'ulsata.sys' was not found".

Did you have a cabbed version of it in your i386 folder?


Edited by jaws75
Link to comment
Share on other sites

Thank you for the information, and I had forgotten to cab the ulsata.sys file

Using the tips given it will now make it to the text mode portion of the install, and sees the single SATA drive connected.

The entire installation of windows goes through normally, and on the last reboot, that should go the desktop (or OOBE) for the first time, it restarts. Safe mode also restarts.

So I am back where I started it seems.

I am installing a single SATA drive, is it still possible to use the RAID driver, and set the controller to RAID mode, since it seems I'm getting nowhere with the SATA driver and IDE mode?


Changed over to RAID and used the fasttx2k driver, and still get the restarts on the initial boot to desktop after setup completes. :(

Edited by SynMonger
Link to comment
Share on other sites

  • 2 months later...
This has been covered time and time again. You can NOT load drivers from a floppy if you're using an unattended CD.

That's all well and good for you to say as a seasoned pro but that guy was a newbie at the time of writing/posting so obviously he wouldn't know that it had been covered time and time again - doh!

Please show some patience to newbies - thanx!


I think the Promise 378 drivers are currently not anymore in the DriverPack, because of incompatiblity issues. It will be added to the new rebuild, though!

I don't see these in the mass driver pack? :no:

[only: viaMraid]...


Edited by the_doc735
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...