Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
what3v3r

Win Server 2003 SP1 RC1

Recommended Posts

does anybody have any experience yet, in creating a multi boot dvd with win server2k3 SP1?

i know SP1 has only been out for a few hours but still!

i just tried to follow this guide: http://flyakite.msfnhosting.com/

but i encountered two problems.

1) when editing the setupldr.bin file and replacing the string "i386", it gives me the message "7 occurences replaced". is that ok?

2) when i boot from the DVD and try to start the installation, i get the error: "NTLDR is corrupt, the system cannot boot"

i did replace the old "boot"-folder with the new one, of course.

Share this post


Link to post
Share on other sites

yes its just a release candidate. but i couldnt resist trying it ;) i also dont think that they will change alot in the final version. from what i read it has pretty much all the improvements taht SP2 had for xp, plus active directory and other server specific improvements.

btw i dont know if this is important, but i didnt replace the boot sector file (the*.dat one). is there a new one out anyway?

Share this post


Link to post
Share on other sites

Seeing as it should take too long to change...

you could edit the setupldr.bin programatically.

Did you create the bootfolders as well?

Share this post


Link to post
Share on other sites
Seeing as it should take too long to change...

you could edit the setupldr.bin programatically.

Did you create the bootfolders as well?

yes i created the bootfolders from a slipstreamed version of win2k3 with sp1.

as for editing setupldr.bin programmatically - is there a guide on how to do that?

Share this post


Link to post
Share on other sites

Solution is as simple as could be - Don't re-edit your setupldr.bin! :P

I've been using the same setupldr.bin for WinXP, all the way from the gold (SP0) release, to SP1, to SP2 alphas/betas, and SP2 final - in other words, entire XP series used same setupldr.bin

Similar was the case with Win2k - I used same file for SP0, SP3 and SP4 (I was not knowing to slip-stream in the days of SP1/SP2 of win2k).

I haven't dl'ed the SP1RC for ws2k4 yet, so I can't say for sure about it.

Use the same old setupldr.bin (which worked for you) - it really can't have changed.

Share this post


Link to post
Share on other sites

hmm, but why would they have different file sizes then?

also the string "i386" was found 7 times in the new one, instead of 4 times as it was in the old one.

well, i will try it anyway, and replace the new one, with the old one. we'll see if it works, i'll let yo know!

Share this post


Link to post
Share on other sites

so far it actually seems to work! thx!

but im really wondering what improvements they made to this file that im missing out on now...?

Share this post


Link to post
Share on other sites

i now ran into a few more problems, with the unattended installation... :sigh:

after the installation finishes, and windows boots up for the first time i get the error :"at least one service or driver could not be loaded .... blablabla"

after the entries in the RunOnceEX.bat file have been entered into the registry, and windows boots up for the second time, i get the same error again.

plus windows fully loads the desktop, the start bar, the "manage your server wizard" and after all that it starts to execute the RunOnceEX entries.

but there is more!

during the installation of some programs, i get the error "fatal error in ntvdm" - "taskkill.exe could not be startet, because framedyn.dll was not found..." and a bunch of other error messages...

also the resolution remains at 640x480 (it should change to 1024x768 - thats what i entered in my winnt.sif), the manage your server wizard starts allthough i told it not to start in the winnt.sif file.

all that worked before. well, i guess i will have to wait until sp1 becomes final.

Share this post


Link to post
Share on other sites
Solution is as simple as could be - Don't re-edit your setupldr.bin! :P

I've been using the same setupldr.bin for WinXP, all the way from the gold (SP0) release, to SP1, to SP2 alphas/betas, and SP2 final - in other words, entire XP series used same setupldr.bin

Similar was the case with Win2k - I used same file for SP0, SP3 and SP4 (I was not knowing to slip-stream in the days of SP1/SP2 of win2k).

I haven't dl'ed the SP1RC for ws2k4 yet, so I can't say for sure about it.

Use the same old setupldr.bin (which worked for you) - it really can't have changed.

Thank you ! ;)

Works Great with SP1 RC2 and reducing size from gosh , thank you too man !

http://www.mobilepcmag.com/features/2005_0...0gadgets-2.html

I burnt 20 cds... :whistle:

Errors : Cannot boot : error code 5

NDLR corrupt

No problems with unattended install ... :thumbup

Share this post


Link to post
Share on other sites
Solution is as simple as could be - Don't re-edit your setupldr.bin! :P

I've been using the same setupldr.bin for WinXP, all the way from the gold (SP0) release, to SP1, to SP2 alphas/betas, and SP2 final - in other words, entire XP series used same setupldr.bin

Similar was the case with Win2k - I used same file for SP0, SP3 and SP4 (I was not knowing to slip-stream in the days of SP1/SP2 of win2k).

I haven't dl'ed the SP1RC for ws2k4 yet, so I can't say for sure about it.

Use the same old setupldr.bin (which worked for you) - it really can't have changed.

Strangely it works with the old setupldr.bin.

The files of the different versions of Windows 2000 and of Windows XP had always the same filesize and i think the same content.

The files of Windows 2003 with and without Service Pack 1 differs. Could someone check the different files and update the Windows 2003 section of the AIO DVD Guide? Perhaps the Bootsectors are also different?

I have attached the new unedited setupldr.bin of Windows 2003 Enterprise with SP1 FINAL integrated. I have taken it from the german version, but i don't think it matters.

greetings

FBi

setupldr_sp1.rar

Share this post


Link to post
Share on other sites

ive tried slipstreaming again, this time with the final version of sp1. but i got another error

i used the old setupldr.bin as suggested in this thread. and it also boots into text-mode setup but then i get the following error:

"setup didnt find any windows version to upgrade on your hard drive. setup needs to verify that you qualify to use this upgrade product, please insert Windows NT4 server cd into your cd rom drive blablabla..."

what caused this? i had this error some time ago, but forgot how i solved it.

Share this post


Link to post
Share on other sites

Have you copied the file "win51iX.SP1" to your AIO-DVD root ??

This could solve the problem.

greetings

FBi

Share this post


Link to post
Share on other sites

yes i did copy the file, but i think i found the cause of this error

stupid me!

i forgot to edit the setupsourcepath in the txtsetup.sif!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...