Jump to content

/integrate switch error/problem


 Share

Recommended Posts

Hi,

I've been reading up the forum for proper how-to install sp2 hotfixes. I found out I can integrate using the /integrate switch, but I've come up with a problem.

I have a sliptstreamed winxp+sp2 folder, located under C:\WinXP\XPCD. I tried to

C:\WinXP\XPCD\WindowsXP-KB885626-v2-x86-ptg.exe /integrate:C\WinXP\XPCD

It starts the extraction, but after some seconds it says "There has been a problem tryint to integrate this hotfix. verify that the arquitecture, idiom and service pack level of this hotfix is valid for this folder"

(Sorry for the bad translation, it's no english XP).

I get that error even thought I'm 100% this xpcd is portuguese, and also sure that the hotfix is portuguese (-ptg).

How can this be solved?

And btw: I got a strange number of folders after trying the integrate switch, even thought it doesn't work...

ASMS

COMPDATA (656 files)

DRW

LANG

svcpack (empty)

SYSTEM32 (NTDDLL.EXE and SMSS.EXE)

Any idea? Thanks!

Link to comment
Share on other sites


Hi,

I've been reading up the forum for proper how-to install sp2 hotfixes. I found out I can integrate using the /integrate switch, but I've come up with a problem.

I have a sliptstreamed winxp+sp2 folder, located under C:\WinXP\XPCD. I tried to

C:\WinXP\XPCD\WindowsXP-KB885626-v2-x86-ptg.exe /integrate:C\WinXP\XPCD

It starts the extraction, but after some seconds it says "There has been a problem tryint to integrate this hotfix. verify that the arquitecture, idiom and service pack level of this hotfix is valid for this folder"

(Sorry for the bad translation, it's no english XP).

I get that error even thought I'm 100% this xpcd is portuguese, and also sure that the hotfix is portuguese (-ptg).

How can this be solved?

And btw: I got a strange number of folders after trying the integrate switch, even thought it doesn't work...

ASMS

COMPDATA (656 files)

DRW

LANG

svcpack (empty)

SYSTEM32 (NTDDLL.EXE and SMSS.EXE)

Any idea? Thanks!

I am also Portuguese!

My Windows Xp is Portuguese too.

I tried the same command line as you did (wich i think is correct) and the same error came to me.

I noticed that the portuguese hotfixes have some Brazilian Portuguese inf files. So that may be the problem. Doesn´t Microsoft test this things?

Finally i gave this up and now i install the hotfixes the usual way.

Link to comment
Share on other sites

Maybe it doesn't work because you are trying to integrate the hotfix in the same location as it is saved in.

Try to integrate the hotfix from another location.

e.g:

C:\Hotfixes\WindowsXP-KB885626-v2-x86-ptg.exe /integrate:C\WinXP\XPCD

I have tried that too and the error persists.

Thanks anyway!

Link to comment
Share on other sites

Ah, ok! I've used that on my SP1 cd ...

From what I've heard, the new hotfixes don't need QCHAIN ?

Thanks for the replies...

EDIT: Should i keep:

MajorVersion=5
MinorVersion=1
BuildNumber=2600

..or change to anything else? (Note that I'm using SP2)!

EDIT2:

My original SP2 svcpack.inf had this:

CatalogSubDir="i386\hotfixes"

I changed it to

CatalogSubDir="\i386\CUpdates"

as it says on the instructions page..does it matter to have \i386\ or just i386\ ? Thanks

Link to comment
Share on other sites

I guess you'll have to do it the old fashion way... as described HERE

you'll see, it is quite simple... check the switch availble for the hotfixes, add the command to svcpack.inf and add a line to dosnet.inf (only once).

I have also tested that with SP2 and it didn´t work!

You can integrate the hotfixes manually. That is doing the same thing the command "/integrate:" does, but by yourself, wich is hard work, and dificult to keep up as new hotfixes are released!

I use this code at cmdlines.txt stage:

for %%i in (%systemdrive%\Install\01\Hotfixes\Hotfixes1\*.exe) do start /wait %%i /z /n /o /q
for %%i in (%systemdrive%\Install\01\Hotfixes\Hotfixes2\*.exe) do start /wait %%i /Q:A /R:N
for %%i in (%systemdrive%\Install\01\Hotfixes\Switchless\*.exe) do start /wait %%i

This way, as new hotfixes are released you just put them on the right folder, without the need to edit any files.

Link to comment
Share on other sites

My method sure works.

The same svcpack method used for SP1 does not work for SP2. At least for me it didn´t.

svcpack works for SP2, but you will have to move more files, i guess.

Don´t ask me how to make it work, because i don´t know.

Link to comment
Share on other sites

Since RyanVM just confirmed that the svcpack method works, and due to the fact that the thread was closed, I ask someone to confirm if QCHAIN.EXE is needed on SP2. I think I read somewhere it wasn't needed anymore..sorry for the pertinent question...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...