Jump to content

Need help to get drivers to work...


genmud
 Share

Recommended Posts

yea... I am having problems with a couple of drivers...

I am trying to get the optiplex gx270 drivers to work... http://support.dell.com/support/downloads/...d=4159&devlib=5

They just dont seem to want to work... I place the .sys files in the /i386/system32/drivers folder, and the INF files in the /i386/inf folder correct?

If you guys could tell me the way on both versions as I haven't made up my mind on what PE to use(barts, or Microsoft) because the software that i am using and creating will work on either :)

thanks,

James

Link to comment
Share on other sites


If it is a enterprise deployment I would go MS PE.

Also you didn't say where the .dll was being placed for the driver. Look in the OPK.chm in winpe 1.2, or winpe.chm in winpe 2004 for more info. Also check the pinned threads at the top they have a ton of useful info

Edited by likuidkewl
Link to comment
Share on other sites

If you guys could tell me the way on both versions as I haven't made up my mind on what PE to use(barts, or Microsoft) because the software that i am using and creating will work on either :)

There is a bartpe plugin, the inf is fairly simple though, and I believe it includes what you need.

source:

http://www.google.com/search?q=nforce+winp...:en-US:official

5th link down.

Drivers Included in Pack

Realtek RTL8150 USB, Realtek RTL8139/810x/8169/8110, Intel PRO/1000 Gigabit (8254x), Intel PRO/100b (8255x), nVidia nForce Ethernet, Broadcom 440x series, Broadcom NetXtreme (57xx and 59xx), 3com 3c99x, Netgear FA101 USB, 3Com Gigabit LOM (3C940/3C2000)

Link to comment
Share on other sites

I guess it helps when i read the manual :) hehe... I have been busy programming this **** thing, but it is cool... I'll show you guys what it looks like when i get done ;)

We are an enterprise type deal, but it is an educational institute(school district)

I am just sick and tired of using those crappy ghost disks, and we dont buy floppy drives anymore, so we would tote around a floppy and crack the case each time a floppy didn't work :( So ima make a Automated Image Deployment/Technology Tools CD for speeding up this XP deployment)

it is gonna be pretty cool if i say so myself.

Adding or Removing Network Drivers

By default, all network drivers on the Windows XP Professional CD or Windows XP 64-Bit Edition are supported. When you create your own WinPE image, you can add or remove the network drivers or replace the network driver list. By keeping the set of drivers to a minimum, you reduce the time required for Plug and Play detection.

To add network drivers to a custom WinPE CD, copy these files as specified:

All network driver *.inf files to the \%WINDIR%\inf directory.

All *.sys files to the \%WINDIR%\system32\drivers directory.

Any related *.dll, .exe, or other files to the \%WINDIR%\system32 directory.

Catalog files are unnecessary, as they are not processed by the WinPE environment.

Link to comment
Share on other sites

I actually think that I am going to be using regular microsofts WinPE... I am currently using windows pe 1.2... Should I update to 2004? Is there that big of differences?

But yea... i just got some awesome stuff going for the WindowsPE... I made a folder with inf, drivers, system32 and software where it will automatically add it to the iso when i makeimg :) wheee... Fun stuff.

Link to comment
Share on other sites

look @ the bottom, and there is a link to ghost32.exe which(correct me if I am wrong) is illegal to distribute without a license... because that is the full program for ghost on windowsPE

Link Removed... I just search for "nforce winpe" on google and found the 5th link down contained the drivers you needed. Sorry I didn't read the whole site, I figured you had tried looking on google, but I thought maybe I'd have better luck :) Might want to edit your post if you're concerned.

*wink*

Link to comment
Share on other sites

WinPE 2004 rocks. Microsoft took care of a few issues in it (such as the lmhosts service not loading with Factory.exe -- which kept you from getting to \\my.server.share.com\sharepoint from net use).

They also included a kick-butt little utility that you can use to integrate drivers properly rather than just dropping the files in and praying that they work. (DRVINST.EXE)..

Support for WMI, the windows firewall, and PnP (but boot up is slow as molasses when you enable PnP.)

All in all, I'm really happy with 2004 \ 1.5 :)

Link to comment
Share on other sites

  • 4 weeks later...

I have tried to use DRVINST.EXE to install intel pro 1000 drivers into a WinPE 2004 image to use over RIS because i currently recieve the error. "The operating system image you selected does not contain the necessary drivers for your network adapter."

When I go to run the DRVINST.EXE with what i assume is the correct syntax I get an Access is denied message..The syntax i am using is "DRVINST.exe /inf<c:\intel> [/inject]c:\newpe\"

where intel is the location of the pro 1000 adapter's inf and driver files and newpe is the location of my winpe 2004 build.

i have check the attributes and folder security to all files and folders and it doesnt look like it should have any denied access...

another problem i had with the download from microsoft licensing was the winpe.chm was corrupted so i do not even have a working help file...if anyone would have the help file from winpe 2004 that would be great.

thanks in advance...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...