Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


TEXTMODE MassStorageDrivers Method

Recommended Posts

[quote name='rcordorica' date='Sep 22 2004, 10:48 AM']update:

I added the drivers into the %OEM%\$$\OemDir directory and everything installed perfectly using the method i posted before. No more errors about missing files.[/quote]
Good job!!!

P.S.: I think I'll use this method in DriverPack MassStorage! :P

Share this post

Link to post
Share on other sites

@rcordorica: woah...hint, hint, hint to me? Did you get my email? I am looking to update the guide but I was hoping you could help me create/debug a utility I have been writing. If you didn't get my email: Congrats on moving the TEXTMODE method to the next level. My email is shown in my signature, drop me a line.

Share this post

Link to post
Share on other sites
oh, i haven't gotten any email from you. I've just moved into my college and it's been my first two weeks there. Sorry, my parents probably intercepted the email, i'll have to dig it up somewhere.

btw, i didn't mean for you, but maybe one of the mod's could stick the topic; seeing how there are a lot of people out there who try this method, but without a really good guide as this one. I owe my success to the method you laid out.

Share this post

Link to post
Share on other sites
alright, i just found the email.... I'd be happy to test it out for you. Right now I am visiting home (until sunday) and I have access to the 3112. But the 3112 is already fixed in Bashrat's driverpack, so I don't know if that is necessary now.

At college I have access to the 3114 and NVRAID which Bashrat's driverpack doesn't work with. So those are good canidates.

If it's a simple script, or java language I might be able to help somewhat. Sorry about that message, i meant no offense by it.

Share this post

Link to post
Share on other sites
@rcordorica: no offense taken at all, the guide really needs to be updated. As far as a sticky goes thats bashrat's department. Hopefully if we can get this program to work, M2 will be extremely easy to use for a wide range of people.

We can discuss more about the code via email or PM, I'm hoping to draw on your expertise in validating the output of the program (ie. does it make the correct directories?, copy the correct files?, and write the correct winnt.sif/textsetup.oem entries?). I'm debugging something for work right now so I may not have a chance to get it to you for a couple of days though...

Share this post

Link to post
Share on other sites
i just checked the Nlite forum, and guess what... Nuhi has started working on a driver integration (textmode method). He already has a beta program for it thats works in some instances (although I don't believe he has tested it all the way, like trying to actually reinstall a system; because if done incorrectly, then there will be problems, like the GUI errors). anyways, i'll email/pm you when i get the chance.

Share this post

Link to post
Share on other sites
Ok, as I have mentioned in other threads, I have a Chaintech 7NJS Zenith, which will also use the MSI drivers, much the same as other boards, the MSI ones are just better.

I have done all kinds of different ways of doing these drivers, (including but not limited to putting the driver entries into the Txtsetup.sif file, which is what I am trying to avoid here, even it does not work that way.) Now from what I have gathered from reading M$ own documents, you have to put your files in a couple places:
[code]$OEM$\Textmode\ (copy all files here from driver folder, remove them from any WinXP folder, but not subfolders within the WinXP folder, you will need those in your textmode folder, (replace folder name for your O/S.))
ie: $OEM$\Textmode\raidtool is fine but $OEM$\Textmode\WinXP\raidtool isn't.
$OEM$\Inf (copy *.inf files here)
$OEM$\$$\System32\ (copy any other files here not listed elsewhere from Textmode folder, such as *.exe, *.nvu, etc.)
$OEM$\$$\System32\dllcache (make hidden and copy *.dll files in here)
$OEM$\$$\System32\Drivers (copy *.sys files here)
Remove any *.txt files as they shouldn't be needed especially readme's.[/code]
Now make sure you dont include any internal folders from your driver set. For example if your download includes a WinXP folder pull out the files from that folder and put them all into your Textmode folder, your going to edit your Txtsetup.oem file to make it work correctly. If you have a Disk1 file without an extension, or a disk1.tag file, or something to that sort, make sure it's in the Textmode folder. Now place your Txtsetup.oem file there as well, then open it cause you need to make sure it reads similar to:[code];textsetup.oem
;includes settings for NVRaid, NVATA, as well as Promise Fasttrak 376 from MSI.
;For NTFS use (WinNT32.sif):
   d1 = "NVIDIA RAID DRIVER (SCSI)",\disk1,\Textmode\
;For Fat use (WinNT.sif):
   d2 = "NVIDIA RAID DRIVER (SCSI)",\disk1,.\Textmode\
   d3 = "Promise FastTrak 376/378 Driver Diskette",\fasttx2k,\Textmode\
   d4 = "Promise FastTrak 376/378 Driver Diskette",\fasttx2k,.\Textmode\
   d5 = "Promise SATA378 Driver Diskette", \ulsata,\Textmode\
   d6 = "Promise SATA378 Driver Diskette", \ulsata,.\Textmode\
   scsi = RAIDCLASS
   scsi = FastTrak_TX2K_xp
    BUSDRV = "NVIDIA NForce Storage Controller (required)"
    UlSata_xp   = "WinXP Promise SATA378 (tm) Controller", UlSata
    FastTrak_TX2K_xp   = "WinXP Promise FastTrak 376/378 (tm) Controller", fasttx2k
    driver  = d1,nvraid.sys,RAIDCLASS
    inf     = d1,nvraid.inf
    dll     = d1,nvraidco.dll
    catalog = d1,nvraid.cat
    driver  = d2,nvraid.sys,RAIDCLASS
    inf     = d2,nvraid.inf
    dll     = d2,nvraidco.dll
    catalog = d2,nvraid.cat
    driver = d1,nvatabus.sys,BUSDRV
    inf    = d1, nvatabus.inf
    dll    = d1,idecoi.dll
    catalog = d1, nvata.cat
    driver = d2,nvatabus.sys,BUSDRV
    inf    = d2, nvatabus.inf
    dll    = d2,idecoi.dll
    catalog = d2, nvata.cat
    driver = d3, fasttx2k.sys, fasttx2k
    dll    = d3, ptipbmf.dll
    inf    = d3, fasttx2k.inf
    catalog= d3, fasttx2k.cat
    driver = d4, fasttx2k.sys, fasttx2k
    dll    = d4, ptipbmf.dll
    inf    = d4, fasttx2k.inf
    catalog= d4, fasttx2k.cat
    driver = d5, UlSata.sys, UlSata
    dll    = d5, ptipbm.dll
    inf    = d5, UlSata.inf
    catalog= d5, UlSata.cat
    driver = d6, UlSata.sys, UlSata
    dll    = d6, ptipbm.dll
    inf    = d6, UlSata.inf
    catalog= d6, UlSata.cat
   value = "", Tag, REG_DWORD, 1
   value = "", Tag, REG_DWORD, 1
   id = "GenNvRaidDisk","nvraid"
   id = "*_NVRAIDBUS","nvraid"
   id = "PCI\VEN_10DE&DEV_008E", "nvatabus"
   id = "PCI\VEN_10DE&DEV_0085", "nvatabus"
   id = "PCI\VEN_10DE&DEV_00D5", "nvatabus"
   id = "PCI\VEN_10DE&DEV_00EE", "nvatabus"
   id = "PCI\VEN_10DE&DEV_00E3", "nvatabus"
   id = "PCI\VEN_10DE&DEV_00E5", "nvatabus"
   id = "PCI\VEN_10DE&DEV_0035", "nvatabus"
   id = "PCI\VEN_10DE&DEV_0036", "nvatabus"
   id = "PCI\VEN_10DE&DEV_003E", "nvatabus"
   id = "PCI\VEN_10DE&DEV_0053", "nvatabus"
   id = "PCI\VEN_10DE&DEV_0054", "nvatabus"
   id = "PCI\VEN_10DE&DEV_0055", "nvatabus"
   id="PCI\VEN_105A&DEV_3376", "fasttx2k"
   id="PCI\VEN_105A&DEV_3373", "fasttx2k"
   id = "PCI\VEN_105A&DEV_3373","UlSata"[/code]Now make sure in your WinNT.sif file you have:[code];SetupMgrTag
;Only need OemPnPDriversPath, if you have PNP Drivers set up to install, if you want to have the stuff you copy to the hard drive using the $OEM$ folder, you can place that in i386 and make the above path: ".\i386\$OEM$\" without the quotes, and when the O/S is done installing it's supposed to remove the folders for you, though not even that way worked when trying to install these drivers.
;In case later I need to change settings for different computer, can be several different settings, FullyUnattended is most used in forum, others are DefaultHide (default setting), GuiAttended, and ReadOnly.

...Only Neccessary lines listed here...

   "NVIDIA NForce Storage Controller (required)"=OEM
   "WinXP   Promise SATA378 (tm) Controller"=OEM
   "WinXP   Promise FastTrak 376/378 (tm) Controller"=OEM
   "IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller"=RETAIL
I have also figured out that you need to set up all your drivers, other files, and anything else your adding to your UXPCD prior to doing your WinNT.sif file from SetupManager, this will give you all the $Restore$ files you will need to make and in them it will automatically rename all the files and paths that you will need to go back and rename so they will be recognized on the CD. Once you have opened each of those files and noted what names in the folder they are in need changing and change those names, you are ready to burn your CD, if you do not do this step, Windows XP will miss a lot of the files, or your CD writer program will attempt to rename them incorrectly, prior to burning the files. (Roxio version 6 was severly bad about doing this, even with a regular WinXP disk, after you already clicked the "Burn" button, and if you cancelled it wouldn't let you burn the disk. If you didn't change the names and add the $Restore$ file with the names inserted in them in the proper folders, XP wouldn't find them later!)

Now according to M$'s obscure instructions on this, under Windows XP, it should work, but to this point I keep getting that dreaded error 18 in line 1747 error, which is driving me up the friggen wall... I should also mention that I have tested these drivers and they work perfectly when using them through F-6, although the only one which loads is the Fasttrak at this point. The NForce, I have never tried to do prior to loading the operating system before, but the fasttrak should be the one which takes as it's necessary for the SATA drives to be recognized with my motherboard. Alas, to my dismay, none of these drivers either take nor will work when trying to do this through unattended. Yes, I have tried every way mentioned so far in these threads, but I still haven't gotten them to work.

Share this post

Link to post
Share on other sites
I've considered using this method: [url="http://www.msfn.org/board/index.php?showtopic=10877&hl=Pure+Chrome"]XP Basic CD Unattended SATA/RAID Install , How to avoid hitting F6 for CD Install. [/url], but I don't particualarly want it set up this way as I need for the entire CD to be there for other computers I may use this on. All I want is to be able to slipstream the mass storage drivers and have them work when installing to my other system. I have even tried using that method and sort of integrating it into the regular UXPCD that I am trying to make, but that doesn't work either. I am about to give up on getting these things to work correctly, and just hope that my floppy drives will hold up until M$ gets off their a$$es and does away with the floppy drive altogether for installations, and fixes their unattended files.

Share this post

Link to post
Share on other sites
Hey, you don't need the floppy.
I dumped it long ago.

You can use Bashrat the Sneaky's driver-packs, to slipstream the mass storage drivers. Or, atleast the instructions there would be helpful for your purpose. Or you can use nLite.

Share this post

Link to post
Share on other sites
I've tried using Bâshrat the Sneaky's driver packs, the problem lies in the the included Realtek drivers that are included with it, (so I don't use them because they are incompatible with my system,) as well as his instructions I have tried, only to recieve an error that it's either looking for some line 1787 in txtsetup.oem, or it will give an error that the drives cannot be found, either way it's not working. So I give up on that as well.

I have tried it all kinds of different ways and still am not able to get the drivers to work. From what I have read there are basically 4 different methods, I have tried them all and all variations of those directions and still cannot get them to work.

Well the one where you run the installer and grab the two files and incorporate them then put the drivers in three different places, modifing the txtsetup.oem files for each place differently, but I need the entire cd, not just what is copied over, so I haven't tried that way.

Nothing seems to be working correctly, not sure if I am having syntax errors, or what. Yes, I use drivers for another motherboard, but the ones for my motherboard are the same drivers, just the one I use are newer versions and are better.

As far as using nLite, I attempted using it but unfortunately I couldn't get it to work correctly, so I gave up, besides I wanted to be able to do this by hand so I know what everything is and where it's putting it, so I can make customizations if needed, either now or in the future.

I should probably mention both my system's spec's as well as the fact that I am trying to use XP Pro SP-2 to do this on.

System contains:[code]Chaintech 7NJS Zenith motherboard (P.O.S. I know but I still use it none the less, waiting till next year to upgrade to 64-bit.)
XP 2100+ (both o/c'd to 2600+ and non-o/c'd)
1GB PC 3200 Kingston HyperX 512MBx2 matched, running at 5-2-2-2-1@1.7v (min volts on 7NJS, wont go lower.)
also tried 512MB of PC 2700 Crucial retail memory, using std settings. (Original purchased memory that Crucial reports works with the board, el-cheapo version, but otherwise good memory, only replaced to be able to o/c the 2100+, also running at 1.7volts, 5-2-2-2-1 settings.)  Doesn't seem to be memory related.
2-Hitachi Deskstar 7K250 120GB Sata drives in raid 0, using SATA power cables.  (No problems reported by any utilities provided by Hitachi, tried even just one drive at a time, but they are normally used as a raid 0.  In fact they were still working just fine prior to reinstalling, where I attempted to do this upgrade.  They are accessble just fine when not using the unattended, but F-6 way of installing the drivers.)
Plextor 708-A/SW-BL, (even used old HP branded DVD Rom and CD-RW to install but they gave up the ghost, so replaced them with the trusty Plexy, which works on both systems the one I am on now is different in it's using an Asus A7N266-VM/AA with a XP 1700+ no o/c's with 512 MB of Crucial PC 2700 memory, (yes I have two matched sticks of this memory as well.)  I replaced the Plexy in this one which is used in the other one now with a Optorite DD-0405 and WD1000JB and 1600JB hdds  Also only uses on-board audio/video, no cards, lan is reached via Linksys WUSB-11.  Power provided by PC P&C TC-510-ATX.  Case is old HP Pavilion xt963.  Yes it all fits but it's tight, cooling is standard air cooling provided by AMD and HP.)
Creative Audigy 2 Platinum
ATI AIW 9000 Pro
Linksys WMP-11 for networking
Antec TruePower 550.
Case is Lian-Li PC-82COM
Cooling via 5 Lian-Li fans and a CoolerMaster Aero 7+[/code]
I should also mention this: [url="http://support.microsoft.com/default.aspx?scid=kb;en-us;816299"]HOW TO: Create an Unattended Installation of Third-Party Mass Storage Drivers in Windows Server 2003[/url]
(*NOTE*- *From above HOW TO* - This procedure cannot be used in conjunction with a Winnt.sif file when starting up from a CD for installation, should be kept in mind when reading, and could also apply to XP w-w/o SP-1 or 2, though I'm not sure, becuase the 2K one, (mentioned in the article,) is what is said to work in both 2K and XP, but there is not a specific entry for XP and there is no reference in the 2K article that mentions this note, neither of them mention XP.)

If anyone can find XP specific instructions please report back, as I have searched the M$ website and cannot find it. Edited by DisabledTrucker

Share this post

Link to post
Share on other sites
I went through this whole process and actually thought I got it to work....but I get this error during the initial setup:

Windows XP Professional Setup

The manufacturer provided file that Setup is trying
to use is corrupted or invalid:

Illegal or missing file types specified in section Files.SCSI.Si3112r_XP.

Setup cannot continue. To quit Setup, press F3.


This is right after setup says "Loading Windows..."

I check my TxtSetup.oem and everything looks right to me. I'm going to paste the beginning of my file to see if you guys can see any issues. I am assuming that this is where my problem is.

[quote]; This file installs the SiI 3x12 SATARaid driver as part of text
; mode setup on Windows NT, Windows 2000, Windows XP, and Windows Server 2003.
; Copyright © 2002-2004 by Silicon Image, Inc.
; All rights reserved

[Disks]disk1 = "Silicon Image SiI 3x12 SATARaid Driver Installation Disk",\Si3112r.sys, \

SCSI = Si3112r_XP

[SCSI]                  ; HwComponent section
Si3112r_XP = "Silicon Image SiI 3x12 SATARaid Controller for Windows XP/Server 2003", Si3112r
Si3112r_NT = "Silicon Image SiI 3x12 SATARaid Controller for Windows NT 4.0 and 2000"

driver = disk1,si3112r.sys, Si3112r
driver = disk1,SiWinAcc.sys, SiFilter
inf = disk1,Si3112r.inf
dll = disk1,SilSupp.cpl
catalog = disk1, Si3112r.cat

driver = disk1,si3112r.sys, Si3112r
inf = disk1,Si3112r.inf
dll = disk1,SilSupp.cpl
;;catalog = disk1, Si3112r.cat[/quote]

Also, here is a screenshot of one of my directories with my drivers to show what files I have there:


Any help is appreciated.

Share this post

Link to post
Share on other sites
@The Accuser: Can you provide us with your winnt.sif and a complete directory structure. The directory you have shown has no relevance to this method. The guide on the first page is now updated and should indicate the proper folders. Also you may want to try RASOR and see if it works for you. You should remove any changes you made to your XPCD for the driver first (delete directories & remove winnt.sif entries). But then this *should* slipstream your drivers up for you. You can see the RASOR thread [url="http://www.msfn.org/board/index.php?showtopic=30231"]here[/url]. If RASOR does or does not work for you, please post your results in that thread.

Share this post

Link to post
Share on other sites
@TheAccuser - i see that you have a "dll" entry in your txtsetup.oem. That might be the cause of your problem. Read the updated guide for help.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...