Jump to content

TEXTMODE MassStorageDrivers Method


Recommended Posts

[b]FINALLY! w00t w00t[/b].

Now I can get on with creating the rest of the install. w00t w00t

Well it was the driver. After trying from the original XP cd & getting the same message asking for the floppy I nearly gave up.

As a last ditch effort instead of using the XP driver ( I only want it to pick up the array at bootup) I chose to use the win2k driver.

It booted all the way to seeing the array. I haven't gone any further but I believe the problem is solved. I'll try going all the way in a day or two.

I've only done it using nlite but can't see any issues when I go with textmode.

I should be able to slim down that driver folder file as I go now.

Thanx again trainee for helping me thru. I would have chucked the towel in long ago. Cheers!
Link to comment
Share on other sites

Yes! I'm glad you got it to work. I remember that feeling the first time I got my 3wares working. I really dont understand why the xp drivers dont work but the 2000 drivers do but now that you have something working slimming down is much easier.

Your hard work paid off; congrats.

@cdob: thanks, glad to help. Can I ask which drivers you have working?
Link to comment
Share on other sites


I've few hardware only.
[quote name='txtsetup.oem'][Disks]
d1 = "Mass Storage Drivers", \TXTSETUP.OEM, ""

;48 bit LBA
scsi = Ultra

Ultra = "Promise ULTRA Controller"
iaStor = "Intel SATA Controller"
viaraid_multiple = "VIA RAID Controller"[/quote]
Link to comment
Share on other sites

Hi everyone i tried to use this method but it didn t work here is what i did step by step
I created 2 folders ( $TEXTMODE$ ) one under $OEM$ and another under I386
so now i have

I copied all my sata driver to both directories
then modified winnt.sip here is what i added

"iaAHCI_ICH7R = "Intel® 82801GR/GH SATA AHCI Controller (Desktop ICH7R/DH)" = "OEM"


and here is some other winnt.sif infos


so can anyone tell me what s wrong in the installation ?
I attached also a copy of txtsetup.oem ( btw i modified the file extension to .txt to i could upload it here )

Thanx in advance Edited by TheCrowX
Link to comment
Share on other sites


[MassStorageDrivers] has to match the description in txtsetup.oem.
That's not the hole line. Remove iaAHCI_ICH7R.

"Intel(R) 82801GR/GH SATA RAID Controller (Desktop ICH7R/DH)" = "OEM"[/code]

Or try[code][MassStorageDrivers]
"Intel SATA RAID Controller" = "OEM"
"Intel SATA AHCI Controller" = "OEM"[/code]

[code]; ****************************************************************************
; ****************************************************************************
; ** Filename: TxtSetup.OEM
; ****************************************************************************
; ****************************************************************************

disk1 = "Intel Matrix Storage Manager driver", iaStor.sys, \

scsi = iaStor

;----------- Component Section -----------

iaStor = "Intel SATA RAID Controller"
iaAHCI = "Intel SATA AHCI Controller"


driver = disk1, iaStor.sys, iaStor
inf = disk1, iaStor.inf
catalog = disk1, iaStor.cat

driver = disk1, iaStor.sys, iaStor
inf = disk1, iaAHCI.inf
catalog = disk1, iaAHCI.cat


value = "", tag, REG_DWORD, 1b
value = "", ErrorControl, REG_DWORD, 1
value = "", Group, REG_SZ, "SCSI miniport"
value = "", Start, REG_DWORD, 0
value = "", Type, REG_DWORD, 1


id = "PCI\VEN_8086&DEV_27C3&CC_0104","iaStor"
id = "PCI\VEN_8086&DEV_2652&CC_0104","iaStor"
id = "PCI\VEN_8086&DEV_24DF&CC_0104","iaStor"
id = "PCI\VEN_8086&DEV_25B0&CC_0104","iaStor"
;id = "PCI\VEN_8086&CC_0104","iaStor"

id = "PCI\VEN_8086&DEV_27C1&CC_0106","iaStor"
id = "PCI\VEN_8086&DEV_2652&CC_0106","iaStor"
id = "PCI\VEN_8086&DEV_2653&CC_0106","iaStor"
;id = "PCI\VEN_8086&CC_0106","iaStor"[/code]
Link to comment
Share on other sites

Thanx cdob for the answer
well i used this
"Intel® 82801GR/GH SATA RAID Controller (Desktop ICH7R/DH)" = "OEM"
and still doesn t work i wasted like 6cds until now
I foud this on intel site too
but still doesn t work the strange thing on this methode is that
iaAHCI = "Intel SATA AHCI Controller" doesn t exsist in textsetup.oem
i even have IAAHCI.CAT, IAAHCI.INF, IASTOR.CAT, IASTOR.INF, IASTOR.SYS, and TXTSETUP.OEM copied over three folders which are

and again here is what is in winnt.sif
"Intel® 82801GR SATA AHCI Controller" = "OEM"


i used a newer version of the sata files here is the file again
Any other suggestion ? :(

Thanx in advance

Link to comment
Share on other sites

Crow, I'm just getting into this $OEM$ integration also. I was interested in getting this done because I'm also using HFSLIP. Then I ran into Fernando1's various conversations about force-fitting difficult NVidia RAID drivers, and he mentioned a program called Windows Unattended CD Creator. It was developed by his friend, Vitali Graf. Go to: [url="http://www.vitaligraf.de/en/index.htm"]http://www.vitaligraf.de/en/index.htm[/url]

I haven't used all of the features of the CD Creator, but I can tell you that it worked great integrating those Intel iaStor drivers. It also integrated (in PnP mode) the IntelINF drivers perfectly.

The nice thing about this program as it will interest you is that it applies TEXTMODE drivers in the traditional $OEM$ manner.

You may want to give it a shot. Vitaly is German, but you can setup the program for English, and he has an English forum. If you give it a go, let me know how it works out for you. Edited by PVU
Link to comment
Share on other sites

hi PVU i m sure that that method will work i got my sata drivers slipstreamed using nlite too but i want to do it with this methode cuz it doesn t Change any file i ll give that software a try
BUT i m still interested in this textmode methode

Link to comment
Share on other sites


There are reliable CD-RW.

Winnt.sif and txtsetup.oem has to contain the same string.

You may edit txtsetup.oem.
A edited txtsetup.oem may contain 'iaAHCI = "Intel SATA AHCI Controller"'.

ISO9660 directroy name has to be $OEM$, not _OEM_.
ISO9660 names has to be uppercased: $OEM$, WINNT.SIF, TXTSETUP.OEM
Run ISOBuster and compare.

Does your hardware use ID PCI\VEN_8086&DEV_27C3 ?
Link to comment
Share on other sites

I need help peeps.

I've got a new Dell 5150c, with the ICH7R (AHCI) sata controller. Several people here have this same controller onboard and must be facing the same problem I am. Of course the XP setup doesn't recognize any hard drive because of this controller. I've read through every post on this thread, and I've done everything right as far as I can tell but setup STILL does not see the controller and thus no hard drive.

I have a multiboot cd environment, so keep that in mind.

I've got txtsetup.oem and the iaStor.sys, iastor.inf, iastor.cat, iaahci.inf, and iaahci.cat files in the following folders:


my winnt.sif file has the following relevant entries:

"Intel® 82801GR/GH SATA RAID Controller (Desktop ICH7R/DH)"
"Intel® 82801GR/GH SATA AHCI Controller (Desktop ICH7R/DH)"
"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"


For good measure, I've copied the iastor.sys file (uncompressed) to the PRO1 folder, as well as the i386 folder. Still not working. What am I doing wrong? Or what am I missing? BTW: in case it matters, I've got a 250GB sata drive hooked up which Dell suggests may be the problem and they said to try changing a BIOS setting on the SATA portion to Combination mode rather than normal mode. I haven't tried that just yet but my feeling is that it is the driver support above that is causing my problem.

Any help is appreciated. Thanks
Link to comment
Share on other sites

Okay, I realized I had left off the critical = "OEM" part within the WINNT.SIF for the [MassStorageDrivers] section.

I've fixed that and now during the initial part of setup (before it would let you partition drives), I get an error immediately after loading the iaStor.sys file that says

Section Files.SCSI.iaStor_ICH7R of the INF file is invalid
Link to comment
Share on other sites

  • 2 months later...
  • 1 year later...

This worked absolutely great!!! All I did was use the exact WINNT.SIF file in the very first post (substituting my data for the "XXXX" fields, of course). Here was the situation I overcame:

We send out server appliances to all our clients and use them to provide remote DBA admin/monitoring services for the client's servers. I recently painstakingly built up a Ghost image to use on these servers that includes a 3Ware 8006-2LP SATA RAID card to provide a RAID 1 mirror for the XP Pro OS we install. We had been using 1U servers that had an Intel® Server Board SE7520BD2 motherboard. I built the original Ghost image by using a scratch manual install from CD with a Floppy to "F6" the 3ware drivers at the beginning. No big deal and I didn't care about unattended because I only had to build up one box from scratch and then Ghost would do the grunt work for all the rest. Well...

We just got our next batch of servers, and lo and behold, our HW vendor has switched our motherboards to Intel® Server Board S5000VSA motherboards. So now my Ghost image is no good due to the changed underlying hardware and there is not only no floppy drive in the new servers, but NO FLOPPY CONTROLLER either!

I tried to slipstream the driver into an XP Pro SP2 CD image using nlite's "Add Driver" (which looks like it just crams it down as compressed files in two places under i386?), but that didn't work. Then I found this thread and simply used the exact WINNT.SIF file and burned another CD (with the drivers tossed into the $OEM$\TEXTMODE\ and I386\$OEM$\ directories). I didn't even care about unattended, I just wanted to get XP loaded somehow, some way, on my 3Ware array sitting on a floppyless mobo! Well now I've killed two birds with one stone, because I have a sweet unattended install CD that includes my 3Ware drivers. I can even use the same CD if the motherboard changes again. I probably only understand about 70% of how this works too, but that's fine with me!

Thank you very, very, much!

Link to comment
Share on other sites

  • 1 month later...

Hi there,

I want to build an installation of xp from my USB-Stick. (It will be handled on my Mainboard as a harddisk ...)

In cause I'm using a RAID0 set on my PC, I want to integrate the RAID Drivers (nForce 4) into the Installation.

Now I want to try the Textmode-Method, but I have a little problem, because I also want to integrate the SATA Driver (Silicon Image).

I read in the deploy.chm that I'm able to add multiple instances, but -naturally- this is not documented by Ms.

Could anybody give me an answer how to do it ?

My problem is: I have two txtsetup.oem files -one for the nvraid(RAID) and one for the sil3132(SATA)- and

I don't know what to do now.

Must I add the entries of the one txtsetup.oem to the other txtsetup.oem or am I able to create Subfolders and

set the path in the [OEMBootFiles]-Section to the txtsetup.oem's ?

Or is it better to install the Silicon Image SATA Driver over the OemPnPDriversPath.

I don't need the Silicon Image Driver at Boot-up, just the nvraid/nvatabus Drivers !


"NVIDIA nForce Storage Controller (required)"=OEM
"Silicon Image SiI 3132 SATALink Controller for Windows XP/Server 2003"=OEM



You can see that I renamed the TxtSet(up).exe in the moment, so don't wonder - it's just temporary renamed til I found a solution ...



Edit: Sorry for this Spam, I found the answer in this thread ... :blushing:

Edited by Greenhorn
Link to comment
Share on other sites

  • 11 months later...

EDIT: here is my previous post

Does this method override txtsetup.sif?

I only ask because I noted that you have to include the line

"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"

to prevent the system from being unable to find the boot device (this is a reference to a device also found in txtsetup.sif). I have already added drivers using driverpacks for mass storage devices, I am just wondering if I need to reference these drivers again in [MassStorageDrivers] or only the above line of code in order to take advantage of mass storage drivers from both places (i will be using my installation disk on a variety of hardware and am aiming for the maximum compatibility)

For reference, this method does override txtsetup.sif, or rather, it overrides where it looks in that file. I placed a different raid controller in my test system which worked before I defined a [MassStorageDrivers] section or [OemBootFiles] section in my winnt.sif and it was unable to find the drive during the installation.

Previously, I had added entries to winnt.sif under the IDE cdrom one as such:

"Adaptec AHA-294X/AHA-394X/AIC-78XX SCSI Controller" = "RETAIL"
"Adaptec AHA-294XU2/AIC-7890 SCSI Controller" = "RETAIL"
"Adaptec RAID Storport Driver" = "RETAIL"
"Agilent HHBA-510x PCI Fibre Channel Controller" = "RETAIL"
"Compaq Drive Array" = "RETAIL"
"Compaq Fibre Channel Host Controller" = "RETAIL"
"Smart Array 53xx/63xx Controller" = "RETAIL"
"Emulex Scsiport Fibre Channel Host Adapters" = "RETAIL"

with the same names listed in txtsetup.sif. However, with something like 50 or so drivers to list, or some other factor I may be unaware of, the presence of all of those devices in [massstoragedevices] prevented it from detecting the controller I was trying to add to the install:

"AMCC 3ware 7000/8000 Series ATA RAID Controller" = "OEM"

As listed previously in this thread, this is the only method that works with this controller.

I think it may be possible to get past this by referencing txtsetup.sif in the oembootfiles section, but I'm not sure if that would work.

Edited by penpen
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...