Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Windows 2000 on a Z490 based machine


Recommended Posts

2k-bmp.png

 

I recently built a new pc based on intel's z490 platform with an i7-10700k, and wanted to see how well 2k would work on it. This is the result.

Functional:
AHCI
USB3
Non-Functional
LAN
Audio (didn't test much so it might work)
ACPI
Hyperthreading

Edited by rob9980
  • Upvote 3
Link to post
Share on other sites

Posted (edited)

2k-png.png

Got USB3 to work with PAE under a new driver. Also screwed with the audio driver some more, it's fine now as well.

Edited by rob9980
  • Like 1
  • Upvote 1
Link to post
Share on other sites
  • 4 weeks later...
5 minutes ago, tyukok said:

Neat! Where did you get patched ACPI? I tried to install on a Z370, got a 0x00000000A5 error.

Device Manager indicates that he used the MPS Multiprocessor HAL, which doesn't use ACPI. I just tried that HAL on X58 (which also works fine with ACPI) and confirmed that it does kill hyperthreading, along with Enhanced Intel SpeedStep.

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...